SERVER PXE DIFERENT SERVER DHCP



  • Hello

    I´m trying install server PXE with fog into the net, but I don´t know what is the code correctly that I have to write in the dhcp.conf of the dhcp server. I working with Ubuntu in both servers:(

    I had added this code, but it isn´t running:

    <quote>
    subnet 192.168.1.0 netmask 255.255.255.0 {
    range 192.168.1.70 192.168.1.100;
    filename “pxelinux.0”;
    next-server 192.168.1.50;
    option subnet-mask 255.255.255.0;
    option broadcast-address 192.168.1.255;
    option routers 192.168.1.1;
    </quote>

    I can access fron the PC´s of the net.
    Can yu help me?
    Thanks



  • Solution to FOG in other DHCP server, using IPcop. It works with version 2.0.8 of IPCOP, in the latest version 2.1.8 does not work, track down.
    Edit in IPcop 2.0.8: /var/ipcop/dhcp/dnsmasq.local
    Add:
    ###############################################
    enable-tftp
    tftp-root=/tftpboot
    dhcp-boot=tag:!IPXEBOOT,undionly.kpxe,fog,10.0.0.5
    ###############################################
    Explanation of concepts;
    ##undionly.kpxe=boot file
    ##fog=Sever name
    ##10.0.0.5=IP
    @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
    By testing found the solution, just the line must be removed;
    tftp-root = / tftpboot

    So that would be this way;
    Edit in IPcop 2.1.5 & 2.1.8: /var/ipcop/dhcp/dnsmasq.local
    ############################################
    enable-tftp
    dhcp-boot=tag:!IPXEBOOT,undionly.kpxe,fog,10.0.0.5
    ############################################

    Tested on IPCop 2.1.8 and 2.1.5 versions.



  • This post is deleted!


  • This post is deleted!


  • This post is deleted!


  • This post is deleted!


  • ]--------Original Configuration-----------------

    add by racl[

    subnet 192.168.212.0 netmask 255.255.255.0{
    option routers 192.168.212.1;
    option subnet-mask 255.255.255.0;
    option domain-name-servers 80.58.61.250, 80.58.61.254;
    range 192.168.212.8 192.168.212.254;

    ----------Configuración with external Server PXE -----------------

    add by racl

    subnet 192.168.212.0 netmask 255.255.255.0{
    option routers 192.168.212.1;
    option subnet-mask 255.255.255.0;
    option domain-name-servers 80.58.61.250, 80.58.61.254;
    range 192.168.212.8 192.168.212.254;[

    #configuracion pxe fog

    filename “pxelinux.0”;
    next-server 192.168.212.5;


  • Developer

    [url]https://help.ubuntu.com/community/PXEInstallServer[/url]

    Specifically the configure dhcp section.

    If you have an existing dhcp server, you should point it to your pxe server by doing something like the following
    [CODE]subnet 192.168.0.0 netmask 255.255.255.0 {
    <other config here>
    filename “pxelinux.0”;
    next-server <pxe host>;
    }[/CODE]

    Be sure to restart your dhcp server so that the changes take effect
    [CODE]sudo /etc/init.d/dhcp3-server restart[/CODE]



  • I´m using fog 0.32


  • Developer

    Are you using fog .32 or .33?

    .33 ues undionly.kpxe not pxelinux.0

    Also this may help:
    [url]http://www.fogproject.org/wiki/index.php/Integrating_FOG_into_an_Existing_Network_in_non_intrusive_mode[/url]


Log in to reply
 

384
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.