Unable to access the FOG URL(remote user interface)



  • I just installed FOG on a Ubuntu system using the following article.

    [url]http://www.fogproject.org/wiki/index.php/FOG_on_an_Isolated_Network[/url]

    After the install, it said this.
    You still need to install/update your database schema.
    This can be done by opening a web browser and going to:

      [url]http://192.168.1.5/fog/management[/url]
    
      Default User:
             Username: fog
             Password: password
    

    I am unable to access [url]http://192.168.1.5/fog/management[/url]. I can’t access the FOG RUI at all. I was able to boot a computer on the network to FOG using PXE so I know that part is working.

    I do have a password setup for the root user but during the install for MySQL, I just pressed enter and left the password blank. I also tried editng the config.php files with my root password but that doesn’t work either.

    Can someone tell me where I went wrong here? I am close.

    Thanks,

    Justin



  • Thank you for the replies.

    Since I already have the latest version installed. I will just try that quick. If it works, great. If not, then i’ll go back to version 13.

    Justin


  • Senior Developer

    There is also a wiki for 14.04.


  • Developer

    [quote=“JustinGSEIWI, post: 25780, member: 23733”]I installed Ubuntu 14.04 LTS 64-bit. I just ran the two commands you sent me. I will now try to install FOG and let you know if the same issues occurs.

    Thanks,

    Justin[/quote]

    My recommendation, [B]don’t[/B]. 14.04 was just recently released, you may be biting off more than you can chew. I haven’t even tested 14.04 to it’s fullest capabilites with FOG yet, so, I advise you to use 13.10 or something older. There have been changes to apache2 in 14.04, the folder that is now doing the serving is in /var/www/html instead of /var/www like it has been previously, the fix for this is simple, but I am not sure 9as I have not tested) what else may be broken or may not be functioning without adjustments.

    If you are dead set on installing FOG on Ubuntu 14.04… download the fog zip file, decompress and follow the installation instructions. After it tells you that the install was a success and the installer asks you to perform the schema update, insert the following command

    [code]
    sudo ln -s /var/www/fog var/www/html/fog
    [/code]

    Now you may proceed with updating the schema at the url.


  • Moderator

    Did you see the thread about Ubuntu 14.04 and the changes to the apache2 documents directory changing from /var/www to /var/www/html



  • I installed Ubuntu 14.04 LTS 64-bit. I just ran the two commands you sent me. I will now try to install FOG and let you know if the same issues occurs.

    Thanks,

    Justin


  • Moderator

    which version of Ubuntu, and did you make sure to update the system before you run the FOG installer? (sudo apt-get update, sudo apt-get upgrade)


  • Developer

    This post is deleted!


  • Thanks for the reply but I am already reinstalling. It should not be this hard so something must of went wrong. I’ll let you know if I still have this issue after reinstalling.

    Thanks,

    Justin


  • Senior Developer

    [code]tail -100f /var/log/apache2/error.log[/code]

    Keep the terminal running.

    Try accessing the page:
    192.168.1.5/fog

    Does it try to redirect you to: 192.1.68.1.5/fog/commons/index.php?redir=1 ?



  • I used a different IP address then the default they recommended. I am also connected to a router on my home network but that should have nothing to do with locally connecting to the fog console right? I am unable to access it even if I disconnect all network connections. I know I have the IP right since I get the “It works!” page.



  • This is a fresh install of Ubuntu as well. When I installed, I created an IT user that has a password. That is separate from the root which I enabled after the install. When I tried to enter the commands you put above, I was always asked to enter the IT password even though I am logged on as root. Could that of had to do with anything?



  • No, I was never able to access the page. I followed the install direction in the link above. I am not sure where I went wrong.


  • Developer

    Did you ever get a page to show up on 192.168.1.5/fog/, even if it just said “Click here to upgrade database”?



  • I entered that command and it said it started but still can’t access the FOG console.



  • Yes that is the entire /var/log/apache2/error.log.


  • Developer

    Can you make sure the mysql service is running?

    “sudo /etc/init.d/mysql start”



  • They are the entire log. I’ll check again to make sure but I did control A to select all.


  • Developer

    Are those the last 14 lines of the log or the first 14?

    The newest are at the bottom, not the top.



  • Here is the log.

    [Fri Apr 18 14:25:13.511142 2014] [mpm_event:notice] [pid 4870:tid 139646723962752] AH00489: Apache/2.4.7 (Ubuntu) configured – resuming normal operations
    [Fri Apr 18 14:25:13.511530 2014] [core:notice] [pid 4870:tid 139646723962752] AH00094: Command line: ‘/usr/sbin/apache2’
    [Fri Apr 18 14:25:42.931251 2014] [mpm_event:notice] [pid 4870:tid 139646723962752] AH00491: caught SIGTERM, shutting down
    [Fri Apr 18 14:25:44.042911 2014] [mpm_prefork:notice] [pid 6508] AH00163: Apache/2.4.7 (Ubuntu) configured – resuming normal operations
    [Fri Apr 18 14:25:44.043258 2014] [core:notice] [pid 6508] AH00094: Command line: ‘/usr/sbin/apache2’
    [Fri Apr 18 14:25:45.439808 2014] [mpm_prefork:notice] [pid 6508] AH00169: caught SIGTERM, shutting down
    [Fri Apr 18 14:25:46.623359 2014] [mpm_prefork:notice] [pid 6584] AH00163: Apache/2.4.7 (Ubuntu) PHP/5.5.9-1ubuntu4 configured – resuming normal operations
    [Fri Apr 18 14:25:46.623446 2014] [core:notice] [pid 6584] AH00094: Command line: ‘/usr/sbin/apache2’
    [Fri Apr 18 14:35:01.775039 2014] [mpm_prefork:notice] [pid 6584] AH00169: caught SIGTERM, shutting down
    [Fri Apr 18 14:35:02.955554 2014] [mpm_prefork:notice] [pid 21073] AH00163: Apache/2.4.7 (Ubuntu) PHP/5.5.9-1ubuntu4 configured – resuming normal operations
    [Fri Apr 18 14:35:02.955644 2014] [core:notice] [pid 21073] AH00094: Command line: ‘/usr/sbin/apache2’
    [Fri Apr 18 15:00:07.577513 2014] [mpm_prefork:notice] [pid 21073] AH00169: caught SIGTERM, shutting down
    [Fri Apr 18 15:01:01.189676 2014] [mpm_prefork:notice] [pid 1914] AH00163: Apache/2.4.7 (Ubuntu) PHP/5.5.9-1ubuntu4 configured – resuming normal operations
    [Fri Apr 18 15:01:01.224231 2014] [core:notice] [pid 1914] AH00094: Command line: ‘/usr/sbin/apache2’


Log in to reply
 

398
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.