FOG image upload through fogweb ui stuck on queue



  • Hello all,

    It’s my first time using fog.
    Heard many things about it and I am now trying it out in a virtualbox enviorment.
    To see and experience its wonders.

    Everything seemed to go right…
    Installation>configuration etc.

    But now when I added the virtual client to the host list and perform a upload image task and force it to start.
    It status stays queued without any progression or any files in the /images/dev folder.

    I googled a bit, followed many steps but I just can’t seem to figure it out.
    There’s no dhcp and no Dns.

    static IP and noted mac addresses.

    Some said, the image proces is running but due the lack of a DNS there isn’t any viewable proces.

    Others told me it had to do with the folder permissions on the /image/dev folders.
    Which is chmoded according to the found steppes.

    Everything seems to be right…

    But I’m just stuck now…

    Do I really have to setup a Dns ? or domein…
    Or am I missing a conf ?

    Please help! :)


  • Developer

    No fog can use its own storage, in my experience I have always used a DHCP server to dole ip addresses, I have never successfully used a static network. I set fog at a static ip address so it never changes, and you can set your machines at static ip addresses, but in my experience pxe booting, something needs to be giving addresses for the machines to have during the boot process.

    If you are not interested in using a DHCP server, look into the dnsmasq option and server proxy ip addresses for the pxe boot process only.

    IMHO I think it a better idea to use DHCP and just reserve your addresses to a MAC, but to each his own.



  • COuld it be, because of I didn’t create storage node on a different machine ?



  • Well I’m not using any DHCP or DNS services.

    All static.
    And the server’s IP is defined in all records.
    It does navigate to my server “192.168.56.101 255.255.255.0” from my client “192.168.56.102 255.255.255.0”

    with following error I mentioned in my 2nd post.

    And yes the tftpd-hpa service has been a problem for many people but even after stopping and starting the services or using a restart script, nothing changes.

    Does FOG need a DHCP & a DNS ?


  • Senior Developer

    Did you specify the boot server information?

    DNS may need to be set, but it can be your internal network address rather than a REAL dns server.

    By specify the boot server information, I mean, as you’re not using FOG as the dhcp server, you have to tell your network were to look for the information.

    This can be done through next-server line if your DHCP server is a linux machine,

    Or if your DHCP server is a Windows System:
    specify options 66 and 67 of your relevant subnet (or all as the case may be)

    Option 66 should be set to the IP of your FOG server

    Option 67 should be set to pxelinux.0

    You also may need to restart the tftpd-hpa service on the FOG Server as 12.04 has a known issue where it tries to start tftp BEFORE the network is even available.



  • I’m using fog version 0.32

    On a virtualbox machine running ubuntu 12.04 LTS as Os.

    No I haven’t done that before, but when doing so it comes with a error telling me Nothing to boot no such file or directory.


  • Senior Developer

    FOG is a spectacularly useful tool, when configured properly. However, I think perhaps we need to know more information.

    First, what OS is the FOG Server running?

    Second, what version of FOG are you using? (e.g. 0.32, 0.33b, 0.27, etc…)

    When you scheduled the task to be performed, did you reboot the Client to send or download the image so it pxe boots?


Log in to reply
 

427
Online

38938
Users

10697
Topics

101491
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.