Errory deploying images



  • Hello I am trying to set up fog however when I try to deploy an image to one of my machines it does not work. The machine is a custom build and it uses these parts [url]http://pcpartpicker.com/p/2GcEg[/url].
    the machine will boot into pxe and then hang (see image 1)
    then it will proceed to the point found in Image 2.
    after that it will go and act as if it is deploying an image however no image is deployed on the machine.
    I have tried a few kernels however none of them have worked.
    The machine has been set to legacy boot, secure boot disabled and the hard drive has been set to IDE.
    I have no issues with my other machine just this one.

    Any help would be appraciated

    Thank you

    [url="/_imported_xf_attachments/0/661_Fog Image1.png?:"]Fog Image1.png[/url][url="/_imported_xf_attachments/0/662_Fog Image2.png?:"]Fog Image2.png[/url]



  • Hello,
    So after changing the sata operation mode from to Raid it seems to be proceeding with the deploy process. I am sorry I did not try this before I just figured that fog would work with IDE or ACHI mode both which i had tried earlier.

    Thank you both of you for you help with this issue. although I am still confused why raid mode would work while ide does not.


  • Developer

    What chipset is on the motherboard the SSD does not work with?



  • I am not sure if this changes anything however I tried the SSD in a different machine that is working and I was able to successfully deploy a image onto that drive.

    As far as driver needs I do not know where to get this info if you give me an idea I can let you know.

    Thank you for all the help you have provided as of now.


  • Senior Developer

    Can you get me the exact driver needs for this SSD? I know you gave info, but I need a little more.

    I’ll build it when I get home.



  • Hello BPSTravis,

    I tried following the instructions given to creating a kernel however when I get to the step to extract I get an error.
    stdin: not in gzip format

    I am new to using linux so any help in getting past this would be great.

    Thank you



  • thank you I will give this a try.


  • Developer

    Sounds like you will need to build a kernel for the machine so it recognizes the SSD.

    For that you will need to find the actual driver for the SSD and include it in the kernel.

    [url]http://fogproject.org/wiki/index.php?title=Building_a_Custom_Kernel[/url]



  • Hello Tom,

    One more updated. As I was browsing the forums I found the mention of checking your hardware to ensure that it is compatible with Fog and My NIC passes however the hard drive fails. I tried both IDE and ACHI mode for the hard drive and both seem to fail.
    [URL=‘http://pcpartpicker.com/part/samsung-internal-hard-drive-mz7pd128z’][FONT=Trebuchet MS][COLOR=#006699][SIZE=12px]Samsung 840 Pro Series 128GB 2.5" Solid State Disk[/SIZE][/COLOR][/FONT][/URL] is the only hard drive that is the machine.

    What can I do to possible get this working for this machine? or what other info would you need to better help figure out the issue?

    Thank you



  • Hello Tom,

    An update for my issue I have another machine that has the same error as above however that machine does go through with the image process and loads the image.
    If it helps the image I am currently trying to load is windows 8 x86 which was uploaded as Multiply Partition - All Disks.
    Also I forgot to mention I am using Fog .32.

    If you need any more information please let me know.

    Thank you



  • Hello Tom

    I tried the newer kernel and now I have a new message that it hangs on.
    “esas2r: driver will not be loaded because no ATT0 esas2r devices were found i2c-parport-ligh: adapter type unspecified”

    I am getting no other error messages from this now. The machine after hanging at this point for a while will go to the fog stage .

    I ran deploy in debug mode and Image4 is what I get after running the fog command.
    the machine still does not have an os installed after the machine reboots.

    Thank you

    [url="/_imported_xf_attachments/0/664_Fog Image4.png?:"]Fog Image4.png[/url]


  • Senior Developer

    Read the link in my signature.


Log in to reply
 

407
Online

38955
Users

10706
Topics

101576
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.