Realtek 8153 USB Network Adapter



  • I have a Realtek 8153 based USB network adapter and Fog will not work with it. I can download the driver but I do not know how to compile it into a linux kernel.



  • For what it’s worth, if it’s stuck on the black screen + “ipxe initialising devices”, undionly.kkpxe works. Our HP 4520s have the Realtek NICs which have this issue.

    x-post here: https://forums.fogproject.org/topic/2807/ipxe-boot-issue-with-realtek-rtl8153/18


  • Moderator

    @Jason-Kovacs It’s likely that your laptop model is either UEFI only, or has UEFI support turned on and BIOS/Legacy support turned off.

    If you can, take a peek around in the firmware settings and see what you find.

    If it’s a UEFI only system, you will have to switch the boot file you’re using to a .efi file. If you can turn UEFI off and enable BIOS/Legacy, then you can continue with undionly.kkpxe


  • Senior Developer

    Do you, possibly, have STP enabled on your network? This isn’t necessarily bad, but it is a known problem as the time constraints for STP are a bit…slower than ipxe is expecting. If you do have STP and don’t need it, please disable it. If you need STP is there anyway you can enable the Rapid/PortFast options for STP?



  • I am having a slightly different issue with this same adapter on a Dell Latitude 7350. It will connect to the FOG server and start to boot the iPXE environment, and then says “Configuring” and the MAC address. It then reboots before it loads the FOG menu. We have FOG 1.2.0 and are using undionly.kkpxe(using undionly.kpxe the computer would not connect at all).


  • Developer

    [quote=“Chadd, post: 43760, member: 28977”]Any updates on this? I’ve also been unable to get this going with Yoga S1’s and the same usb adapter, I’ve tried with a bunch of different kernels and no go. I’ve tried with the flag enabled which hasn’t made a difference :( I’ve attached a screenshot of the issue I’m having. If I just wait it ends up saying that there’s no network connection…[ATTACH]1781[/ATTACH][/quote]
    From what I can see on that picture I’d say that iPXE is not an issue. Comes up and loads kernel and initrd. The kernel does not recognize the usb adapter I suppose. Which kernels have you tried?



  • Black screen after it says ipxe initializing device :(


  • Senior Developer

    Try the ipxe.pxe file.



  • Upgraded to 3111.

    With undionly.kpxe It just sits at “ipxe initialising devices” The other undionly’s just immediately go to a black screen.

    Anything else I can try?

    Thanks


  • Senior Developer

    Upgrade to svn please.



  • Any updates on this? I’ve also been unable to get this going with Yoga S1’s and the same usb adapter, I’ve tried with a bunch of different kernels and no go. I’ve tried with the flag enabled which hasn’t made a difference :( I’ve attached a screenshot of the issue I’m having. If I just wait it ends up saying that there’s no network connection…[ATTACH]1781[/ATTACH]

    [url="/_imported_xf_attachments/1/1781_20150312_073558_resized_2.jpg?:"]20150312_073558_resized_2.jpg[/url]


  • Senior Developer

    Have you tried with the has usb nic flag enabled?



  • sadly, no change



  • Thank you Tom for the information. I just installed (Feb 10, 2015) version 1.2.0 on Ubuntu 12.0.4.5 desktop. Traditional older clients are not having any problems. I did install the latest “Published Version” kernel yesterday, 3.14.2. I have now just installed your latest “unofficial” 3.18.4.
    I’ll try it out.


  • Senior Developer

    [quote=“rmackinnon, post: 42145, member: 22613”]@Jeff Turley,
    Did you get any resolution with this? We have just invested in the S1 Yogas with OneLink Pro docks and cannot get it connect to FOG[/quote]

    To my knowledge. 3.18 kernels have this issue figured out.

    Also, even if they didn’t for a bit, we narrowed what the problem was. It was NOT the kernel not having the drivers. That part actually worked perfectly. It was the kernel trying to reload a device that wasn’t released properly. A fix in the Development version(s) of fog was to add has_usb_nic=1 to the kernel arguments of the hosts this relates to. It would allow you to pause, disconnect the device and replug it back in. Then things seemed to work.

    That said, reading your post you’re talking about Docks. I don’t know what’s different for them. But may try a newer kernel?



  • @Jeff Turley,
    Did you get any resolution with this? We have just invested in the S1 Yogas with OneLink Pro docks and cannot get it connect to FOG



  • I am working on an L440 and got the same error using the onboard NIC. I just went in and disabled the 3.0 usb slot in the bios and it goes right to the registration/imaging screen.

    Not perfect but at least it will help you get them done.


  • Senior Developer

    They’ll probably have a release in a couple of days. So I’ll keep you posted, I don’t have the device to test with either though, so I’m just shooting in the dark. You could try a different configuration file as well. You don’t have to try mine. I don’t know where the isuse is. It looks, to me, simply like it can’t attach the device on that port, maybe another one? Do you have another USB NIC you could try?



  • Thanks for the help. Not sure where I am going to go from here. i need to have 250 of these computers imaged my the end of may.


  • Senior Developer

    The pxe boot, itself, works perfectly fine.

    It’s the kernel loading afterward that it can’t find the driver. My guess is the kernel driver’s just got a bug in it at the moment.


Log in to reply
 

387
Online

38981
Users

10712
Topics

101676
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.