• Hi there,

    I’m relatively new to Fog so I’m hoping someone can help me out here…
    I have an existing Fog server, running on Ubuntu Server. Works great. But now I want to move it onto its own separate network to reduce traffic, etc.
    Ideally I’d like to have it completely isolated on its own network, with no internet connection. Just a Fog server and a switch and a bunch of clients for reimaging purposes only.
    Previously the Fog server relied on one of our Windows 2003 servers to handle DHCP, DNS, etc. Now I need to reconfigure the Fog server to do this.
    When I try to rerun the installfog.sh in the installation directory (/opt/fog/bin), the script shows my current settings and asks me if I wish to continue. But there’s no option to modify the settings. There must be some way to rerun the script to adjust the DHCP/DNS/Using Fog DHCP settings, but I’m stuck finding it.

    Meanwhile, as a test, I edited /etc/network/interfaces and /etc/resolv.conf to update the settings to point to a separate network and it sort of worked. The clients boot up (using a spare Windows DHCP server I had) and I get the Fog PXE menu to show. However when I go to register the hosts, they all report an error message that they can’t register due to the following error: (blank)

    So I switched things back to the way they were for now so I could use it, but I really would like to have it on its own network…I’m assuming I’m missing some steps, another file that needs to be edited.

    How do I rerun the installfog.sh to modify the settings? Does Fog need an internet connection once it’s set up?

    Thanks for any help,

  • No can do, I really needed to get it going so I opted to redo my base Ubuntu install and start over. Everything’s working as expected now. Now the only thing I need to do is transfer over the rest of my images.

  • Developer

    [quote=“SirTimbit, post: 1235, member: 447”]It tries to connect then reports “Failed to connect to DefaultMember.” [/quote]

    is the firewall enabled??
    Please upload a screenshot.

  • Got a bit closer now…I made a backup copy of the .fogsettings file, deleted the existing one, and reran the installsh script. Then I could re-enter the settings and now I’m almost back in business. The only thing I’m trying to figure out is Fog will not display the Disk information window status. It tries to connect then reports “Failed to connect to DefaultMember.” I’m thinking there is still some DNS issue however Firefox can get out onto the web just fine, Fog displays the kernal updates just fine, and shows the estimated number of Fog sites and current version status. I changed all the settings I could find referring to the old IP address of the Fog server in the Fog settings menu, but still get that message. More hunting…

  • Developer

    OK. When you deploy an image, FOG create a PXE file in /tftpboot/pxelinux.cfg. The filename is =01-XX-XX-XX-XX-XX-XX, where XX-XX-XX-XX-XX-XX is the MAC address of the PC. The file is like this:

    [CODE]# Created by FOG Imaging System,
    DEFAULT fog
    LABEL fog
    kernel fog/kernel/bzImage
    append initrd=fog/images/init.gz root=/dev/ram0 rw ramdisk_size=127000 ip=dhcp dns=
    type=down img=aula-sc-carlos-santamaria-lab-idiomas-tmm mc=yes port=63162 storageip=158.xxx.yyy.zzz storage=158.xxx.yyy.zzz:/images/ mac=xx:xx:xx:xx:xx:xx ftp
    =158.xxx.yyy.zzz web=158.xxx.yyy.zzz/fog/ osid=1 imgType=n shutdown= loglevel=4 fdrive= chkdsk=0 hostname=U008298

    FOG uses this file to obtain the configuration variables. Let’s go to see:
    [][B]type[/B]=down. This is the tasks type, a download task.
    ][B]img[/B]=aula-sc-carlos-santamaria-lab-idiomas-tmm. This is the image name.
    [][B]mc[/B]=yes. This tasks is a multicast task.
    ][B]port[/B]=63162. This is the port of the multicast task.
    [][B]storageip[/B]=158.xxx.yyy.zzz. IP of the storage node.
    ][B]storage[/B]=158.xxx.yyy.zzz:/images/. The path where the image is.
    [][B]mac[/B]=xx:xx:xx:xx:xx:xx. The mac of the client.
    ][B]ftp[/B]=158.xxx.yyy.zzz. IP of the storage
    [][B]web[/B]=158.xxx.yyy.zzz/fog/. The path of web interface. FOG uses it to know where the webservices are.
    ][B]osid[/B]=1. Type of OS.
    [][B]imgType[/B]=n. Image Type.
    ][B]hostname[/B]=U008298. PC Hostname.
    This PXE file is setup by FOG when you make click in the web interface. To setup it, FOG uses some parameters, those parameters are in the databese “fog”, in the table globalsettings. You can also see them in the interface web “about it” -> FOG settings. Check them. I’m sure that your problem is there.

  • Thanks Fernando,

    Found the file and edited, as well as updated the IP address in Fog System settings. I also updated the PXE menu.

    I’m much closer now but still no go. The clients PXE boot, Fog lets them register, but at the end of the registration process when I tell Fog to image the clients, they reboot and conk out at "Mounting NFS fileystem…can’t find (old ip address). Somewhere in there it’s still referring to the old IP address of the Fog server. Is there some other file where the IP address of the Fog server would be stored?

  • Developer

    If you make a reinstall of FOG, the installer search the /opt/fog/.fogsettings to see the server configuration. Please, see it and change the file configuration with the new parameters.