Router DHCP setup

  • I’ve recently installed FOG .32 on Ubuntu v10.04.4 32-bit running in a VirtualBox VM on Windows 7. I have a LAN with a Peplink Balance 20 router providing DHCP and other services, so I didn’t use FOG’s built-in DHCP service.

    Reading the FOG docs led me to believe I would need to configure DHCP extensions 66 (TFTP server name) and 67 (boot file name). I did so, specifying my FOG server’s IP (‘’) and ‘pxelinux.0’, respectively.

    But that didn’t work – none of my network PCs found or would boot from the FOG server.

    What DID work was using DHCP extensions 160 (BOOTP next server), 161 (BOOTP server name), and 162 (BOOTP boot file), which I set, respectively, to ‘’, ‘FOGHAT’, and ‘pxelinux.0’. Voila! My network PCs booted into the FOG menu!

    As always, your mileage may vary… but this configuration works for my particular LAN.

    Here is a screenshot of the router’s DHCP settings:



  • [quote=“Jaymes Driver, post: 25101, member: 3582”]Thanks for letting us know which option numbers to use on this hardware![/quote]
    You’re very welcome!

  • Developer

    Thanks for letting us know which option numbers to use on this hardware!

Log in to reply





Looks like your connection to FOG Project was lost, please wait while we try to reconnect.