FOG 0.32 on Ubuntu 10.04.4 LTS Desktop 32bit - tftp works on host, but no where else



  • Hello, all. Would like to see FOG for myself, but haven’t had any luck getting a working installation. I’m using a VirtualBox v4.3.10 VM for testing.This is my fourth attempt; previously I’ve tried installing version 0.32 on

    1. Ubuntu 12.04.4 LTS Desktop x64: ran into the problem of the tftpd-hpd daemon starting too soon and none of the suggestions here fixed the problem.

    2. Ubuntu 8.10 Desktop x64: apache2 package failed during installation.

    3. Fedora 20 Desktop x64: php-gettext package failed check during installation.

    …using these settings:

    Distro: Ubuntu (or Fedora in one case)
    Installation Type: Normal Server
    Server IP Address: 192.168.1.16
    DHCP router Address: 192.168.1.1
    DHCP DNS Address: 192.168.1.1
    Interface: eth0
    Using FOG DHCP: 0
    Internationalization: 0

    My fourth attempt is w/ Ubuntu 10.04.4 LTS Desktop x32. As in all previous installs, I installed the OS and set up a static IP of 192.168.1.16. I then applied all available updates, after which I took a snapshot of the VM and installed FOG.

    All went well and I was able to browse to the FOG admin web page to update the database and then access the standard FOG admin page.

    A quick test of tftp in a terminal window on the host showed that the tftp daemon seemed to be working:

    tftp -v 192.168.1.16 -c get pxelinux.0
    Connected to 192.168.1.16 (192.168.1.16) , port 69
    Getting from 192.168.1.16:pxelinux.0 to pxelinux.0 [netascii]
    Received 16967 bytes in 0.0 seconds [9681598 bit/s]

    However, tftp fails from my Windows 7 workstation, though I can ping the host successfully.

    I’m a linux newb and at this point I’m stumped. Any ideas?


  • Developer

    Not a problem I knew it had to be a windows something. I use Windows XP to host my virtual software, I don’t face this problem ;)



  • Further research shows that the Windows 7 firewall is blocking my Win7 TFTP client from connecting to the FOG server. Doooh!

    Who would have thought that Microsoft, in all of their infinite wisdom, wouldn’t modify their firewall to allow their own TFTP client to actually work? :-)

    Thanks, everyone, for helping me to figure this out. It seems the FOG server is functioning correctly and I can now move on to configuring my router.



  • [quote=“Jaymes Driver, post: 25073, member: 3582”]Can you use the command on other windows machines, not the one hosting the vm?[/quote]

    Bingo! I CAN successfully download pxelinux.0 using tftp on a different Windows PC!

    Thanks!

    Now… why can’t I do the same on the FOG VM host workstation? Odd…


  • Developer

    Can you use the command on other windows machines, not the one hosting the vm?



  • [quote=“Jaymes Driver, post: 25071, member: 3582”]What kind of switch gear is between your fog server and your windows server, if you put them on the same switch are you able to use the get command?[/quote]

    The fog server runs in a VirtualBox VM on my Win7 workstation; its ethernet adapter is bridged to the workstation’s nic. I can ping the fog server VM from the workstation and vice versa, and I can ping other PCs on my network from the fog server VM.

    FWIW, my workstation is attached to a Netgear GS108T switch.


  • Developer

    What kind of switch gear is between your fog server and your windows server, if you put them on the same switch are you able to use the get command?



  • Some screenshots to help(?)
    [ATTACH=full]641[/ATTACH][ATTACH=full]642[/ATTACH]

    [url="/_imported_xf_attachments/0/641_fog-server-1.jpg?:"]fog-server-1.jpg[/url][url="/_imported_xf_attachments/0/642_fog-win7-tftp-fails-1.jpg?:"]fog-win7-tftp-fails-1.jpg[/url]



  • [quote=“Tom Elliott, post: 25038, member: 7271”]Are you certain the tftp-hpa service is actually running:

    [code]sudo service tftpd-hpa status
    sudo service tftpd-hpa restart[/code][/quote]

    Yes, it’s running. The result of the status command is:

    tpdtd-hpa start/running, process 1203



  • [quote=“Tom Elliott, post: 25037, member: 7271”]Where are you running this command? Windows, or your FOG Server, or another linux host?[/quote]
    [quote=“Tom Elliott, post: 25037, member: 7271”]Where are you running this command? Windows, or your FOG Server, or another linux host?[/quote]
    [quote=“Tom Elliott, post: 25037, member: 7271”]Where are you running this command? Windows, or your FOG Server, or another linux host?[/quote]

    Tom, I’m running it on my Windows 7 workstation. Earlier in the thread I explain that I can download the pxelinux.0 file successfully on the FOG server itself, and I can successfully ping the FOG server from my Win7 workstation.


  • Senior Developer

    Are you certain the tftp-hpa service is actually running:

    [code]sudo service tftpd-hpa status
    sudo service tftpd-hpa restart[/code]


  • Senior Developer

    [quote=“Spearfoot, post: 25035, member: 23487”]Yes, sir:

    tftp -i 192.168.1.16 get pxelinux.0
    Timeout occurred
    Connect request failed[/quote]

    Where are you running this command? Windows, or your FOG Server, or another linux host?



  • I turned off the firewall with this command: sudo ufw disable
    …and rebooted the fog server. Still no joy.



  • Yes, sir:

    tftp -i 192.168.1.16 get pxelinux.0
    Timeout occurred
    Connect request failed


  • Developer

    Can you post the tftp error you are recieving?


Log in to reply
 

433
Online

38938
Users

10697
Topics

101491
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.