Newest of Tom's kernels does not support Hyper-V VM machine



  • I use a Hyper-V system to build my base images… keeps things clean. the latest of Toms kernels does not load properly in this setup. the last official kernel did.

    I’v switched from using toms to the old one to upload and then switch back to deploy, but would be good if this was brought back in.



  • ah yes, version 1.0.1

    Searched the forums, most of what I found did not apply the rest did not help. Also tried loading old kernels, result was different error messages (thus my suspicion that its the bzImage file) but still no fog screen. Even tried creating the host manually and assigning an upload task.

    If I’m wrong hopefully I can get pointed in the right direction. the host is a Windows Server 2008 R2
    [ATTACH=full]819[/ATTACH]

    [url="/_imported_xf_attachments/0/819_fogerror.png?:"]fogerror.png[/url]


  • Senior Developer

    [quote=“TheSchnak, post: 27970, member: 23085”]so continuing on this… just upgraded to version 1.1 and Hyper-V is again unsupported byt the bzImage file.[/quote]

    WHAT?

    You mean Version 1.0.1?

    What makes you think “Hyper-V is again unsupported byt the bzImage file.”?

    I implore you to take a look at the TomElliott.config.64 file and tell me what’s missing?

    What are the issue you’re having?



  • so continuing on this… just upgraded to version 1.1 and Hyper-V is again unsupported byt the bzImage file.


  • Senior Developer

    Kernel’s have all been updated.

    32bit : [url]https://mastacontrola.com/fogboot/kernel/bzImage32[/url]
    64bit : [url]https://mastacontrola.com/fogboot/kernel/bzImage[/url]

    Files from drop down menu in 0.33b also reflect this.

    My kernel configs are also updated to reflect the changes.


  • Developer

    There’s always the option of building a custom kernel, Tom has a guide on working with the kernels he builds, and there is also a fabulous guide on this forum written by Ozzy that touches on building your own kernel.



  • cool thanks.


  • Senior Developer

    Rebuilding the 64 bit kernel, it will/does contain Hyper-v stuff in it. Working to get the same settings for the 32 bit as we speak. That said I hope this is now resolved for you. Will post update once bzImage’s are updated.

    Thank you,


  • Senior Developer

    I’m taking a look to see if I can get this re-included.


Log in to reply
 

371
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.