Dell Latitude E5440 FOG .32



  • Hi,

    Im looking for a kernel that will work with the E5440 laptop, when trying to upload an image i get a kernel panic error.

    Thanks


  • Senior Developer

    [quote=“Sivasubramaniam.T, post: 25002, member: 22852”]Hi Tom,

    I have tried the kernel with few others models. Its working absolutely fine with some new models.

    [B]Good Working with below Models :[/B]
    Dell Latitude 5420
    Dell Latitude 6420
    Dell Latitude 5440
    Lenovo L440


    [SIZE=3][B]Delay in loading kernel with below models :[/B][/SIZE]
    Dell Vostro 3400
    Dell Vostro 3460
    Dell Vostro 3450 (i3)

    [SIZE=3][B][I]Problem :[/I][/B][/SIZE] Its taking 4 to 5 minutes to load the kernel to perform any tasks.
    [COLOR=#ff6600]esas2r : driver will not be loaded because no ATTO esas2r devices were found [/COLOR]
    [COLOR=#ff6600]i2c-parport-light: adapter type unspecified [/COLOR]
    After 5 minutes its performing the tasks in a normal way.
    [ATTACH]640[/ATTACH]


    [B]Problematic Model :[/B]
    Dell Vostro 3450 (i5)

    Kernel have stopped at this line once the kernel is loaded
    [COLOR=#ff6600]esas2r : driver will not be loaded because no ATTO esas2r devices were found [/COLOR]
    [COLOR=#ff6600]i2c-parport-light: adapter type unspecified [/COLOR]
    [COLOR=#ff6600]IP-Config:Reopening network devices.[/COLOR]…
    No Process after this.
    [ATTACH]638[/ATTACH]


    Sorry for long description. Please help in solving this issue.[/quote]

    AN EMERGENCY ON YOUR PART DOES NOT CONSTITUTE ONE ON MINE!

    I realize you want help, but I can’t possibly tell you why or what is wrong. The esas2r message doesn’t mean anything, but it’s telling you that the kernel has not found that driver and can’t load it. same with the i2c-parport-light.

    What the kernel’s doing after that I don’t know. It’s fast on some, slow on others, and yet others it doesn’t work at all. I don’t know what to say to help.

    The best I can do is recompile and try different things.

    But I don’t have the systems to build against.

    I’m sorry that my kernels have failed you thus far!


  • Senior Developer

    My kernels are meant to be as much as all encompassing as possible. I haven’t a clue as to why it’s slower on some systems, or not working at all on other systems. There’s no way for me to build a kernel that just works against every possible system on the market. First, I don’t have every possible system so I can’t test the kernel for speed or if it works. I try my best. I don’t know is the best answer I can say right now.



  • [quote=“kelly.bettendorf, post: 24950, member: 5100”][/quote]

    [SIZE=4]Tom,[/SIZE]

    [SIZE=4]I also wanted to ask if the [FONT=arial]500GB (5.400Rpm) Solid State Hybrid Drive with 8GB Flash (400-ABCY) that we have ordered in our E5440 Laptops could be the cause of why its not working for us but is for others?[/FONT][/SIZE]

    [SIZE=4][FONT=arial]For [/FONT][FONT=arial]anyone[/FONT][FONT=arial] who has this kernel working with your Dell E5440 laptops what kind of hard drives have you been using with them?[/FONT][/SIZE]

    [SIZE=4][FONT=arial]Thanks for the feedback.[/FONT][/SIZE]



  • Hi Tom,

    I have tried the kernel with few others models. Its working absolutely fine with some new models.

    [B]Good Working with below Models :[/B]
    Dell Latitude 5420
    Dell Latitude 6420
    Dell Latitude 5440
    Lenovo L440


    [SIZE=3][B]Delay in loading kernel with below models :[/B][/SIZE]
    Dell Vostro 3400
    Dell Vostro 3460
    Dell Vostro 3450 (i3)

    [SIZE=3][B][I]Problem :[/I][/B][/SIZE] Its taking 4 to 5 minutes to load the kernel to perform any tasks.
    [COLOR=#ff6600]esas2r : driver will not be loaded because no ATTO esas2r devices were found [/COLOR]
    [COLOR=#ff6600]i2c-parport-light: adapter type unspecified [/COLOR]
    After 5 minutes its performing the tasks in a normal way.
    [ATTACH]640[/ATTACH]


    [B]Problematic Model :[/B]
    Dell Vostro 3450 (i5)

    Kernel have stopped at this line once the kernel is loaded
    [COLOR=#ff6600]esas2r : driver will not be loaded because no ATTO esas2r devices were found [/COLOR]
    [COLOR=#ff6600]i2c-parport-light: adapter type unspecified [/COLOR]
    [COLOR=#ff6600]IP-Config:Reopening network devices.[/COLOR]…
    No Process after this.
    [ATTACH]638[/ATTACH]


    Sorry for long description. Please help in solving this issue.

    [url="/_imported_xf_attachments/0/638_3450 Not working.jpg?:"]3450 Not working.jpg[/url][url="/_imported_xf_attachments/0/640_Vostro models getting delayed for 4 minutes (2).jpg?:"]Vostro models getting delayed for 4 minutes (2).jpg[/url]



  • [quote=“kelly.bettendorf, post: 24949, member: 5100”]Tom,

    All my settings are as you listed above, is it possible that a chainloader im useing could be causing the panic? I have some dell systems that boot loop when they hit fog so i use the chainloader to append HD 0 during host startup.

    Im thinking my next steps will be to test PXE booting with a different E5440 to eliminate any possible issues with the new laptop.
    Don’t think it will make a difference but this morning i restarted the server.

    Thanks again for helping out with this but it might be a few days until i get a chance to work with the E5440 laptops as soon as i can i will let you know if its working or not.

    Let me know if you have any more brilliant ideas.[/quote]

    [url="/_imported_xf_attachments/0/632_FOG TFTP 1.png?:"]FOG TFTP 1.png[/url]



  • [quote=“Tom Elliott, post: 24938, member: 7271”]@kelly.bettendorf

    There are a few things.

    First, try removing the kernel parameter that was set on the host within the GUI.

    Second, make sure the GUI is pointing to the right file:
    Other Information->FOG Settings->
    FOG_TFTP_PXE_CONFIG_DIR should be set as: /tftpboot/pxelinux.cfg
    FOG_TFTP_PXE_KERNEL_DIR should be set as: /tftpboot/fog/kernel/
    FOG_TFTP_PXE_KERNEL should be set as: fog/kernel/bzImage

    My guess is your FOG_TFTP_PXE_KERNEL lines are pointing at another kernel. I think this because it seems, to me, that Sivasubramaniam.T has tested this kernel and it worked on the E5440. Why it wouldn’t on yours doesn’t seem to make sense unless something is misconfigured.[/quote]

    Tom,

    All my settings are as you listed above, is it possible that a chainloader im useing could be causing the panic? I have some dell systems that boot loop when they hit fog so i use the chainloader to append HD 0 during host startup.

    Im thinking my next steps will be to test PXE booting with a different E5440 to eliminate any possible issues with the new laptop.
    Don’t think it will make a difference but this morning i restarted the server.

    Thanks again for helping out with this but it might be a few days until i get a chance to work with the E5440 laptops as soon as i can i will let you know if its working or not.

    Let me know if you have any more brilliant ideas.


  • Senior Developer

    @kelly.bettendorf

    There are a few things.

    First, try removing the kernel parameter that was set on the host within the GUI.

    Second, make sure the GUI is pointing to the right file:
    Other Information->FOG Settings->
    FOG_TFTP_PXE_CONFIG_DIR should be set as: /tftpboot/pxelinux.cfg
    FOG_TFTP_PXE_KERNEL_DIR should be set as: /tftpboot/fog/kernel/
    FOG_TFTP_PXE_KERNEL should be set as: fog/kernel/bzImage

    My guess is your FOG_TFTP_PXE_KERNEL lines are pointing at another kernel. I think this because it seems, to me, that Sivasubramaniam.T has tested this kernel and it worked on the E5440. Why it wouldn’t on yours doesn’t seem to make sense unless something is misconfigured.



  • Im also running ubuntu version 11.04



  • This post is deleted!


  • [quote=“Tom Elliott, post: 24923, member: 7271”]Right![/quote]

    Yes i still get Kernel Panic


  • Senior Developer

    Right!



  • [quote=“Tom Elliott, post: 24920, member: 7271”]Have you tried booting with this?[/quote]

    Im not sure i understand your question. Booting up the E5440 laptop?


  • Senior Developer

    Have you tried booting with this?



  • [quote=“kelly.bettendorf, post: 24916, member: 5100”]Thanks for all your hard work on this Tom I will give it a go.[/quote]

    Okay so i followed your instructions line for line

    [FONT=Consolas]cd /tftpboot/fog/kernel[/FONT]
    [FONT=Consolas]mv bzImage bzImage.orig.2014APR01
    wget -O bzImage --no-check-certificate [url]https://mastacontrola.com/fogboot/kernel/bzImage32[/url][/FONT]
    [FONT=Consolas] [/FONT]
    [FONT=Consolas]But i think i might have an idea why this is not working. When i navigate to the Kernel in GUI under properties of the kernel it shows
    Type: Dos/Windows Executable

    Im not sure why since im downloading the file right from Terminal [/FONT]



  • [quote=“Tom Elliott, post: 24915, member: 7271”]kelly,

    As I just added the reading ability of the “kernel” argument on the host level in 0.33b, I’m not sure this actually worked on 0.32.

    I’d try doing the methods I recommended above, just create a backup of your bzImage first.[/quote]

    Thanks for all your hard work on this Tom I will give it a go.


  • Senior Developer

    kelly,

    As I just added the reading ability of the “kernel” argument on the host level in 0.33b, I’m not sure this actually worked on 0.32.

    I’d try doing the methods I recommended above, just create a backup of your bzImage first.



  • [quote=“kelly.bettendorf, post: 24905, member: 5100”]O gosh… your right let me go try that again and i will let you know, I can’t believe i did that! Thanks again.[/quote]

    Now when i try to run an upload i get

    Kernel panic - not syncing
    Kernel Offset: 0X0 From 0xc1000000

    The Kernel Offset part is new.


  • Developer

    [quote=“kelly.bettendorf, post: 24905, member: 5100”]O gosh… your right let me go try that again and i will let you know, I can’t believe i did that! Thanks again.[/quote]

    wow I don’t know where my head was at when I read that but I re-read it and saw that you mentioned you changed the name of the file, sorry for my confusion :oops:

    [quote=“Sivasubramaniam.T, post: 24907, member: 22852”]Hi James,

    The issue got fixed !
    I am using [B]fog 0.32[/B] in Ubuntu 12.04 [B]64 bit OS[/B].

    First I have tried with [B][url]https://mastacontrola.com/fogboot/kernel/bzImage[/url][/B] unfortunately it gave kernal panic error.
    Later I have tried with [B][I][FONT=Consolas][url]https://mastacontrola.com/fogboot/kernel/bzImage32[/url] [/FONT][/I][/B]It worked for me :)

    I have tried with Dell 5440, 5420, 3450 and Lenovo L440 model laptops. Its working perfectly in all the laptops.
    Thank you for your support.:)[/quote]

    Glad you got it working!



  • [quote=“Jaymes Driver, post: 24888, member: 3582”]Yes, there is a 64 bit version of the kernel, [url]https://mastacontrola.com/fogboot/kernel/bzImage[/url]

    You need to follow the instructions Tom has given you but this will allow you the 64 bit capabilities.[/quote]

    Hi James,

    The issue got fixed !
    I am using [B]fog 0.32[/B] in Ubuntu 12.04 [B]64 bit OS[/B].

    First I have tried with [B][url]https://mastacontrola.com/fogboot/kernel/bzImage[/url][/B] unfortunately it gave kernal panic error.
    Later I have tried with [B][I][FONT=Consolas][url]https://mastacontrola.com/fogboot/kernel/bzImage32[/url] [/FONT][/I][/B]It worked for me :)

    I have tried with Dell 5440, 5420, 3450 and Lenovo L440 model laptops. Its working perfectly in all the laptops.
    Thank you for your support.:)


Log in to reply
 

437
Online

39.3k
Users

11.0k
Topics

104.5k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.