DHCP Issues communicating with FOG



  • Hi all, been using this software for a little while and its brilliant, however the guys i work with have for some unknown reason completely messed up our DHCP Server and had to rebuild a new one with new information etc.

    Since then the fog server has not worked, i have set up dhcp reservation and sorted out ports 066 and 067, however i do remember the initial installation for fog required details of the DHCP Server information,

    does anyone know where that information is stored and if it can be changed to accomodate a new DHCP Server?

    thanks in advance


  • Developer

    Glad you got it sorted!!!



  • haha yeah indeed, definitely a setting worth knowing about though. thanks again for all your help tom + Community


  • Senior Developer

    Awesome, at least it was less troublesome than networking issues as a whole right?



  • hey guys, thanks again for all your help,

    we have found that within the fog web interface under:-
    Other information -> Fog settings -> TFTP Server -> FOG_PXE_IMAGE_DNSADDRESS
    was incorrect due to the change, after changing this to the correct address fog is now up and running.


  • Senior Developer

    [quote=“westontech, post: 24845, member: 23261”]Hi all,

    Thanks in advance for your help, ive tried the tftp -I and its come back successful. and ive checked ports 66 and 67 are both correct. is there anything else that I will need to check?[/quote]

    As you say this is working now I don’t know where to go.

    The only thing, I imagine, that’s keeping your systems from booting the pxelinux.0 (it’s a binary file so not something you can just edit.) is the IP address the option 66 part of the DHCP scope. Option 66 should be the IP address pointing at your new FOG Server’s IP address.

    You state they appear to be correct. This may be true, the only other thing you may need to look at is the DHCP ip-helper commands from the switch that’s passing the main network’s routing information. My guess is the ip-helper is currently pointing DHCP to go to your old DHCP server address. Systems within the layer 2 of your network are working fine because it’s passing straight to the new DHCP server (I’m just guessing) where systems on separate subnets and switches are probably having issues as well, they just haven’t quite cropped up yet.


  • Developer

    Look here, this is a guide to help you accomplish your task at hand.

    [url]http://www.fogproject.org/wiki/index.php/Using_FOG_with_an_unmodifiable_DHCP_server/_Using_FOG_with_no_DHCP_server[/url]

    The pxelinux.0, to my understanding, is a file that will boot linux from a network server with a linux ROM that will allow you to load and transfer data via the PXE environment such as, communicating with a TFTP server to acquire an image for upload or deployment.

    I have never edited one in the past, I don’t even know what the file is encoded as so I am going to say that it CAN be modified but I have no expertise how. Tom does all the major work with the PXE system, he has a much better grasp on the files, I am sure he would be willing to offer some help if you let us know what it is you are trying to achieve.



  • [quote=“Jaymes Driver, post: 24848, member: 3582”]If your tftp command comes back as successful, then the server is operating normally, and the problem lies in the environment.

    Try setting up the dnsmasq service to dole out proxydhcp information, it can sometimes help in getting your pxelinux file where it needds to be by supplying the tftpboot information that the clients need. I use this in my environment set ups and it solves the issues you are experiencing.[/quote]

    Hi Jaymes, thanks for your help and input, unfortunately im not much of a Linux user really just trying to get the fog server up and running again haha, how would I go about doing this dnsmasq service? also is the pxelinux.0 file editable ? what is actually in that file?


  • Developer

    If your tftp command comes back as successful, then the server is operating normally, and the problem lies in the environment.

    Try setting up the dnsmasq service to dole out proxydhcp information, it can sometimes help in getting your pxelinux file where it needds to be by supplying the tftpboot information that the clients need. I use this in my environment set ups and it solves the issues you are experiencing.



  • Hi all,

    Thanks in advance for your help, ive tried the tftp -I and its come back successful. and ive checked ports 66 and 67 are both correct. is there anything else that I will need to check?


  • Developer

    The tftp command is not available by default in Windows 7 but can be enabled by turning on the [I]TFTP Client[/I] Windows feature from Programs and Features in Control Panel.
    tftp will also be blocked by default by the windows firewall



  • hi tom, ive tried running that command from the DHCP Server and it comes back failed, is that definately the command that needs to be used?


  • Senior Developer

    Okay, then you don’t have to worry about telling fog about a dhcp server.

    You need to verify that the DHCP server’s Options 66/67 are set up properly, and that you can get the file’s from FOG Server.

    From the DHCP server, try using the tftp command, something like (from windows):
    [code]tftp -i <FOG IP ADDRESS> get pxelinux.0[/code]



  • the dhcp server install part of setup was not done.


  • Senior Developer

    When the FOG Server was installed, did you install the dhcp server? Not did you setup the server with the dhcp server’s ip address, but did you install the package that makes the fog server A dhcp server?



  • hey tom, thanks for your help, however the name of our dhcp server has changed aswell as the ip address to it. that is the information im trying to track down on the fog server but my knowledge is quite limited on linux :(


  • Senior Developer

    Normally, the fog server DHCP setting stuff is for the isc-dhcpd package to be installed.

    As you’ve already stated, you’re not intending to use FOG for the DHCP server, so this isn’t really needed. So long as the new DHCP server is pointing to the FOG Server’s IP (I believe Option 66) and is handing out the pxelinux.0 file (I believe Option 67) and your fog server’s tftp-hpa service is running (tftpd-hpa – ubuntu, xinetd – redhat) All should work. I’d take a look at a couple of things.

    First thing to check is the Option’s 66/67 are set properly.
    Second, make sure the tftp service is running on the FOG Server.
    Third, if your new DHCP server has any significant changes to it, you may need to make sure your switches are pointing to the New DHCP server properly. This can be done on many managed switches with the use of the ip-helper command.


Log in to reply
 

358
Online

38982
Users

10712
Topics

101678
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.