Fog is unable to move /images/dev/Macaddress to /images/imagename



  • Hello,
    I installed the latest build (0.32) on a virtual ubuntu 12.04 LTS system the VM is running on VMWare Workstation 10. now I have the problem that the upload skript tells me “unable to move /images/dev/MACAddress to /images/imagename”.
    First I thougt its maybe an issue with the permissions on the directory so I set 777 -> doesn’t help.
    afte I checked other possible reasons like group memberships and followed the instructions on the [URL=‘http://www.fogproject.org/wiki/index.php/Images_Directory_Permissions’]wiki[/URL] I fuggured out that fog server creates evrey image with 701 permissions and the owner ship is root:root I think that this could be the Problem does anyone know a ressolution for this Problem?

    greetings Asadea
    PS sorry for the bad englisch I’m from Germany and are not the professional english speaker ;)



  • I fixed the Problem. After I tested imaging with a other machine (win7) and this worked I only changed the OS entry in the fog web ui at the XP machine wich was unable to image. Now it works. :)


  • Senior Developer

    Check the password on the Storage Node itself.

    FOG GUI->Storage Management->All Storage Nodes-><YOUR STORAGE NODE>Management Username and password.

    Change the password as needed. it usually fails on this step for one of two reasons.
    Password is wrong.
    Or
    Permissions are set wrong on the /images folder.

    verify the permissions on the /images are chmodded to 777
    [code]chmod -R 777 /images[/code]

    Then try again.

    If you still have the problem, you may be having an issue deleting the ALREADY EXISTING image file if it’s there.



  • I have checked all the passwords for the “fog” but the issue is still there. I also added the fog user to the root group at the linux system this also doesn’t help :(


  • Developer

    Check the password for the user “fog” on the linux system and make sure it matches with what is in /var/www/fog/commons/config.php and in the fog settings window in the web UI(search for ftp).


Log in to reply
 

365
Online

38982
Users

10712
Topics

101678
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.