FOG Setup with 2 NIC's



  • Hi,

    I’m trying to install a new FOG Server with 2 NIC’s. eth0 is supposed to be the management NIC which is accessible via the local network, and eth1 should only be used by FOG but I can’t seem to get it to work. Has someone set it up that way and can point me in the right direction ?

    Edit: For anyone who has the same Problem a quick how to.

    1.Setup your NIC’s to something like this
    [CODE]auto eth0
    iface eth0 inet dhcp

    auto eth1
    iface eth1 inet static
    address XXX.XXX.XXX.XXX
    netmask XXX.XXX.XXX.XXX
    [/CODE]
    Replace the address and netmask to your liking. In this example there is a network with dhcp server connected to eth0 and eth1 will serve as a standalone network.

    1. Download and install FOG, configure it like this.
      [CODE] Here are the settings FOG will use:
      Distro: Ubuntu
      Installation Type: Normal Server
      Server IP Address: "Address of eth1"
      DHCP router Address: "Address of eth1"
      DHCP DNS Address:
      Interface: eth1
      Using FOG DHCP: 1
      Internationalization: 0[/CODE]

    This should do the trick. Reboot if you’re having troubles.



  • I just wanted to say thank you for the post. Have been all over looking for this answer, as I am new to both setting up a Ubuntu desktop as a Linux server and FOG. Really excited to start using FOG, great piece of software by the way, and give this school district an answer to cloning that doesn’t involve using deploy studio to clone a PC. Thank you again.


  • Developer

    Then your server did not upload any image which is why you are getting the error that it cannot find the files.

    Try the upload again and watch it for errors at the beginning.



  • /images and /images/dev are both empty.


  • Developer

    What kind of image did you tell it to upload?

    If you check the “/images” directory what files do you see inside the folder with your images name on it?

    If you only have /dev inside /images then your image was never moved and is likely under /dev in a folder with the mac address of the client as the name.

    If it’s not shown in either of those locations then it didn’t upload the image.



  • Thanks for the Help so far. After reinstallinge everything dhcp and pxe is working fine.

    But I have an other problem now. When I try to image a Client it says "Unable to locate image file for Windows 7! (sys.img.000).
    Here is what I did, I created an Image and then did a full inventory on the client linking it to the image and appropriate OS and set it to “image this client on reboot”. After that I get an endless boot loop.


  • Senior Developer

    The server IP is the listening server of FOG, but when it comes to the GUI, apache naturally listen’s on all available network interfaces unless you specify otherwise.

    It seems likely that you setup the TFTP and DHCP server to listen on the wrong interface. You shouldn’t have to reinstall the whole thing, but this will likely correct the problems.



  • Sorry, I thought the Server IP was the listening IP of FOG. However, it’s still not working. I’ll probably start from scratch tomorrow or the day after. I think I messed up my system somehow with dnsmasq and dhcp.


  • Developer

    you will be accessing the web gui via eth0.

    Try it before you assume it won’t work.



  • But then I’m accessing the Web GUI via eth1 and not eth0 which won’t work because eth1 is not connected to the network.


  • Developer

    You should be able to.



  • [quote=“BPSTravis, post: 24615, member: 22444”]Then you will want to install fog with the ip 10.0.0.100[/quote]

    But then I won’t be able to access the Web GUI or am I wrong ?


  • Developer

    Then you will want to install fog with the ip 10.0.0.100



  • Yes, eth0 is using DHCP and connected to the network. eth1 is set to static with the IP 10.0.0.100 and connected to an office switch where I’m connecting the clients for imaging/deploying.


  • Developer

    We need to verify something first.

    Are you using eth1 as a local network separate from the eth0 network?

    If so then when you set up the server you need to use the IP 192.168.1.1 So it creates it’s own network.



  • [quote=“BPSTravis, post: 24611, member: 22444”]Did you chose to have FOG do the DHCP?

    If so make sure your DHCP server is running(Varies depending on your distro).[/quote]

    That seems to be the problem, the dhcp server isn’t starting. This is how I installed FOG:
    Here are the settings FOG will use:
    Distro: Ubuntu
    Installation Type: Normal Server
    Server IP Address: 91.0.160.140
    DHCP router Address:
    DHCP DNS Address:
    Interface: eth1
    Using FOG DHCP: 1
    Internationalization: 0

    Note: the Server IP is the eth0 address. Do I need to set the eth1 address as DHCP router ?


  • Developer

    Did you chose to have FOG do the DHCP?

    If so make sure your DHCP server is running(Varies depending on your distro).



  • [quote=“BPSTravis, post: 24603, member: 22444”]when I did this I set FOG to use eth1 during the initial install.

    The web interface is still accessible via eth0.

    From what I remember, I did not have to alter anything after that point.[/quote]

    Thats how I did it, but my test client isn’t getting a IP address. I’ve connected an office switch to eth1 and can access the GUI via eth0.


  • Developer

    when I did this I set FOG to use eth1 during the initial install.

    The web interface is still accessible via eth0.

    From what I remember, I did not have to alter anything after that point.


  • Senior Developer

    I have never attempted to use two nic’s separately on a FOG Server. Usually I just default to using eth0, or the first interface that’s seen by the system when FOG performs the install.

    That said, The GUI should work on any interface naturally. Unless you’ve made changes to the apache configuration to only listen through a specific IP address in which case you’d have to set it up to listen on the NIC’s IP Address you want it to. As for everything else, instead of using the defaults FOG presents you with, you can specify which IP address the rest of the items go through. These settings can be changed from the GUI. Particularly under FOG Configuration->FOG Settings/Other Information->FOG Settings under the below options:
    FOG_WOL_HOST (Set the ip address, make sure it’s GUI accessible.)
    FOG_WOL_INTERFACE (Make sure this interface is the same interface from the IP you set for FOG_WOL_HOST or at least accessible to the same network.)
    FOG_UDPCAST_INTERFACE (Make sure it’s the interface you want to perform multicast imaging from.)
    FOG_NFS_ETH_MONITOR (Make sure it’s the interface you want to perform imaging from.)
    FOG_TFTP_HOST (Should be the same IP address you want tftp/PXE boot to happen from. Usually the same IP as the interface you’re trying to do Imaging from.)
    FOG_WEB_HOST (Set the ip address, make sure it’s GUI accessible. This is usually the IP you install FOG with.)

    Hopefully this helps and works for you.


Log in to reply
 

427
Online

38995
Users

10714
Topics

101713
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.