Using 0.32 with Fedora 20



  • Hi…

    I’ve been trying to hack my way through installing FOG on Fedora 20. I’ve been able to follow some of the other threads to successfully complete the installation and change some PHP files. I’m able to successfully view the site in a browser, as well as add new hosts and migrate some images from an older installation.

    I’m at the point where I’m trying to deploy an image in Task Scheduler, but I’m receiving the dreaded “None of the machines were able to be queued! Unable to connect to tftp server.” error message.

    I’ve gone through the process of resetting the fog user password is reset to the default “password”, as well as checking to make sure in the FOG_TFTP_FTP_USERNAME and FOG_TFTP_FTP_PASSWORD in the GUI and also TFTP_FTP_USERNAME, TFTP_FTP_PASSWORD, STORAGE_FTP_USERNAME, and STORAGE_FTP_PASSWORD are all set to the same.

    I’ve disabled SELinux and the firewall for the time being. All of this and no luck with getting a task started. Has anyone else come across this? Or am I just being a little too aggressive trying to get it up and running on such a new OS?

    Thanks for any advice…


  • Moderator

    This should probably get Wiki’d.



  • Part 2:

    [LIST=1]
    [][FONT=Times New Roman]Go to /opt/fog-0.32/packages. We need to install/fix UDPCast by using the following commands: (thanks to the post from Tom Elliot on [url]http://fogproject.org/forum/threads/setting-up-and-building-udpcast-failed.4548/[/url])[/FONT]
    [LIST]
    [
    ][FONT=Times New Roman]wget [url]https://svn.code.sf.net/p/freeghost/code/trunk/packages/udpcast-20120424.tar.gz[/url] [/FONT]
    [][FONT=Times New Roman]rm -f udpcast-20071228.tar.gz [/FONT]
    [
    ][FONT=Times New Roman]sed -i ‘s/udpcastout=“udpcast-20071228”/udpcastout=“udpcast-20120424”/’ …/lib/common/config.sh [/FONT]
    [][FONT=Times New Roman]sed -i ‘s/udpcastsrc="…/packages/udpcast-20071228.tar.gz"/udpcastsrc="…/packages/udpcast-20120424.tar.gz"/’ …/lib/common/config.sh [/FONT]
    [/LIST]
    [
    ]Go to /opt/fog_0.32/lib/redhat
    [LIST]
    []vi functions.sh
    [
    ]On lines 473-475 change mysqld to mariadb
    [/LIST]
    [][FONT=Times New Roman]cd …/…/bin [/FONT]
    [LIST]
    [
    ][FONT=Times New Roman]./installfog.sh[/FONT]
    [/LIST]
    [][FONT=Times New Roman]Go to /var/www/html/fog/management/includes and edit the tasks.confirm.include.php file[/FONT]
    [LIST]
    [
    ][FONT=Times New Roman]Search the entire file for [B]&$tmp[/B] and replace with [B]$tmp[/B][/FONT]
    [/LIST]
    [][FONT=Times New Roman]Install and update clamav[/FONT]
    [LIST]
    [
    ][FONT=Times New Roman]yum install clamav clamav-update[/FONT]
    [][FONT=Times New Roman]cd /var/lib/clamav[/FONT]
    [
    ][FONT=Times New Roman]touch clamd.sock[/FONT]
    [/LIST]
    [][FONT=Times New Roman]cd /opt/fog_0.32/bin[/FONT]
    [LIST]
    [
    ][FONT=Times New Roman]./installfog.sh[/FONT]
    [][FONT=Times New Roman]Fill out the installation options according to your needs[/FONT]
    [/LIST]
    [
    ][FONT=Times New Roman]Since this server is only accessible inside my office, I made the following changes to the fog folder in /var/www/html[/FONT]
    [LIST]
    [][FONT=Times New Roman]chmod –R 755 fog[/FONT]
    [
    ][FONT=Times New Roman]chown –R apache:apache fog[/FONT]
    [/LIST]
    [][FONT=Times New Roman]cd /etc/httpd/conf/[/FONT]
    [LIST]
    [
    ][FONT=Times New Roman]vi httpd.conf[/FONT]
    [][FONT=Times New Roman]Locate the ServerName line and enter your server name or IP[/FONT]
    [LIST]
    [
    ][FONT=Times New Roman]In my office we just used the IP address so it would look something like:
    ServerName 192.168.100.14:80[/FONT]
    [/LIST]
    [/LIST]
    [][FONT=Times New Roman]Make sure you enable the following services so that if the server is rebooted, they start back up automatically[/FONT]
    [LIST]
    [
    ][FONT=Times New Roman]systemctl enable <service name>.service[/FONT]
    [LIST]
    [][FONT=Times New Roman]Httpd[/FONT]
    [
    ][FONT=Times New Roman]Mariadb[/FONT]
    [][FONT=Times New Roman]Nfs-server[/FONT]
    [
    ][FONT=Times New Roman]Vsftpd[/FONT]
    [][FONT=Times New Roman]Firewalld[/FONT]
    [LIST=1]
    [
    ][FONT=Times New Roman]If turning on firewall, allow public access on http, https, ftp, tftp, nfs[/FONT]
    [/LIST]
    [/LIST]
    [/LIST]
    [][FONT=Times New Roman]Make sure to also start these same services[/FONT]
    [LIST]
    [
    ][FONT=Times New Roman]Systemctl start <service name.service>[/FONT]
    [/LIST]
    [][FONT=Times New Roman]Disable SELinux[/FONT]
    [
    ][FONT=Times New Roman]There is a chance that you may need to reset the fog account that’s created from the install.[/FONT]
    [LIST]
    [][FONT=Times New Roman]Passwd fog[/FONT]
    [
    ][FONT=Times New Roman]Go to your FOG webpage > Other Info > FOG settings and enter[/FONT]
    [LIST]
    [][FONT=Times New Roman]TFTP Server username – fog[/FONT]
    [
    ][FONT=Times New Roman]TFTP Server password - <your password>[/FONT]
    [/LIST]
    [][FONT=Times New Roman]Then go to Storage Management > All Storage Nodes >Default member[/FONT]
    [LIST]
    [
    ][FONT=Times New Roman]Enter your fog username and password[/FONT]
    [/LIST]
    [][FONT=Times New Roman]vi /var/www/html/fog/commons/config.php[/FONT]
    [LIST]
    [
    ][FONT=Times New Roman]line 24 – define( “FTFP_FTP_USERNAME”, “<enter your fog username here>”);[/FONT]
    [*][FONT=Times New Roman]line 25 – define( “FTFP_FTP_PASSWORD”, “<enter your fog password here>”);[/FONT]
    [/LIST]
    [/LIST]
    [/LIST]
    [FONT=Times New Roman]That’s all I have. Hopefully, it’s enough for you to get your server up. Unfortunately, if you have any other questions, I’m not sure I’ll be much help, but following these steps I was able to access my FOG server in any browser using its IP address (we didn’t set up a DNS entry). Also, if you’re using a DHCP server make sure to set up the appropriate entries there so that you can properly PXE boot to your FOG server.[/FONT]
    [FONT=Times New Roman]Good luck![/FONT]



  • [FONT=Times New Roman][quote=“Kronkras, post: 34558, member: 25243”]Could you elaborate on the other tweaks you performed to make it work. I’m currently having problems were I’m able to access the web interface from the fog server but not from another machine.[/quote][/FONT][quote=“Kronkras, post: 34558, member: 25243”]

    [FONT=Times New Roman]Fedora 20[/FONT]
    [FONT=Times New Roman]Fog 1.2.0[/FONT][/quote]

    [FONT=Times New Roman]Here are my notes for setting everything up from installing the OS to completion.[/FONT]

    Part 1
    [LIST=1]
    [][FONT=Times New Roman]Install Fedora 20[/FONT]
    [
    ][FONT=Times New Roman]Use yum install to install the following packages:[/FONT]
    [LIST]
    [][FONT=Times New Roman] httpd, mariadb (mysql replacement), mariadb-server, php (I just did a generic install everything php. You may not need every one, but I thought it wouldn’t hurt)[/FONT]
    [/LIST]
    [][FONT=Times New Roman]Run yum update to make sure all packages are up to date[/FONT]
    [
    ][FONT=Times New Roman]Download the FOG tar file and move it to /opt[/FONT]
    [][FONT=Times New Roman]Unpackage the tar file[/FONT]
    [
    ][FONT=Times New Roman]Run following commands (I forget what they do though):[/FONT]
    [LIST]
    [][FONT=Times New Roman]rpm -Uvh [URL=‘http://pkgs.repoforge.org/rpmforge-release-0.5.3-1.el6.rf.x86-64.rpm’]http://pkgs.repoforge.org/rpmforge-release/rpmforge-release-0.5.3-1.el6.rf.x86_64.rpm[/URL][/FONT]
    [
    ][FONT=Times New Roman]rpm --import [URL=‘http://rpms.famillecollet.com/RPM-GPG-KEY.remi’]http://rpms.famillecollet.com/RPM-GPG-KEY-remi[/URL][/FONT]
    [/LIST]
    [][FONT=Times New Roman]Go to /opt/fog-0.32/lib/redhat/ and edit the config.sh file (create a backup of it first)[/FONT]
    [LIST]
    [
    ][FONT=Times New Roman]On line 22, change the following packages[/FONT]
    [LIST]
    [][FONT=Times New Roman]php-gettext -> php-common[/FONT]
    [
    ][FONT=Times New Roman]php-mysql -> php-mysqlnd[/FONT]
    [][FONT=Times New Roman]mysql -> mariadb[/FONT]
    [
    ][FONT=Times New Roman]mysql-server -> mariadb-server[/FONT]
    [][FONT=Times New Roman]clamav-update -> clamav[/FONT]
    [/LIST]
    [
    ][FONT=Times New Roman]On line 23, make the following changes to storageNotePackages[/FONT]
    [LIST]
    [][FONT=Times New Roman]delete php-gettext[/FONT]
    [
    ][FONT=Times New Roman]delete mysql[/FONT]
    [][FONT=Times New Roman]delete mysql-server[/FONT]
    [
    ][FONT=Times New Roman]change php-mysql to php-mysqlnd[/FONT]
    [/LIST]
    [][FONT=Times New Roman]On line 62, edit the freschclam config file section to:[/FONT]
    [LIST]
    [
    ][FONT=Times New Roman]#where is freshclam’s config file
    #freshdb="/var/lib/clamav/";
    freshdb="/var/clamav/";
    freshwebroot="${webdirdest}/av/";
    freshconf="/etc/freshclam.conf";
    #freshcron="/etc/sysconfig/freshclam"
    freshcron="/usr/bin/freshclam"[/FONT]
    [/LIST]
    [][FONT=Times New Roman]Save the file[/FONT]
    [/LIST]
    [
    ][FONT=Times New Roman]restart NFS -> systemctl restart nfs-server.service[/FONT]
    [][FONT=Times New Roman]restart xinetd -> systemctl restart xinetd.service[/FONT]
    [
    ][FONT=Times New Roman]restart rpcbind -> systemctl restart rpcbind[/FONT]
    [/LIST]



  • [quote=“a1adam12, post: 24115, member: 22878”]I 've gotten somewhere. I thought the firewall was disabled because I was using the old iptables rather than firewalld. So I believe I never had it set up correctly. After a few tweaks, Task Scheduler seems to have successfully connected to TFTP and started the job.

    After that it was double checking to make sure some other services, like nfs-server, were properly enabled and started and I’m good to go.[/quote]

    Could you elaborate on the other tweaks you performed to make it work. I’m currently having problems were I’m able to access the web interface from the fog server but not from another machine.

    Fedora 20
    Fog 1.2.0



  • [quote=“a1adam12, post: 24086, member: 22878”]Hi…

    I’ve been trying to hack my way through installing FOG on Fedora 20. I’ve been able to follow some of the other threads to successfully complete the installation and change some PHP files. I’m able to successfully view the site in a browser, as well as add new hosts and migrate some images from an older installation.

    I’m at the point where I’m trying to deploy an image in Task Scheduler, but I’m receiving the dreaded “None of the machines were able to be queued! Unable to connect to tftp server.” error message.

    I’ve gone through the process of resetting the fog user password is reset to the default “password”, as well as checking to make sure in the FOG_TFTP_FTP_USERNAME and FOG_TFTP_FTP_PASSWORD in the GUI and also TFTP_FTP_USERNAME, TFTP_FTP_PASSWORD, STORAGE_FTP_USERNAME, and STORAGE_FTP_PASSWORD are all set to the same.

    I’ve disabled SELinux and the firewall for the time being. All of this and no luck with getting a task started. Has anyone else come across this? Or am I just being a little too aggressive trying to get it up and running on such a new OS?

    Thanks for any advice…[/quote]

    I 've gotten somewhere. I thought the firewall was disabled because I was using the old iptables rather than firewalld. So I believe I never had it set up correctly. After a few tweaks, Task Scheduler seems to have successfully connected to TFTP and started the job.

    After that it was double checking to make sure some other services, like nfs-server, were properly enabled and started and I’m good to go.


Log in to reply
 

348
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.