Unable to boot correctly - Invalid OS ID



  • I’m starting to think I’m cursed. A few weeks ago I’d installed FOG on my home server in order to test out a fresh install. Well it worked and I was able to upload an image of my laptop. Following that, I began using my laptop more for work. Within a few days (and not a month after the warranty expired!) the hard drive began to fail. It was a Seagate Momentus which I replaced with a Western Digital Black of the 2.5 inch variety and the same size as my old one.

    Here’s where the trouble began. The new unit is an “Advanced Format Drive”. It didn’t take me long to figure out those are not compatible with version .32 so I took the plunge and tried out .33b. The build I downloaded was the one linked from the first page of the “Latest on Fog .33b” thread; for some reason I could not access mastacontrola.com. Now the upgrade was fairly painless and I like the new log in screen. And of course upon booting it went straight into iPXE. Then it stopped and said “Invalid OS ID (0)” and rebooted. At the time my laptop was set to Legacy BIOS. I tried setting it to UEFI, but Secure Boot wouldn’t allow me to PXE boot and I can’t seem to turn it off.

    The laptop is a Gateway NE56R34u bought around Christmas 2012. It runs Windows 8 (not 8.1). Now when I first uploaded the image I had to set the OS to be Windows 7. For some reason FOG would not accept Windows Other as an OS ID and there was no option for Windows 8. However after upgrading to .33b I can’t seem to find a place to change the OS using the web management console. The image is single disk, multipartition and the server OS is Debian 7. Is there any hope for me to get the image off the server?



  • I look forward to using the new version in the future. It sounds like it will be vastly superior to .32.

    The problems with my drive are largely due to the fact that it’s an advanced format drive. Even the Windows 8 recovery partition won’t work because it was created on a non-AFD disk. Also my laptop is 64-bit but my desktop is 32-bit so I can’t simply create an install disk from the windows 8 installer. Ugh!

    FOG, however, has performed very well. This little adventure has helped me test out version .33b so when we do upgrade I the server at work I know what to expect. At present my plan is to wait until it’s finalized. Since we have about four spare computers (and only need about that many images) at work recreating reference images is not much of an issue. My main concern is for the FOG database since rebuilding it would require going around to the public computers. Is it possible to copy the database, store it somewhere, and then put it back on the server when version .33 is installed? Or is the best way to upgrade simply to have two servers? Note that we do not have any FOG server as of yet, although I do not want our big Windows 7 roll out to be dependent on software which is still in Beta.


  • Developer

    [quote=“MikeoftheLibrary, post: 23398, member: 20568”]Ah ok. So on an ordinary day speeds will be comparable to what .32 can do? My initial concern was that partclone was slower than partimage.[/quote]

    Yes 0.33b will be just as fast, if not FASTER than 0.32.

    Tom is currently working on the iPXE system and I believe with it comes HTTP which is a hell of a lot faster than the FTP method we are currently using.

    Tom even took the time to add in the ability to change the image compression and this in turn should help with both upload and download speed.

    Sorry you are having issues with your drive. I actually set up a second box for my 0.33b, because 0.33b isn’t a direct drop in replacement for 0.32.

    This way I still have my old images on my 0.32 server and I can start pushing my new images to BOTH until 0.33b is actively ready for my environment. Right now I have it separate from my network so I can test it and ti capabilities.



  • Ah ok. So on an ordinary day speeds will be comparable to what .32 can do? My initial concern was that partclone was slower than partimage.

    Thank you for your help, but it looks like my hard drive is too far gone to be copied again. Probably I should not have deleted the old image. But I did get a chance to try out .33b without messing with one of the work computers.


  • Senior Developer

    Probably the way the program functions. It couldn’t obtain, (just my guess) the proper blkid because of the drive failing.

    So it was probably trying to image using RAW format. The raw part worked until it couldn’t read the sector’s an further.



  • Well partclone failed with the error “this disk has bad sectors”. That was on the first partition and the rest would not image at all. CHKDSK seems to have done nothing. Unless anyone has any other ideas this is probably the end of the line for this solution since I deleted the other image owing to my server not having enough space for both. Fortunately there was nothing on my laptop which was not elsewhere.

    One question though. Partclone seemed to think my old hard drive was completely full when it wasn’t. Also it went extremely slowly before failing. Was that a bug or simply a function of the way the program operates?



  • Changing the OS ID to Windows 8 for the image allowed me to boot into the menu. I like that the password is the same as for the web interface. And the new FOG menu is a little better than the old one in my opinion. But as you said, Tom, the image download did not work so over the weekend I will re-image my old hard drive and attempt this again.


  • Senior Developer

    All should install pretty much the same. I’ve made some, but not many, changes to the installer, and I’ve tested them quite thouroughly so you should be good.


  • Senior Developer

    Because I use Dyndns to translate back to my home pc. I didn’t add webhop for www to translate back.



  • Ah that worked. Out of curiosity why does including the WWW produce an error?

    I will run chkdsk again just to be sure. The last time it did not seem to do much but it’s best to be cautious where images are concerned. Also will it help to run the FOG installer on your website on my server or is it the same as the one I have? I noticed that different builds seem to have been released over the last few months and want to make sure mine is the one which will function best.


  • Senior Developer

    Also, if at all possible, try running a full chkdisk from windows before setting up the upload task.


  • Senior Developer

    Lose the www part of the address
    [url]https://mastacontrola.com[/url]



  • There is either something wrong with your site or my computer because when I type in this: [url]https://www.mastacontrola.com/[/url] it says the site is unavailable. I’ve tried in Firefox Chrome, and IE both at home and at work. Now I’d noticed earlier that Chrome did not like your SSL certificate so perhaps that is the issue?

    I will check the image later and see if I can set the type there. However it sounds like the best course of action for both of use might be for me to pop the old hard drive back in (it still boots) and reimage it). My only concern is that if I do so, will there be any issues with corrupted files or errors being replicated between drives? I was getting a lot of event ID 153s before purchasing a new drive.


  • Senior Developer

    If you tried to download 0.33b yesterday, my server was down until about 5 pm east due to electric box being put in.

    The osid being 0 is my guess is you updated the current 0.32 to 0.33 which isn’t pretty. Check your images and set the is type there. It used to be on each host but is now on the image.

    The last part may not be much help. 0.33 b uses partclone for the imaging medium where previous revisions used partimage. So if you have an existing image it probably will not work right away. If you want I can this together a special init.gz for you that will do part image just for the download. Just let me know.


Log in to reply
 

774
Online

38981
Users

10712
Topics

101676
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.