Compression



  • Is there any way to set compression levels in Fog 0.32?

    Thanks!



  • Thx [SIZE=12px]Junkhacker; I’m on 0.32 in this case; after some testing I think the message “compression level…” may not be credible; if when it says NONE the imager clearly uses compression since the final *.img file is nowhere near the actual partition used up space. Could there be some truth to that?[/SIZE]


  • Developer

    this information pertains to fog 0.32
    if you are using fog 1.0 (or fog 0.33b) the setting is changed on the configuration page under boot settings



  • Hi Tom, so on another install I did follow the guide above; now the begining of the file looks like this:

    [CODE]#!/bin/sh

    PIGZ_COMP="-9";
    RUN_CHKDSK="";
    HOSTNAME_EARLY=“0”;
    [/CODE]

    However during an upload the blue screen still says Compression level… None

    Is there another place to enable compression per-se which is an independent setting from the level of compression?

    Thx


  • Senior Developer

    Glad I could be of assistance.



  • Thank you, thank you, thank you! I just manually modified the file once it was unzipped. Running the code the first time screwed it up (probably my fault!), so I just modified the file.

    That’s so awesome! Thanks again!!!


  • Senior Developer

    Yes, but not real easily.

    The way to do it is described below: (root access on FOG Server, use terminal or console.)
    [code]cd /tftpboot/fog/images
    mkdir tmp
    gunzip -d -c init.gz > init
    mount -o loop init tmp
    sed -i ‘s/PIGZ_COMP="-3";/PIGZ_COMP="-0";/’ tmp/bin/fog #THE -0 change to what you want. -0 is worst compression, -9 is best compression.
    umount tmp
    mv init.gz init.gz.orig
    gzip -9 init
    rm -rf tmp[/code]


Log in to reply
 

371
Online

38975
Users

10712
Topics

101675
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.