DNS Failure - PXE-E53



  • Hi,

    We’ve recently had one of our DCs go down and have moved our DNS onto a different Server. Since this has happened we cannot PXE boot to fog anymore.
    When PXE is loading, it comes up with:
    PXE-E53: No boot filename received.
    I’ve done a search for all the files holding the old IP address of the DNS Server and changed them to the new one.
    I’ve restarted processes and the server multiple times, still the same.
    I’ve changed the FOG_PXE_IMAGE_DNSADDRESS to the new IP in the web util.
    The eth0 interface is also using the new DNS IP.
    I’ve changed all the IP addresses from old to new in the default file on the tftpboot directory.
    I’ve also changed them in the …/lib/common/config.sh which the installfog.sh looks at during the initial install.

    There must be a master config file I’m missing somewhere or an entry which has been written to SQL.

    I havn’t ran the installer again since the change which I’m guessing would overwrite everything. I’m hopeing for other options before I go down that route.

    Cheers.


  • Developer

    Another option is to install the DNSMasq service for proxy dhcp. If you are absolutely positive that all the ip addresses are the same and all the next-server information is correct, the proxydhcp service has saved many of us a lot of trouble. you can install it and see if it has any affect. it is a “pseudo” dhcp server that only operates while pxe booting and will be ignored by your normal network.



  • Hi,

    Yea the FOG Server’s IP has stayed the same. So DHCP option 66 is still point to 10.152.4.110 and FOG_TFTP_HOST has the same IP address also.

    Double checked the ownership on tftpboot and that’s correct


  • Senior Developer

    So the DHCP Server has remained the same, Has the FOG Server’s IP Address changed?

    Under the ( ? ) icon, Choose FOG Settings

    Look for:
    FOG_TFTP_HOST and Make sure it’s pointing at: 10.152.4.110

    Make sure Option 66 on your DHCP Options is also pointing at 10.152.4.110

    I don’t think the PXE_DNS stuff matters for the booting of the TFTP files.

    Also, make sure the ownership of tftpboot on the FOG Server is:
    [code]chmod -R fog:root /tftpboot[/code]



  • Our DHCP Server hasn’t changed so it still has option 66 pointing to the Fog server and 67 pxelinux.0.
    The IP address of DHCP and the Fog server have stayed the same.

    It’s running on Ubuntu 12.04 and yes it’s fog 0.32.

    tftp on the fog server:

    Connected to 10.152.4.110 (10.152.4.110), port 69
    getting from 10.152.4.110:pxelinux.0 to pxelinux.0 [netascii]
    Received 16967 bytes in 0.0 seconds [3607122 bit/s]


  • Developer

    Running the installer again would allow you to “upgrade” your current set up. All current images, folders, and image stores will remain and so will your database. The only thing that will change would be config files like you are talking about editing manually.

    The ONLY instance where a FOG installation will be “deleted” and a new installed, is if you manually rename or remove the folders.

    THAT BEING SAID. When your DC went down, did you also change your information to point to your new fog IP address? (Option 66, also called next-server)

    Which Linux version do you have fog installed on? Also what VERSION of fog , I will assume 0.32 but please confirm this for me!

    Did you check to make sure that the TFTP service is actually running and serving? you can test this from the command line of a working station on the same network.

    From your FOG server test out tftp
    [code]tftp -v X.X.X.X -c get pxelinux.0[/code]
    or run this command on a windows box
    [code]tftp x.x.x.x get pxelinux.0[/code]

    Let me know what the output is


Log in to reply
 

443
Online

38940
Users

10697
Topics

101495
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.