Unable to move /images/dev/macaddress to images/name-of-image



  • I am new to Fog and am still learning. I had my server running and everything was going great. Then i had to shut it down to physically relocate it and that is when i started having issues. Now it will give me this error everytime i try to upload an image. I’ve tried everything that google has to offer: chmod -R 777, chown -R fog:root, verifing the ftp password. im stuck. any help would be greatly appreciated.



  • Made sure that the node user/pass, tftp user/pass, and linux user/pass were the same. My Fog server is now back in business.

    Thanks!


  • Senior Developer

    The username and password settings dealing with images should be under the Storage Management Page.

    Choose All Nodes, select your node, Management Username and Management Password.

    Verify that they are set properly. These should be set to the local fog user account on the fog server (unless your storage node is separate from your fog server).



  • [quote=“BPSTravis, post: 23994, member: 22444”]check the actual config file and make sure your tftp/ftp username and password are set correctly in /var/www/fog/commons/config.php

    Then try resetting the password for the unix user fog:
    sudo passwd fog

    then enter your password twice as it shows in the config file.[/quote]

    Tried this, same results.


  • Developer

    check the actual config file and make sure your tftp/ftp username and password are set correctly in /var/www/fog/commons/config.php

    Then try resetting the password for the unix user fog:
    sudo passwd fog

    then enter your password twice as it shows in the config file.



  • I’m having a similar issue. I’ve been running fog 0.32 on Ubuntu server 12.04 (kernel 3.5.0-45) for about 9 months but recently i started having problems.

    Image uploads are starting and apparently completing fine (the uploading client finishes and give a Task Completed message) but then the machine does not shutdown or reboot. Instead, it begins displaying an asterisk every 5 seconds or so.

    The active task in “Task Managment” does not complete, and the image (in /images/dev/macaddress) does not get moved to /images/imagename

    I thought this was related to the drive in the first machine being an AF (4k) drive, but I tried again on an older model which i’ve successfully imaged in the past and it’s now doing the same.

    The image folder permissions are 777 and the user and group are fog:root. I’ve verified that the tftp credentials in fog settings are correct.

    Any ideas?

    Thanks


  • Developer

    [quote=“Boygenius, post: 23844, member: 22716”]Any update/work around on this? I have 125 laptops ready to deploy… :([/quote]

    Have you gave the latest 33b release a try? It uses part clone which will work with 4k drives. Also you could use raw image in .32 but it’s very slow.



  • [quote=“reefcrazed, post: 22473, member: 22026”]Mine was doing this, I went through everything and I knew everything was perfect. What it ended up being was these new advanced format drives. I tried an old drive, imaged like a champ. Any newer drive will not image at all. I was getting the messages saying it could not move the image.

    So what is the status of 4k drives guys?[/quote]

    Any update/work around on this? I have 125 laptops ready to deploy… :(



  • Mine was doing this, I went through everything and I knew everything was perfect. What it ended up being was these new advanced format drives. I tried an old drive, imaged like a champ. Any newer drive will not image at all. I was getting the messages saying it could not move the image.

    So what is the status of 4k drives guys?


  • Senior Developer

    Can you manually FTP the images/dev/macaddress to images/name-of-image?



  • no it does not



  • i tried again to upload and it did not work


  • Senior Developer

    Does images/name-of-change already exist on the server?



  • yes i have .mntcheck in both images and images/dev
    i was able to touch both


  • Senior Developer

    yes, but do you have the permissions as:

    [code]chmod -R 777 /media/Images/images[/code]

    Also do you have the .mntcheck files in both images and images/dev
    [code]touch /media/Images/images/.mntcheck
    touch /media/Images/images/dev/.mntcheck[/code]



  • Our mount point for the images is different it is /media/Images/images
    touch /media/Images/images works


  • Senior Developer

    Can you open a fog session to the FOG Server and, in the /images/ directory touch a file to see all is working?



  • I have it set up as the same username and password


  • Senior Developer

    The fog username and password need to be the one that is actually on the FOG server, not the one you use to login to the GUI. While it sounds like this was working, did the password change for the fog user?



  • Thank you for responding to help, Tom.

    when i type that command i get: vsftpd start/running, process 943


Log in to reply
 

394
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.