• Hi everyone, i am a bit desperate now i’ve tried almost every single tutorial but still no luck.

    problem : fog server will only create a d1.mbr file for my windows 7 image then just restart.

    According to one of the tutorials all i have to do is to run the fogprep.exe in the computer am trying to upload the image from. On my server just create an image with MULTIPLE PARTITION IMAGE- SINGLE DISK ( NOT RE-SIZABLE ).

    I have been using fog project for almost two years with windows xp with no problems.

    Do i have to do something to the Bios?( gigabyte board )
    Is it really necessary to use sysprep ?( i did not have to do it for windows xp, i installed a lot of software in my xp image an upload the who thing, then since i used this for work i just created a different image for each department with the software that the need )


  • Well i found i work around, but it will work on my favor only i guess, not as a general fix to the issue. Technically i just did the same thing but in a different and older bios ( INTEL board, dual core CPU, 4 GB RAM, 80 GB SATA )

    My goals :

    1 Create a Windows 7 image ( regardless of the hardware)
    2 Be able to install this image on different hardware.
    3 Different images for different departments within the company.

    What i did :

    1 Since i was having too many issues with a GIGABYTE board UEFI ready, which i am still not fully familiar with. I decide to get the image from a different board.

    2 i installed the image on to a brand new i5 Gigabyte board with 500 GB HD. which it did, only that i found something interesting.

    • In windows XP (single disk NTFS only) fog will used the entire disk and just use whatever was used by windows for the installation( EX 10 GB )
    • In windows 7 ( Multiple partitions single disk ) i created the image from a 80 GB SATA HD and fog will use the 80 GB out of the 500 GB HD that i deployed to and leave the rest
      unallocated, which for my purpose is really not a bad thing because i can just manually format that partition and use is for local data storage ( not what i wanted but hey )

    3 Once i get it working i will create a a different image for our many different departments ( i did this with windows xp and works perfect for me ) this way i am just down to only
    some windows updates and join the computer to the domain.


    Now am facing a different issue, i i am just going to mentioned because all of you have been really helpful and i hope my findings help someone else later…

    In windows XP i would just deploy the computer and after i was done before joining the computer to the domain i would just run NewSID which will modify any SID entries to avoid any SID
    conflicts in my environment. It worked perfect and never had a single issue… Now i ran the NewSID in windows 7 ( as Administrator ) then after the computer restarted windows will not boot again.

    I can try to find a work around to this but i don’t want to have to do this all the time. I looked for a NewSid alternative for Win7, but the closes is to run sysprep with the unattended file which i was trying to avoid since i did not have to deal with it in widows xp but i guess i have to.

    Again very much appreciated and i will post later my findings !!!

  • I’m trying to work on getting a fluid mbr/gpt backup so we still maintain the partition tables, problem is figuring out it truly is gpt or mbr. I’m almost certain that your drive is partitioned using GUID Partitioning (gpt) which is why you’re running into issues.

  • Just to keep posting, just to test i did the same procedure on a different hardware, an INTEL board and i was able to upload the image to the server. This is definitely something UEFI, MBR, GPT related. I will keep playing with the gigabyte bios, just wanted to provide more inf, hopefully this can save some time for someone else.

  • I’m only thinking, maybe if you have a live CD, can you try running gparted? It should be GUI based and should also allow you to change the partitions as you deem necessary. I don’t know how it will affect data as your system seems to work fine, it just won’t image.

    Of course, you should be able to do this with windows as well. Below is a link I found on converting GPT to MBR.


    Hopefully this will help you out.

  • Any ideas on how to fix this ? 😞

  • So your problem appears to be an issue with the way the system installed the OS.

    It seems to me that it created the same end sector and start sector for both partitions.

  • Thanks Tom, here it is what i have :

    Thanks need2 as well, i will try disabling UEFI as well… trial and error !!!


  • Moderator

    I personally have not yet gotten FOG working in a UEFI environment, so I would definitely say disable UEFI if you are having troubles. Not to step on Tom’s toes… do the 'fdisk" thing too.

  • You need to boot into the fog stuff. Boot the system you’re having problems with, at the PXE Boot Menu Choose Debug mode, then run that command.

  • Thanks a lot Tom … sorry for the question but am trying to run fdisk and i get this :

    ‘fdisk’ is not recognized as an internal or external command,
    operable program or batch file.

    I don’t think i can use this tool on windows 7 or how can i run it ?

    fyi i ran it as an Administrator if that makes any difference.

  • Boot the system in question into debug mode.

    Perform fdisk -l and post results please.

  • Thanks Again, this is more inf about my hardware !!!

    [ATTACH=full]533[/ATTACH][ATTACH=full]534[/ATTACH][ATTACH=full]535[/ATTACH][ATTACH=full]532[/ATTACH][ATTACH=full]533[/ATTACH][ATTACH=full]534[/ATTACH][ATTACH=full]535[/ATTACH] [ATTACH]533[/ATTACH][ATTACH]534[/ATTACH][ATTACH]535[/ATTACH]


  • Thanks everyone,

    Tom Elliott
    To be quit honest i am not completely familiar with the type of partitions DYNAMIC / GPT . I will do some research to be able to provide more inf.

    i read somewhere that i might need to disable [SIZE=14px][FONT=Segoe UI]COLOR=#454545 ???[/COLOR][/FONT][/SIZE]


    As i did in windows xp. I am using a GIGABYTE board as my base image, i am not at the office still but as soon as i get there i will provide exact model !!!

    Again very much appreciated !!!

  • Moderator

    I am also curious about the hardware this Windows 7 is running on. I know a couple of Dell installs have given me headaches due to their weird diagnostics partitions.

  • Have you checked the partitions to make sure they’re not “Dynamic” or GPT disks? d1.mbr wouldn’t even work in that case either as the partition table can’t be created properly.