DELL E6440



  • Hello,

    today I was trying to take an image from a new DELL E6440 laptop, but somehow it wasn’t able to start up fog.
    I ran into all kind of problems and I seem to be stuck …

    First problem: There was an error caused by the USB 3.0 chipset, which caused the system to stop. After disabling the chipset in the BIOS, the system continued to boot.

    Second problem: There was an error while mounting the hard drive. Returned to the BIOS and selected another Drive emulation (changed it to ATA instead of e-raid). The system continued to boot …

    Third (and last) problem: the system now halts on an error concerning the LAN-drivers. Apparantly it can not load the correct drivers for the network card thus stopping the startup.

    Does anyone have an idea on how to solve this? My company won’t like it if I have to disable all the new features in the BIOS in order for the imaging to work. Enabling them afterwards is not an option, because FOG allows us to let users connect their own devices and we can control them from abroad. If we have to change the BIOS before and after every installation, the advantages of FOG will disappear.

    wkr,

    David Van Uffelen



  • Problem is solved!

    I have updated the kernel (Other Information - Kernel Updates - 3.8.8 Core) and reverted the settings in /etc/exports and now the image is running …

    Thnx very much for the advice!


  • Moderator

    Choose the system information option from the FOG menu, then check system compatibility. Make sure both network and HDD pass.



  • Just made the adjustments, but still no luck…


  • Senior Developer

    In your /etc/exports file, can you add to:

    /images *(…) Add at the end, inside the parenthesis, fsid=0
    /images/dev *(…) Add at the end, inside the parenthesis, fsid=1

    Then restart the nfs-kernel-server service with:
    [code]sudo service portmap restart
    sudo service nfs-kernel-server restart[/code]



  • Ok, I’m not sure on how to gather all the information you need, so I’ve included some screenshots on how far the systems starts. At this moment we have turned back the settings for the hard-drive. So we are back at error #2.

    We are still using the kernel that was included in the default installation. I assume there is a way to update that kernel to a new version?

    [url="/_imported_xf_attachments/0/524_WP_20140129_006[1].jpg?:"]WP_20140129_006[1].jpg[/url][url="/_imported_xf_attachments/0/525_WP_20140129_004[1].jpg?:"]WP_20140129_004[1].jpg[/url]


  • Senior Developer

    Still need some more information.

    You say the problems exist before FOG Starts to pull/push an image from the computer. Does this mean that it’s booting into FOG, or it just gives the menu but never loads the bzImage/init.gz file?

    If it is booting into fog, does it not find the hard-drive or network?

    Have you tried other kernels? I’m guessing you are just using what came with 0.32, which if memory serves, is 2.6.39.2 for the kernel. I’ve got a kernel built on 3.13 and has all possible linux drivers for networking installed. It also has many options for Hard Drive such as SATA, SAS, PATA, RAID, etc… so it may cover all of your bases here.

    It is possible to upgrade ubuntu without reinstalling FOG again, but if you don’t remove FOG and you perform the installfog.sh script again, it will not “reinstall” it will just use your original settings and update as and where necessary.



  • Hi guys,

    First of all, the problems exist before FOG starts to pull the image from the computer. (Since this is our first device of that type, we’ll need to upload a working image first).

    @ Tom:
    Currently we are using FOG 0.32 on a Ubuntu 12.04 server (32-bit). Is it possible to upgrade Ubuntu without having to reinstall the whole thing again? And will that have an impact on the drivers during the PXE boot?


  • Moderator

    Yeah. I’m confused. Are you getting these errors when FOG tries to load the bzImage/Init or after the imaging process completes and Windows is trying to boot?


  • Senior Developer

    And you’re sure this is specific to FOG rather than Hardware?

    What version of FOG are you running?

    Have you tried other kernels?


Log in to reply
 

409
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.