Scheduled tasks don't work if the host machine is not on.



  • Title says all. I can manually wake up computers fine by using the Wake Up command from the Tasks page. Any ideas on how to troubleshoot and solve this?


  • Moderator

    In windows, you need to configure the card. You can either go through device manager or network and sharing center, change adapter settings, properties of the NIC, click the “configure” button just below the “connect using” box. It may be on the advanced or power management tab.

    “Wake on LAN” “Wake system from S5” “Allow this device to wake the computer” or similar. There may be other choices about only allow magic packet, just depending on the card and the driver.

    If you’re using the default driver installed by Windows, your choices may be more limited. Try to get the board/chipset specific driver for the LAN card from the manufacturer.



  • [quote=“chad-bisd, post: 21727, member: 18”]
    Some desktops I have require me to configure the BIOS to WOL, then configure the adapter in Windows to allow WOL[/quote]
    How do you go about doing that in Windows?
    I’ve already enabled WOL in the BIOS on my computers (they are Acer Veriton S661 btw). For me it’s pretty important to get this feature working, since it will enable me to restore computers at night.


  • Moderator

    My success with WOL is spotty at best. Some of the computers I have wake up without much configuration. Just go into the bios and enable WOL.

    Some desktops I have require me to configure the BIOS to WOL, then configure the adapter in Windows to allow WOL, then they only work if you soft shut down the machine (Start->Shut Down). If I turn the machine off via the power supply, or if I unplug the system to move it, WOL no longer works until Windows is booted and the system goes back into soft shutdown.

    All that is to say, play with the settings in the BIOS and in the OS to see what’s going on. And lest I forget, WOL may not work across subnets without additional configuration.



  • [quote=“Tom Elliott, post: 21660, member: 7271”]What version of fog? I’m going to guess 0.32?[/quote]
    Correct. FOG 0.32 running on a Debian 7 server.

    [quote=“chad-bisd, post: 21661, member: 18”]I don’t know if scheduled tasks include the WOL call that non-scheduled tasks have.[/quote]
    Well, manual tasks related to imaging also fail to wake up the computers. Only the Wake Up command works.


  • Moderator

    I don’t know if scheduled tasks include the WOL call that non-scheduled tasks have.


  • Senior Developer

    What version of fog? I’m going to guess 0.32?


Log in to reply
 

430
Online

38951
Users

10701
Topics

101530
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.