• Also, you shouldn’t need net specify the systems. At the point that the system’s loaded, it can’t interpret hostnames anyway (NO DNS SERVER) so it would seem like me it should fail at that point.

  • Try putting this in your exports file:
    [code]/images *(ro,sync,no_wdelay,insecure_locks,no_root_squash,insecure,fsid=1)
    /images/dev *(rw,sync,no_wdelay,no_root_squash,insecure,fsid=2)[/code]
    Then restart rpcbind and nfs-kernel-server:
    [code]sudo service rpcbind restart
    sudo service nfs-kernel-server restart[/code]

    Basically the fsid just tells the system in which order the nfs share needs to be mounted. It creates less confusion in the long run.

  • Not sure if this makes a difference, but the dhcp server was off during the above install so as not to conflict with the campus DHCP server.

  • Here is the output, Tom. The errors encountered during the apt-get mirror those I saw when installing FOG. As for the /etc/exports file, the hostnames are two of the computers on the network (not the server). Before I edited the file there was only one set of arguments for each folder, neither of which had subtree_check, and they were preceed by an * .


  • also, what’s the output of:
    [code]cat /etc/exports[/code]

  • Mike,

    If you try to install NFS manually, what kinds of errors do you run into:
    [code]sudo apt-get install nfs-kernel-server nfs-common rpcbind[/code]

  • Reinstall cured the dhcp issue and once again I can PXE boot. However the NFS server did not install properly. The package was installed (and came out ok during the check), but was not configured and it returned an error at the end when the services were set. There was also an error about nfs-kernel-server, nfs-common, and rpcbind not being configured correctly due to dependencies or something like that. It flashed by during the install. Unfortunately I did not think to take a picture before restarting (which did not fix the problem). I did attempt to configure NFS using[URL=‘http://forums.debian.net/viewtopic.php?f=16&t=42078’] these directions[/URL], to no avail.

  • I don’t think you need to have anything extra installed at OS install time, but it wouldn’t hurt anything either.

    I do think a reinstall would help. You don’t have to start from scratch either. Just rerun the installer and it will find your settings file under: /opt/fog/.fogsettings

  • After some thought two questions have come to mind. First, are there any specific components (web server, file server, MySQL database, etc) of Debian that should be installed when the OS is? Second, would reinstalling FOG solve my problems?

  • I followed the directions located [URL=‘http://forums.debian.net/viewtopic.php?f=16&t=42078’]here[/URL] to setup NFS and now the dhcp server won’t start. When I go to do so an error message saying that the service failed to start. It being 5 PM I am going home and will deal with this more tomorrow.

  • It seems that NFS is not configured or set up correctly on mine. Naturally this has to be something nobody else has experienced. I am going to look into doing so.

  • not that I’m aware of. I’m running Debian 7 on one of my VM’s and it has no issues with FOG. It’s not my main server, but everything has been tested and it works perfectly fine.

  • Seems that portmap has been replace by rpcbind in Debian 7. Any attempt to install portmap defaults to installing rcpbind instead. I can’t comment on the significance of that, but there are some manuals for setting up NFS on Debian which might help (such as this [URL=‘http://www.debianhelp.co.uk/nfs.htm’]one[/URL] which talks about editing the /etc/exports file). Seems worth a shot. I’m not going to have to start over with a new OS am I?

  • Tom that should be possible. If I turn off DHCP and TFTP the I can connect the server to the campus network/internet without causing disruption just long enough to install port map.

  • I don’t think wireshark will help.

    Can you uninstall rpcbind and install portmap on your system?

  • Apt-get purge (twice) followed by a restart seemed to rid me of it. At least whereis does not return any results. But the same error still pops up when upload is attempted. Also I checked with the web interface and under disk information it says “cannot connect to default member” and when I click on that FOG tells me it cannot pull server information. Not sure if that’s related though. Do you think the wireshark analysis will help? I can try e-mailing it to you (since the forum will not let me post it here).

  • You could try apt-get removing it, let it spit the errors it needs to, but after it’s uninstalled, restart the system. This way you can be sure everything cleaned out.

  • Turns our firestarter was not totally removed. Trying to do so returned a number of errors relating to “FogMulticast” and rmnologin. They go on for a lot longer than in the picture. It looks like that software should never have been installed.


  • Right,

    That’s because it can’t connect with your nfs server. NFS is only mounted on download/upload tasks from unicast modes.

  • Well I completely removed firestarter because it was causing problems. As far as I know IPTables is not active, but I will double check. Also I was able to register the computer and enter debug mode yesterday. So far only uploading an image is causing an issue.