Fog issues with DELL Optiplex 3020



  • ok thanks I will try it


  • Senior Developer

    Try my kernel, but download the 32 bit

    [url]https://mastacontrola.com/fogboot/kernel/bzImage32[/url]



  • I am having an issue with the dell opt 3020 as well. After I select full inventory of the opt 3020 the screens goes blank and I cant see any text after that or see when I can type in the pc’s name and hit enter to continue with the registration process. What I do is wait a few minutes and type in my pc name and hit enter 8 or 9 times and then the registration process starts but I am doing this blind because you cant see anything. Also when I am downloading an image the opt 3020 the screen will go blank and I can not see the process of the image. any ideas?



  • .



  • Thank you Tom, that did it. We have lift off.
    I’m glad I didn’t have to recreate the “golden” system from scatch.
    You’re the man!


  • Senior Developer

    You need to either change the image type from (Single Disk-Resizable) to Multi-Part (All or Single Disk) or recreate the “golden” system from scratch.

    Your issue is not a kernel, or root password error specifically.



  • Hi Tom,
    I have the same issue with the Dell 3020’s.
    I am unable to access the root password. I have upgraded the kernel to 3.8.8 Core. But am still getting an error. Any recommendations on getting by the root password to upgrade the Kernel?[ATTACH=full]559[/ATTACH][ATTACH=full]560[/ATTACH]

    [url="/_imported_xf_attachments/0/559_photo 1.JPG?:"]photo 1.JPG[/url][url="/_imported_xf_attachments/0/560_photo 2.JPG?:"]photo 2.JPG[/url]


  • Senior Developer

    So Joel,

    Does my kernel not work with your system?



  • Disregard my post. I updated via the web console to [FONT=Ubuntu][COLOR=#333333]Kernel - 3.8.8 Core and it let me register the computer. I am trying to upload it now.[/COLOR][/FONT]



  • Tom,
    I just followed the kernel instructions you posted. I am still having the issue. It does the same thing when i tried to follow Jaymes’ post above. Any ideas? Running fog .32. Optiplex’s up to 780 worked fine prior to the kernel update, i have not tried any other model since.



  • That worked for me. Thanks much. We have a 350 PC deployment coming up and they can now all be deployed thanks to you. Cheers!


  • Senior Developer

    It most definitely looks to be a kernel issue.

    I’ve added many, many things to my kernel if you want to give it a shot.

    The file goes in:
    /tftpboot/fog/kernel/bzImage

    Perform these steps to download it.

    1. Log in as root (or with a user you can use sudo with) to your FOG server

    2. Open a terminal.

    3. Sudo up to root, or if you are root already, just skip this step:
      [code]sudo su -[/code]

    4. change directory to the kernel location.
      [code]cd /tftpboot/fog/kernel[/code]

    5. Copy the original kernel as original, just in case.
      [code]cp bzImage bzImage.orig[/code]

    6. Copy the the kernel from my server:
      [code]wget --no-check-certificate https://mastacontrola.com/fogboot/kernel/bzImage32[/code]

    You should be good to go, test and hopefully all is working for you.


  • Developer

    Check the compatibility. The test will help us to find the failing component so we can rectify it.

    I’m leaning towards the kernel needs to be updated. If I were you, I would look into the kernels Tom has been uploading he does an amazing job of packing all the stuff up in a good working lightweight kernel. When I build them I normally just check all the things that look necessary and then it takes AGES to load :p

    [FONT=Tahoma]To [/FONT]Run a compatibility test.

    [FONT=Tahoma]From the fog PXE boot menu, you will see:[/FONT]

    [FONT=Tahoma]Boot from hard disk[/FONT]
    [FONT=Tahoma]Run memtest86[/FONT]
    [FONT=Tahoma]Quick host registration and Inventroy[/FONT]
    [FONT=Tahoma]Perform full host registration and Inventory[/FONT]
    [FONT=Tahoma]Quick Image[/FONT]
    [FONT=Tahoma]Client system information[/FONT]
    [FONT=Tahoma]Debug Mode[/FONT]

    [FONT=Tahoma]A. Choose Client System Information[/FONT]

    [FONT=Tahoma]B. Your computer will load another menu and it will look like this:[/FONT]

    [FONT=Tahoma]1.) Reboot[/FONT]
    [FONT=Tahoma]2.) IP Information[/FONT]
    [FONT=Tahoma]3.) Partition Information[/FONT]
    [FONT=Tahoma]4.) Check FOG compatability[/FONT]
    [FONT=Tahoma]5.) Ping a Host[/FONT]
    [FONT=Tahoma]6.) Display MAC Address[/FONT]
    [FONT=Tahoma]7.) Show DMI Information[/FONT]

    [FONT=Tahoma]C. Type 4 and press Enter[/FONT]


Log in to reply
 

340
Online

6.2k
Users

13.6k
Topics

127.9k
Posts