Dell Precision T3500 Unable to Upload Image

  • FOG 0.32. Cannot upload an image from a Dell T3500. I get the typical unknown/unsupported BIOS error, which I get with a variety of other Dell models. Usually I can find a set of settings to work with every model, but the T3500 also spits out a Fatal Error: Unable to locate hard disk. It will boot to PXE fine, but throws that error about the time I would expect the upload to begin. This is a single disk system. I’ve tried all of the available image options but all will fail. The image is a fully patched Win 7 image and the FOG prep installed. A13 BIOS.

    Has anyone had any success imaging the T3500? If so, any suggestions on what to try here? Thanks.


  • I’m sure the T3500’s I have don’t have dual video cards but I’ll double check again tomorrow, its not been too much of a hassle anyway as I only have a few to image.

  • Seth,

    I just got a batch of Dell Precision T3500’s and had some issues with uploading. I’m running FOG version 0.30. First issue was my T3500’s have dual video cards and the one card caused a driver issue with FOG’s inventory boot up. I removed the card and it allowed me to do the full host inventory. The second issue I had was it would upload the first two partitions and get 20% into the third partition and fail out. I read your post about changing the drive setting. This reminded me about a similiar issue with a Dell Latitude laptop at a previous job with FOG. We had to change the drive setting to ATA from AHCI and then rebuild the image.

    I changed the drive setting to ATA on my T3500 and reinstalled Windows 7 and ran FOG prep. The image uploaded fine. I just deployed it to one of the other T3500’s and it worked fine.

    Thanks for the memory jog and hope this helps with your T3500.


  • Issue is probably sorted now, but for anyone searching T3500 this might help with other issues
    I’ve just imaged a batch of Precision T3500 machines. There was no issue with picking up the drives however mine are standard SATA with single drives. I did get corruption on the screen when trying to register the machine (shown below) but did manage to get around it but just doing a quick registration and then changing the hostname/details within the web interface.

  • Update: The disk drives in these machines use a variation of a connection for SATA. The power and data are combined into a single plug. The cable then runs to a back plane off the main board. You cannot use standard SATA connectors on these drives. In short, this prevents using another known-good machine to run the image.

    I have also tried updating to the newest kernel, but I see the same behavior with the failure to recognize the hard disk. I’ll post a solution if I find it.

  • Really good suggestions. Besides the default drive setting of RAID On, I tried the other two options for RAID autodetect w/ATA and AHCI but neither of those work. I did a boot to PXE without a job scheduled, and ran through the available utilities in the FOG client. The compatibility test indicates that “This computer is NOT compatible with FOG!” … Network passes but disk fails. I am instructed to try a newer kernel through Kernel Updater in the FOG management interface. I will try that in the coming days. Compatibility test photo attached.

    I am also going to try your suggestion of using another box. I will have some Optiplex 755 or 745 boxes coming through on normal rotation, which work pretty well. I will give that a shot and post the results.

    Thank you for the suggestions.

  • Never tried a T3500, but can you do the deploy w/ debugging? I’d be curious to see if from the command line you’re able to see /DEV/SDA or whatever else. This might help point to where the problem might be.

    Could there be any other devices that are plugged in that might be recognized as some type of storage and throwing off FOG? Or maybe the controller mode (RAID, SATA, AHCI)?

    A workaround I’ve been able to do is just move the drive into another model of computer you’ve been able to upload from and capture the image from there, since FOG is only grabbing the image and doesn’t care what the actual computer is (as I understand it, anyway). Well, unless it’s a T3500 I guess. 😄 This would at least allow you to get the image onto the server.

    My guess is that deploying said image to the T3500 would be a problem as well.