Issue with image creation on brand new HP machines - please help!



  • Hello,

    I have been using fog for a relatively short period of time but have had much success. I work at a high school and we have thousands of computers all working on fog with 10+ different machines with working images.

    I have recently purchased multiple new computers to build new computer labs. They are all the latest and greatest HP has to offer. I was unable to find a kernel that would work with these new computers (HP Elitebook 850 laptops and HP ProDesk 600G1 desktops). Because I could not find a working kernel, I decided to try to create a custom kernel to get these to work. I was relatively successful as I was able to get the Elitebook 850 to now start the process of pulling a fog image as it now seems to recognize network drivers. This computer model is currently my focus.

    This is what I now run in to:

    1. The image will begin to pull, but it attempts to pull the partition size as the entire 465GB of usable space on the hard drive. If I would allow it to continue it seems as if it would pull a 465GB image. This seems backwards, almost as if it is trying to pull the empty space as an image instead of the operating system. I have tried a single partition and multiple partition image, both have the same result. Any advice would be appreciated.

    2. The HP ProDesk will not properly function in fog at all - it gives me this a few seconds after the fog network boot UI shows up “GPT-formatted disk - press control alt delete to reboot”. When I received these computers I used the windows disk that came with to format the hard drive and installed windows from scratch. I am not super familiar with disk formatting types and what works best in fog, but I was surprised to see this. Any advice would be appreciated.

    The kernel I used to make the custom fog kernel was the latest kernel from [url=“http://www.kernel.org”]www.kernel.org[/url]



  • Dekar, Try using this. [url]http://fogproject.org/forum/threads/win-7-image-upload-no-partitions-found.1130/#post-5714[/url]

    All props go to Madeyem for this. This fixed my issue. I hope it fixes yours.


  • Senior Developer

    All,

    This seems to be the partitioning scheme being used. It seems to be using GUID partitioning rather than the standard fdisk paritioning.

    The reason recreating the system worked is it’s not using a regular partitioning.



  • I hope it works for you. The Pro 4000 I have was formatted and partitioned using the Windows setup disc.



  • After messing around for a while I was able to get the EliteBook to pull an image successfully. I am not 100% sure how I fixed it (or why it worked). All I did was format the HDD using the windows 7 disc and allow it to use its default settings when creating the new partition (including the system files partition). I created the image as a multiple partition non re-sizable image in fog and pulled it and it just worked. I deployed it successfully as well.

    As for the ProDesk, I am still working on it. I don’t know how or why the hard drive became GPT formatted (it’s only a 500GB hard drive) but it did. I pulled it and put it into a working machine as a 2nd hard drive and tried to re format it as MBR, but windows would not allow it. I used partition software to unallocate the space and cleaned it. I was then able to reformat the drive as MBR. I have not yet tried to pull an image into fog with it, more to come.



  • I too am having issues with HP desktop machines. At my job we are using HP Pro 4300, which are about to go end of life. I’ve uploaded images before on these models, however, my vendor told me they changed their SKU and it’s a newer ‘version’. Ever since then, I can’t upload an image. I can register it in Fog, but when I try to push the image up to the server I get the error that there are no partitions found. Then it reboots. We’re about to update our stock with the HP ProDesk 600 models too.


Log in to reply
 

458
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.