Ubuntu Installation for FOG (12.04+)


  • Developer

    [CENTER][SIZE=5][B]USE AT YOUR OWN RISK: We are not responsible for any damage to yourself, hardware, or co-workers. Use at your own risk. This is a set up that was proven to work in at LEAST 3 test environments. Any misuse or replication of this walk through in any other form is STRICTLY PROHIBITED.[/B][/SIZE][/CENTER]
    [CENTER] [/CENTER]

    [INDENT=1][B][SIZE=4]Ubuntu 12.04, 12.10, 13.04, 13.10[/SIZE] – SETUP and INSTALLATION[/B][/INDENT]
    1.) Insert your Ubuntu 12.10 installation disc and reboot the computer. Boot from the disc, Ubuntu will launch in it’s live form for you to get a feel for the OS or install. You will be presented with two options, install Ubuntu or run a Live instance. Click the “[U]Install Ubuntu[/U]” Option when it is presented to you at the Welcome screen.

    2.) Proceed with a normal install of Ubuntu, I allow it to Download the Latest updates while installing by Ticking the [U]checkbox[/U]. Ubuntu will now examine hardware and alert you of any previously existing operating systems, I delete all remaining old information and supply it with new. During the install Ubuntu will like for you to set your timezone, Layout, and some user information such as a user name and password, I use the user Rooty, or tooR. In the latest flavors of Ubuntu [B]the Root user account is disabled[/B], after installation I will show you how to enable it. Ubuntu will copy files and begin the installation.

    3.) After installation is complete, reboot. Remove the installation disc and press enter, your computer will reboot and boot up in it’s new operating system that is much faster and more durable than it’s squishy, virus prone, partners. Log in with the Password and the User you specified during installation.

    [INDENT=1][B]Enabling Root[/B][/INDENT]

    4.) Ubuntu has changed since it’s earlier years, no you are presented with Unity, a desktop GUI that in my opinion would be great if you had a touch screen, click the top left hand icon called “Dash Home” in the text box type “terminal” and select the first program called [I]Terminal[/I]. Type “sudo passwd root” without the quotes and press enter. First enter your user account password, next supply a password for the Root user and press enter, Retype your password to verify and press enter, while typing linux will not display any input, this is fine, please type your password and press enter. The terminal will return [U]Password updated successfully[/U]! Type ONLY the underlined part “[U]sudo sh –c ‘echo “greeter-show-manual-login=true” >> /etc/lightdm/lightdm.conf’[/U] “and press enter. Restart the machine by going to the gear in the top right hand corner and clicking, a menu will appear, second from the bottom is “[U]Restart[/U]”, Click it, and then click Restart in the dialog! Back at the login screen click “[U]Login[/U]” and type root into the first box and your password in the second box and log in.

    [INDENT=1][B]SETTING STATIC IP AND INSTALLING FOG[/B][/INDENT]

    5.) Click the “[U]Dash Home[/U]” icon again, in the text box at the top type “[U]Network[/U]” and select the first icon in the list displayed as “[U]Network[/U]”. Select Wired and click Options. Select the “[U]IPV4 Settings[/U]” tab and change the method from Automatic to Manual, Add, and supply the server with a proper IP address and information. Click Save. Your connection will reconnect.

    6.) Next click on FireFox and in the browser navigate to the webpage [URL=‘http://www.fogproject.org/’]http://www.fogproject.org[/URL] and follow the download links to download the latest version of FOG, at the time of writing it is 0.32. Right mouse click and select show in folder and close your browser and all other open windows. Move the file to your desktop if you haven’t already. Right mouse click and select “[U]Extract Here[/U]”.

    [B][SIZE=4]GIVEN THE DATE OF THE FOG 0.32 REVISION SOME PACKAGES ARE NO LONGER SUPPORTED AND MUST BE UPDATED WE WILL DO THIS FIRST!!![/SIZE][/B]

    7.) Click on the “[U]Dash Home[/U]” Icon again, type “[U]Terminal[/U]” into the search box and select the first Icon. Now we are going to install FOG and configure it. We will do the installation through the Terminal with a number of commands, please follow them and remember to press enter after each line. Note the Capital and lower case letters, linux is VERY picky, “A” is not the same as “a”.

    cd Desktop/ (enter)
    cd fog_0.32/ (enter)
    cd /packages (enter)
    wget [url]https://svn.code.sf.net/p/freeghost/code/trunk/packages/udpcast-20120424.tar.gz[/url] (enter)
    rm -f udpcast-20071228.tar.gz (enter)
    sed -i ‘s:udpcastout=“udpcast-20071228”:udpcastout=“udpcast-20120424”:’ …/lib/common/config.sh (enter)
    sed -i ‘s:udpcastsrc="…/packages/udpcast-20071228.tar.gz":udpcastsrc="…/packages/udpcast-20120424.tar.gz":’ …/lib/common/config.sh (enter)
    cd …/bin/ (enter)
    sudo ./installfog.sh (enter)

    Type 2 and press Enter for Ubuntu installation.
    Type N and press Enter for Normal installation
    Supply IP Address, it SHOULD be the static IP address you set up earlier, if it is not please revert to step 5 and try again.
    Type Y and press Enter setup DHCP Server.
    Enter the IP Address associated with your DHCP Server
    Type Y and press Enter to set up DNS.
    Enter the DNS Server address and press Enter.
    Type N and press Enter to leave the default Network Card the same.
    Type N to disable DHCP Service.
    Note that it tells you that in order to use your PXE server you have to run a few commands on your DHCP server, this is not entirely true, but it definitely helps, this will point your clients to your server, or you can disconnect your server from the outside world while you image.
    Type N to not install Additional Languages.
    Type Y and press Enter.
    Next it will verify the settings, make sure everything has been entered correctly.

    Fog will begin its installation.
    Press Enter and begin the MySQL Server setup.
    I set up Fog with default passwords for MYSQL and users, you can supply information if you like, just make notes.
    Type a password for the “root” user and press enter.
    Type the Password again and press enter.
    Type the Password again and press enter.
    Type Y to send your install information to the Project, and it will take some time to complete.

    8.) Now we need to set up the web GUI for FOG. Open your browser and navigate to [url]Http://(serveripaddress)/fog/management[/url]. Or click the link in the Terminal window.

    9.) The web GUI will alert you to back up your database for MYSQL Server and install the upgrades, do so and follow the upgrade instructions.

    10.) Next log in, default user name is [B]FOG[/B] and the password is [B]password[/B].

    11.) Click “[U]User Management[/U]” the Second Icon from the Left. Click “New User” on the left and set up a new user. Supply the name, password, and check the “Mobile/Quick Access only” box and press create user. In the PXE menu when doing a Quick Image, you will need to provide the username and password specified here to complete the image process.

    12.) [B][U]Image Management[/U][/B] will allow you to create images, this MUST BE DONE PRIOR TO IMPORTING A HOST TO YOUR FOG SERVER, otherwise you will have to create one and select it later. Click “New Image” on the left. Give the image a name, a description, select “[U]Default[/U]” for Storage, and give the file a name, no spaces. Select [U]Multiple Partition image – Single Disk (Not resizeable)[/U] or [U]Multiple Partition image – All Disks (Not resizeable)[/U] I have never had a problem using these settings. However [U]Single Partition (NTFS, Only Re-sizable)[/U] will work as well. DO NOT use the RAW format, it takes a long time to upload and does so sector by sector. This would be a recommendation if you are backing up a Linux partition. Click Add.

    13.) [B][U]Host Management[/U][/B] will allow you to manually add or manage a host, I recommend using the PXE menu to register your hosts, but if you need to change information or the image type you can do it here.

    14.) Your Fog server is configured and setup, register a host via the PXE menu.

    15.) On your FOG Server in the WEB GUI, click on [U]Task Management[/U]. On the left hand side, select “[U]List all hosts[/U]” click on the “[U]Upload[/U]” arrow for the host you just added. Select when you want the task to run, I set it a few minutes in the future. FOG has the ability to reboot your machine into the PXE menu to begin it’s process, but I simply reboot the computer, fog will find it and begin the image process

    16.) CONGRATULATIONS you now have a working FOG Server and a host image ready to deploy. In order to deploy an Image, boot into the PXE menu and register the host, next select “[U]Quick Image[/U]” and begin the image process, or select the host from the “[U]Task Management[/U]” screen and select “[U]Deploy[/U]” and reboot the workstation after supplying a time to begin the task, the workstation will begin its image process.



  • If anyone wants to do it the manual/gedit/nano way here is what I did:

    /fog_0.32/lib/common/
    gedit config.sh

    where are the udpcast files from the download package?

    udpcastsrc="…/packages/udpcast-20071228.tar.gz";
    udpcasttmp="/tmp/udpcast.tar.gz";
    udpcastout=“udpcast-20071228”;

    You just change the date on the 2nd and 4th lines above from 20071228 to 20120424, save, navigate to /fog_0.32/packages/ and download the new UDPcast :

    /fog_0.32/packages/
    wget [url]https://svn.code.sf.net/p/freeghost/code/trunk/packages/udpcast-20120424.tar.gz[/url]

    With this change, FOG will install/configure correctly on Ubuntu 14.04 with the newer UDPcast.
    But even though it does install/configure correctly, I still can’t get it to PXE boot in my environment… it fails to PXE boot with a TFTP timeout error. I’m going to try it on 12.04 today or soon, but it is strange that it won’t PXE boot at all…

    Thanks,
    D.L.

    PS - In 10.04 and 11.10 everything works great, so I know that it’s not my network setup that is the problem. Somewhere there is a PXE/TFTP/Linux/Ubuntu/FOG compatibility problem in 12.04+


  • Senior Developer

    All,

    Just to help out, hopefully, a little more. Change the sed commands in the tutorial to:
    [code]sed -i ‘s:udpcastout=“udpcast-20071228”:udpcastout=“udpcast-20120424”:’ …/lib/common/config.sh
    sed -i ‘s:udpcastsrc="…/packages/udpcast-20071228.tar.gz":udpcastsrc="…/packages/udpcast-20120424.tar.gz":’ …/lib/common/config.sh[/code]



  • Hi,
    ifconfig lists the network interface it as eth0, is there somewhere else I should be looking?

    Thanks!



  • Thanks for the reply Tom! I will find out…

    It did ask if I wanted to change the default interface from eth0 on installation; not sure if that is plain text or a variable called up from the system…

    You’re the best!

    PS - Happy Friday! Beer’s on me!


  • Senior Developer

    My guess is the interface is the issue.

    What’s the interface elements? Are they eth0,1,2 or are they p5p1,2,3?



  • So I finally got back to this… I combined the knowledge from this thread with the Wiki post on Ubuntu 14.04 found here:

    [url]http://www.fogproject.org/wiki/index.php/Ubuntu_14.04[/url]

    I was able to get the udpcastsrc path/config updated. I think that it is best to do it manually using gedit because there are 2 references to the old version inside config.sh:

    /udpcastsrc="…/packages/udpcast-20071228.tar.gz" to /udpcastsrc="…/packages/udpcast-20120424.tar.gz

    and there is another entry 2 lines below this that also needs to be changed, I believe. My server is unavailable at the moment, but remember changing it twice (will post path later, if necessary).

    The problem is however that under Ubuntu 14.04 I can’t get TFTP to work correctly, so I don’t yet have a working FOG server on this release. Under 11.10, everything works great. I’ve used the exact same network settings, with a different static IP, and everything else is the same (kernel, drivers, etc).

    At PXE boot it just says:

    TFTP. . .

    The progress creeps slowly until a message saying TFTP timeout (or something similar) appears and it never reaches the FOG PXE menu…

    Any help would be greatly appreciated! I plan on trying it on 12.04 on Monday…

    Thanks again!


  • Developer

    you can sudo gedit the file and change the information if that command doesn’t do the job.

    all it is doing is looking in the file and changing the /udpcastsrc="…/packages/udpcast-20071228.tar.gz" to /udpcastsrc="…/packages/udpcast-20120424.tar.gz" in the …/lib/common/config.sh

    Look in your fog folder for /lib/common/config.sh

    use sudo gedit config.sh and change line /udpcastsrc="…/packages/udpcast-20071228.tar.gz" to /udpcastsrc="…/packages/udpcast-20120424.tar.gz"



  • i am having a lot of trouble getting this to work

    when i issue the command

    sed -i ‘s/udpcastsrc="…/packages/udpcast-20071228.tar.gz"/udpcastsrc="…/packages/udpcast-20120424.tar.gz"/’ …/lib/common/config.sh

    i get

    sed: -e expression #1, char 27: unknown option to `s’

    can someone tell me what i am doing wrong

    i am using ubuntu 13.10



  • Thanks Tom!
    I’m aware of the naming conventions, etc., and I usually manage the kernels manually from the terminal, but thanks for clarifying.

    Do not worry about an x64 init.gz, unless you have extra time, haha! As you suggest, I don’t really need to use it under FOG 0.32, I just thought that it could be an interesting test. The 3.14.0 x86 Tom Elliott kernel has been great on a stock FOG 0.32 installation, and I will definitely try 3.14.1 today or tomorrow!

    Thanks again for your work and dedication to this project!


  • Senior Developer

    The tom elliott kernel’s are built in both formats. 32bit and 64bit.

    The caveat is that you have to rename the bzImage32 file to bzImage for FOG 0.32 to recognize it properly.

    Currently my site is down, so use the svn.

    I’m at 3.14.1 already:

    [url]https://svn.code.sf.net/p/freeghost/code/trunk/packages/web/service/ipxe/bzImage32[/url] (PROBABLY WHAT YOU NEED, JUST RENAME TO bzImage ON THE FOG SERVER)

    [url]https://svn.code.sf.net/p/freeghost/code/trunk/packages/web/service/ipxe/bzImage[/url] (64 bit kernel. Not what you need for FOG 0.32.)

    There is no 64bit FOG 0.32 init.gz file that I’ve built so if you MUST use 64 bit stuff, you’d have to upgrade to 0.33b, or be patient, and once I get my Storage Server back up, I might try to generate a 64 bit init.gz for FOG 0.32 just for you cause I’m a nice guy!


  • Developer

    This post is deleted!


  • Thanks for the reply, you guys are the best. As always, your work is very, very appreciated.

    I am a little bit pressed for time, but I will certainly get back to this soon, and report on how it goes. I’m still chugging along with 11.10 for now but really want to move to 12.04 as it is LTS.

    Regarding updates, is the new 3.14.0 x64 Tom Elliott kernel supported in Fog 0.32 x64? If so, where is the init.gz for that kernel? I’m positive that I cannot load the 3.14.0 x64 kernel because I am using the stock init.gz from a FOG 0.32 x64 installation. Maybe this setup is not supported and I have to use FOG 0.33b to use the x64 kernel?

    I’ve have however had good success with the 3.14.0 Tom Elliott x86 kernel using the stock init.gz from a FOG 0.32 x64 installation.

    Thank you,
    D.L.


  • Developer

    Terribly sorry about that, I have fixed the issue, thanks for reporting it!



  • Thanks Tom, but I’ve already started as root.


  • Senior Developer

    You can install with just sudo ./installfog.sh

    The reason, I think, adding the sh -c is because the -c is usually for the su command, I don’t believe the sudo command supports the -c argument.



  • I have the same issue today under 12.04.4 LTS :

    [U]sudo –c ‘echo “greeter-show-manual-login=true” >> /etc/lightdm/lightdm.conf’[/U]

    I get a “Permission denied” error…

    Then I discovered on the internet:

    [U]sudo sh –c ‘echo “greeter-show-manual-login=true” >> /etc/lightdm/lightdm.conf’[/U]

    This worked. No idea why. How would the sh help?

    Now for my real question: Do I HAVE TO install FOG whilst logged in as ROOT??
    Can’t I just stay logged in as a normal user and type:
    sudo .[COLOR=#141414][FONT=Courier New]/installfog.sh[/FONT][/COLOR]
    Grateful for an answer today if someone is on line and can be bothered. I want to go forward with the install.
    [COLOR=#141414][FONT=Courier New][/FONT][/COLOR]


  • Senior Developer

    [quote=“rhythmtone, post: 25214, member: 57”]Hello,
    Thanks for the guide. I’ve been using FOG for several years now and I’ve stayed on Ubuntu 11.10 with no problems. However, 11.10 is no longer supported and is getting pretty “long in the tooth”, so I’ve decided to attempt a FOG installation on Ubuntu 13.10. Of course, until I have it working, I do not want to take my 11.10 installation offline, so everything is being done in a test environment.

    But I have run into an issue, with Ubuntu 13.10. When I type this command:

    [U]sudo –c ‘echo “greeter-show-manual-login=true” >> /etc/lightdm/lightdm.conf’[/U]

    I get a “Permission denied” error…

    I thought that it could be a directory permissions problem so I ran:

    sudo chmod -R 777 /etc/lightdm

    After modifying the permissions and re-running the command from the guide, it simply says:

    sudo -c: command not found

    I must be missing something obvious, but any help with this would be greatly appreciated as I was hoping to use some kind of guide/instructions to get FOG .32/.33b up and running on a Ubuntu 13.10 system.

    Thanks for reading![/quote]

    I think the syntax is incorrect.

    Shouldn’t it just be:
    [code]sudo ‘echo “greeter-show-manual-login=true” >> /etc/lightdm/lightdm.conf’[/code]



  • Hello,
    Thanks for the guide. I’ve been using FOG for several years now and I’ve stayed on Ubuntu 11.10 with no problems. However, 11.10 is no longer supported and is getting pretty “long in the tooth”, so I’ve decided to attempt a FOG installation on Ubuntu 13.10. Of course, until I have it working, I do not want to take my 11.10 installation offline, so everything is being done in a test environment.

    But I have run into an issue, with Ubuntu 13.10. When I type this command:

    [U]sudo –c ‘echo “greeter-show-manual-login=true” >> /etc/lightdm/lightdm.conf’[/U]

    I get a “Permission denied” error…

    I thought that it could be a directory permissions problem so I ran:

    sudo chmod -R 777 /etc/lightdm

    After modifying the permissions and re-running the command from the guide, it simply says:

    sudo -c: command not found

    I must be missing something obvious, but any help with this would be greatly appreciated as I was hoping to use some kind of guide/instructions to get FOG .32/.33b up and running on a Ubuntu 13.10 system.

    Thanks for reading!



  • Just a heads-up, and I know this guide is a little old, but there was a small correction I had to make to get the tutorial to work for me.
    This command here:
    [CODE]sed -i ‘s/udpcastsrc="…/packages/udpcast-20071228.tar.gz"/udpcastsrc="…/packages/udpcast-20120424.tar.gz"/’
    …/lib/common/config.sh (enter)[/CODE]
    Doesn’t seem to work. But all it took was editing the …/lib/common/config.sh file.

    For newer users, that looks like this:
    [CODE]sudo pico …/lib/common/config.sh
    #Find the udpcastsrc line, and change …/packages/udpcast-20071228.tar.gz to
    …/packages/udpcast-20120424.tar.gz[/CODE]

    Hope this helps someone.


Log in to reply
 

363
Online

38982
Users

10712
Topics

101678
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.