TFTPboot restart problems



  • Hi guys, thanks for all your great affords you’re doing a great job!

    I’m having a little problem though, and I am wondering if you could help me.
    I have been using fog 0.32 without any problems on 200+ computers, although there is one little annoying thing when I am using FOG with a Dell Optiplex 780.

    After imaging, after registering, after quickimage it always ends with the message “Restarting System”.
    All the other computers are rebooting at this point, but not the Dell Optiplex 780.

    I’ve tried both the graphical menu and the text menu, but without any result.
    My guess is that there’s a problem while unmounting devices, because it gives an unmount error just before the “Restarting System” message. The unmount error isn’t displayed every time, in fact I’ve seen it just once. I’ve added a picture that’s taken after imaging but without the unmount error. I’m thinking it’s a kernel problem, but I just don’t know what to do now.[ATTACH=full]31[/ATTACH]

    Thanks in advance!

    [url="/_imported_xf_attachments/0/31_photo.JPG?:"]photo.JPG[/url]



  • [quote=“Markverg, post: 2290, member: 383”]Kevin, we’ve been running that kernel (1037) since feb 7th only for the 780’s and the problem seems to be solved![/quote]

    Would you mind posting the steps you took to do this? I remember seeing how to do it a while ago but I’m in a pinch with a similar problem (Dell 960’s) and I would like to try using a different kernel.

    Edit - Nevermind, I found a link in another post that points out how to do this: [url]http://community.spiceworks.com/how_to/show/2338[/url]



  • Kevin, we’ve been running that kernel (1037) since feb 7th only for the 780’s and the problem seems to be solved!


  • group:cid:13:privileges:mods:members

    Markverg, have you tested this anymore? Is Kernel 2.6.33.3 (1037) still working well for your 780’s and having them restart?



  • Hi guys,

    Major breakthrough here for the problem with the Dell Optiplex 780.
    While using the kernel with id 1037 the problem seems to disappear.
    I’ve set the kernel setting per host on all my 780’s so that it doesn’t affect other pc’s.

    Problem solved (for now?)!


  • group:cid:13:privileges:mods:members

    We currently image our 780’s with the hard drives set to ATA mode using the default kernel that .32 installed with and haven’t had any problems with uploading an image.



  • I’m unable to even get a 780 to upload image…tried the 2.6.35.7 KS Kernel and still nothing . I also saw a solution to change to legacy in BIOS for HD from SATA-RAID . Just can’t seem to get a 780 to upload an image . Imaged up and down on a 790 without issue . The 780 in question is a 250gb , single partition drive . It has about 85gb used on the Drive at the moment . I’m stuck .



  • [S]I seem to have found the problem: a BIOS setting combinated with the new fog version causes the problem.[/S]
    [S]SATA operation was set to “raid on”. Switching this option to any other option seems to correct the problem.[/S]

    Unfortunately, that doesn’t do it. Sometimes it reboots, and sometimes it doesn’t…



  • I doubt it’s a BIOS related problem, because while using FOG 0.29 the problem didn’t occur.
    I updated to 0.32 yesterday, that’s when the problem with the Optiplex 780 started…

    [S]Will try to update to the latest BIOS though, just to be sure…[/S]

    edit: updated the BIOS to version A12 (latest available BIOS) but the problem still occurs


  • group:cid:13:privileges:mods:members

    Time to fire up DCCU and see if that fixes the issue :)



  • I’ve looked into this in the past, it happens a lot with 960’s, and it appears to be related to the way the kernel goes through the shutdown process. [url]http://linux.koolsolutions.com/2009/08/04/howto-fix-linux-hangfreeze-during-reboots-and-restarts/[/url] seems to be related, though I haven’t had a consistent set of results on the same model of optiplex, so I stopped trying to figure it out for now.


  • group:cid:13:privileges:mods:members

    I think it’s actually a BIOS issue, i’ve seen some 780’s restart everytime, and others never do. I’m still working on figuring out what the difference of them are.


Log in to reply
 

339
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.