Stuck Behind PXE Server



  • Running a Fog server for PXE boot only, on a small network.

    Two NICs on my server: eth0 is regular network traffic, eth1 is attached to a small switch where machines are connected to PXE boot … the reason for this is because the business network runs a Cisco router that is also a DHCP server, and my PXE server is also running dhcpd for IP assignment on the second NIC, and I want to avoid a conflict.

    Can successfully boot from Dell Diag, Memtest, TRK, Parted Magic, etc… but can’t access internet (or network outside of my server.

    Here is the output of my ifcfg-eth1:

    [CODE]DEVICE=eth1
    HWADDR=00:1D:72:AF:57:E2
    TYPE=Ethernet
    UUID=8d5ed7e1-8aaf-4de5-88f4-54e55491feae
    ONBOOT=yes
    NM_CONTROLLED=yes
    BOOTPROTO=static
    IPADDR=10.143.1.1
    NETMASK=255.255.255.0
    NETWORK=10.143.1.1
    NAME=“System eth1 PXE”[/CODE]
    And ifcfg-eth0:
    [CODE]DEVICE=eth0
    TYPE=Ethernet
    UUID=92b753d5-cb7b-42e5-911e-6aae0398de3a
    ONBOOT=no
    NM_CONTROLLED=yes
    BOOTPROTO=static
    HWADDR=00:60:6E:84:0C:D3
    IPADDR=192.168.1.210
    PREFIX=24
    GATEWAY=192.168.1.1
    DNS1=192.168.1.2
    DEFROUTE=yes
    IPV4_FAILURE_FATAL=yes
    IPV6INIT=no
    NAME="System eth0 internet"
    LAST_CONNECT=1380816670[/CODE]
    And my dhcpd.conf:
    [CODE]# DHCP Server Configuration file.

    see /usr/share/doc/dhcp*/dhcpd.conf.sample

    This file was created by FOG

    use-host-decl-names on;
    ddns-update-style interim;
    ignore client-updates;
    next-server 10.143.1.1;
    allow booting;
    allow bootp;
    authoritative;
    set vendorclass = option vendor-class-identifier;
    subnet 10.143.1.0 netmask 255.255.255.0 {
    option routers 192.168.1.210;
    option subnet-mask 255.255.255.0;
    range 10.143.1.100 10.143.1.199;
    #range dynamic-bootp 10.143.1.100 10.143.1.199;
    default-lease-time 21600;
    max-lease-time 43200;
    option domain-name-servers192.168.1.2;
    option routers 10.143.1.210;
    filename “pxelinux.0”;
    next-server 10.143.1.1;
    }[/CODE]
    The 192.168.1.2 is a Windows server that runs our DNS.
    I have iptables turned off so there is no firewall (not needed inside the network, we’re already nicely firewalled).
    I have a feeling that the issue is somehow with the IP scheme but am not sure how to change it without broadcasting a second DHCP server across the network and screwing up all the other computers. I am extremely new to Fog and TFTP, and fairly new to Linux in general. Let me know if you need any other output that I have forgotten.



  • I thought of just changing my subnet mask but I suspect it’s far more involved than that.

    I’ll Google around about ProxyDHCP, that sounds like the least convoluted solution - but I’m happy for the help if you have some tips, especially relevant to my configuration…I do appreciate that. I’ve been running CentOS 6 and am happy with it so far. I hope to not have to reinstall everything and start over, since Trinity Rescue Kit was a BEAR to get the config right (some late nights involved and I can’t remember exactly how I got it to finally work, but it does–except for the whole internet connection issue). But if I have to I have to.


  • Moderator

    My suggestion is for you to look into running ProxyDHCP instead of trying to run two NIC’s in separate subnets (unless you are familiar with routing).

    ProxyDHCP lets your normal DHCP server still handle giving out and managing IP addresses and leases. What it listen for DHCP requests that are from clients that understand PXE, and it responds to the clients saying something along the lines of “I know you’re getting your IP address from another server, but here is what you need in order to PXEBoot.”

    If you want to look into ProxyDHCP, I can help you set it up. If not, continue reading for my thoughts on your current network configuration:

    You are not giving your pxe boot clients a proper gateway/router address to forward traffic to if it’s not intended for the local subnet (10.143.1.0/24).

    So basically, if the IP address of the other computer it wants to talk to is in the 10.143.1.x range, it can talk to it, but it has no idea where to send traffic for the rest of the network or internet.

    I don’t see where you’re giving it a route/gateway to use. I think it would be 10.143.1.1 since that is the only device on that subnet that is connected to the rest of the world. You’ll probably need to run pf or other routing package to do that though.


Log in to reply
 

470
Online

39.3k
Users

11.0k
Topics

104.5k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.