Fog 0.33 Beta Issue



  • When I tried to upgrade. I got this error. I can pass through the error and login to fog web intereface but many links and other items do not work, Any advice to fix this. I really need to use the beta version as it allows my new lenovo pc’s to register and inventory. Unless there is a way to use the kernel that is in 0.33 version with 0.32 .

    Here is the error I get during the database schema update.

    to login.
    [B][CENTER]%(#4c68a0]The following errors occured[/CENTER][/B]

    [B]Update ID)[ 36 - 1
    [B]Database Error:[/B]
    Duplicate entry ‘417-23’ for key ‘gmHostID’

    [B]Database SQL:[/B]
    ALTER TABLE fog.groupMembers ADD UNIQUE ( gmHostID, gmGroupID )]



  • The known good systems were extremely slow as well just like the new one using 3.12


  • Senior Developer

    Then there’s something else going on. At that point, it can’t be the kernel. How slow were your “known good systems” when you started imaging them? Where they done to the same EXTREME Slow, or just slightly slower than before?



  • Same results. copies about 90 mbs then chokes.


  • Senior Developer

    Scott,

    Once again, I’ve rebuilt the kernel.

    Try this one as it’s specific to your machine (hopefully):
    https://mastacontrola.com/fogboot/kernel/bzImageIntelNETOnly


  • Senior Developer

    I don’t know how to correct for that.

    I’m working on something at the moment. It just seems odd that it slows down where, to my knowledge, others haven’t been having that issue.

    I’m going to try building just a core kernel with only your network drivers. That should limit any issues on the kernel’s side.



  • Sorry for the other post but I got it to load. I did have to reboot the server. Unfortunately it is doing the same thing going super slow. One thing I will say I am not sure if its something you need to know or not but When it firsts start to image it copies the first 99mbs very quickly and then goes slow.



  • This post is deleted!


  • Thanks I will test it soon


  • Senior Developer

    It’s now available to test. It has been for a little bit now.



  • Please let me know when it is available to test.



  • Will do thanks


  • Senior Developer

    Scott,

    I’m currently rebuilding another 3.12.0 kernel that is based strictly off the Core Config. Removed the KMS Requirements and added all network drivers back. There are no other tweaks to this configuration. Please test this new kernel to see if you have an improvement. If you don’t I’ll keep tweaking the kernel settings as then I know it’s likely something with the drivers that’s causing your issue.

    It will probably be about 30 minutes or so, but it will be at the same link as it’s the same file. Just give me till the turn of the next hour and it’ll be up. I hope this helps.



  • The systems that are known to be good are slow as well using 3.12 kernel.



  • I will check this tomorrow. Thank You


  • Senior Developer

    While on the 3.12, does it affect the speeds of the known good systems?



  • The switching appears to be fine. If I revert back to 3.8 kernel I can image any other machine with excellent speeds using the same cable/switch. I have never imaged this lenovo pc. It is a new pc I am testing before I purchase them. I want to be sure I can use them with fog before I buy a bunch of them. My M73 Lenovos image perfectly using the same switch/cable to the server. I can put a 40 gb image down in about 17 mins.


  • Senior Developer

    Scott,

    Check the switch between your client and your server. As these systems network drivers never worked until this latest kernel, how were you imaging them before? Are other clients affected by slow speeds?



  • Before we were getting very good speeds. We could push this same image to a pc in about 17mins. Th efog server is a quad core beefed up VM



  • just cruising by since yesterday…what speeds where you getting before you updated to Toms latest bzImage for this exact deploy image? Are you at least 1Gb all the way around from the workstation to the network switch to the fog server? Also what are your specs for the fog server? is it a direct install with linux or you using a VM?


Log in to reply
 

474
Online

38916
Users

10688
Topics

101381
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.