Using Auto Log Out Service Restarts Win7 Machines



  • I know I’ve seen threads on this before, but I’m unable to find any. I would REALLY like to use the Auto Log Out Service in FOG. It works fine for our XP machines but not Win7. Since it’s a global feature I have to turn it off. Fog restarts the Win7 machine while the user is using the computer - full activity! SP1 is installed on all our Win7 machines. I’m running FOG .32. The same thing occured when I was using FOG .29. Green FOG shutdown feature works fine for XP and Win7 machines, but the users have to be logged off for this to work.

    Any suggestions?

    Thanks!



  • I have used the feature in the past without issues, it just seems once we pushed out SP1 to win 7 we started to see this issue.
    The rebooting instead of logout doesn’t bother me, but the fact that it does not register activty does.

    I put in a bug at:
    [url]http://fogproject.org/forum/threads/auto-log-out-restarting-even-during-activity.1136/[/url]



  • I should have said that “you can turn it off [b]theoretically[/b]”. I experienced the same thing as you are during our evaluation/testing but, we were already controlling auto logoff via Group Policy in production (and scheduled shutdown/starts via FOG). We were not planning to use this feature so, I didn’t get too far into it - I only found that quote from the wiki because it surprised me that “Auto Logoff” was rebooting machines instead of just logging off the current user.



  • I have:

    ------------------------------------------------------------------------

    Should we reboot even if someone is logged in?

    ------------------------------------------------------------------------

    forcerestart=0

    I know the default behavior is for it to restart in order to log out. But this is happening even if i am sitting typing an email.



  • Yeah, that’s what I experienced.
    Check if [B]forcerestart[/B] is set to[B] [B]1[/B] [/B]on the client in[B] [B]C:\Program Files (x86)\FOG\etc\config.ini[/B][/B]. You can turn it off by changing this to[B] [B]0[/B].[/B]



  • afmrick I don’t think you understand what this is doing. it is loggingout/restarting the machines when a user is logged on working. So if you set the timoue for 5 minutes, when 5 minutes has passed, it is rebooting no matter what is going on.



  • This is by design according to [url]http://www.fogproject.org/wiki/index.php?title=Managing_FOG#Functions_and_Operation[/url]

    “[SIZE=4][FONT=Times][COLOR=#000000][I]This module of the FOG Service will log a user off of a client pc after X minutes of inactivity. This module will display a screen saver-like GUI after 3/4 of the inactive time is up. So if the time out value is 40 minutes, the GUI will be displayed at 30 minutes of inactivity. [B]When the time is up, the client computer will reboot[/B].[/I][/COLOR][/FONT][/SIZE]”



  • This post is deleted!


  • No fix yet? I gave up. I’m using group policy and scheduled tasks to shutdown machines after 6pm when there has been x amount of inactivity. It works very well and easy to update. As far as logging the user off I guess that’s their problem if someone walks by their machine while they aren’t sitting at it and decides to change settings, delete files, etc… LOCK YOUR MACHINE WHEN YOUR NOT USING IT PEOPLE!!! I think the only solution to auto logoff users is the old screensaver trick through GP.



  • [quote=“ajcke, post: 910, member: 97”]I know I’ve seen threads on this before, but I’m unable to find any. I would REALLY like to use the Auto Log Out Service in FOG. It works fine for our XP machines but not Win7. Since it’s a global feature I have to turn it off. Fog restarts the Win7 machine while the user is using the computer - full activity! SP1 is installed on all our Win7 machines. I’m running FOG .32. The same thing occured when I was using FOG .29. Green FOG shutdown feature works fine for XP and Win7 machines, but the users have to be logged off for this to work.

    Any suggestions?

    Thanks![/quote]
    I would also need a fix for this issue. I’m running FOG .32 as well.

    Thanks.


Log in to reply
 

372
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.