PXE Boot problem



  • Ok so I set up a computer running Ubuntu 10.04 and installed fog .32 on it. Got the fog server up and running and trying to put it in a network with a current DHCP

    so the fog server only has an ip address. I went to my windows server running DHCP and added the two to dhcp under the scope options 66 (ip address) 67 (pxelinux.0) When I go to boot into PXE I get taken to WDS menu and no option for fog. We do have a current WDS setup but how do I get a computer to boot to fog pxe?


  • Developer

    Yeah that works too lol :)

    I didn’t have access to my WDS server, and I am the only one adopting FOG in my corporation, the rest wants to spend all their time dicking with that WDS server, FOG is easier for me to use. So long story short, I wasn’t allowed to just disable the service :)



  • Ok thanks I will give that a try too. I also got it to work by stopping wds service


  • Developer

    You must reboot your network and switches before the new “next-server” will take affect.

    alternatively, you can install the DNSMasq (ProxyDHCP) to circumvent this. In the event that your FOG server is unavailable, it will continue to boot WDS, it’s a nice fail safe.

    I had to use the service to make my pxelinux.0 reach my clients, but it will work for “temporarily” taking control of the DHCP service and boot to FOG.

    You can also use a gPXE disc, you can supply your server and filename and it will boot your fog server instead of WDS.

    Look here [url]http://fogproject.org/wiki/index.php/Setting_up_ProxyDHCP[/url]


Log in to reply
 

405
Online

38953
Users

10706
Topics

101571
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.