Can't get FOG to run for some reason?



  • Hello all. This is my first time posting here in efforts of looking for some help. I needed to restart the Fog (Ubuntu) machine today. After it came back on, I logged into the account and then tried doing a PXI boot on a Dell laptop that I needed to deploy an image to. For some reason, it doesn’t connect… The Dell computer is saying “No DHCP or proxyDHCP offers were received. Exiting Intel boot agent”. I went back to Fog server machine and did a sudo service tftpd-hpa stop and then typed in the password, and then I did a sudo service tftpd-hpa start. I went back to the Dell machine and tried doing a PXI boot again and still same issue, can’t get an IP address from the fog server… Does anyone know what’s going on here?? We had this issue before but the person that worked on it is no longer with the company… Any help is appreciated!!! Thanks!


  • Senior Developer

    Sorry I wasn’t much help as I really don’t use ubuntu.



  • Ok, after some frustration… I got it figured out. I had to enter these commands at the Terminal:

    sudo service isc-dhcp-server stop
    sudo service isc-dhcp-server start
    sudo service tftpd-hpa stop
    sudo service tftpd-hpa start

    Thanks for the help guys!


  • Senior Developer

    You’re right that you would add sudo to the front of it, but don’t place service in the front. If you’re going to use the service command, all you should need is:

    sudo service dhcpcd restart
    

    Also, I’m not an ubuntu user, so I might be slightly off. If you know what the service name is, you should be able to find it with:

    sudo ls /etc/init.d
    

    Search for the dhcp item within that directory.



  • Ok. I’m assuming I would do sudo service /etc/init.d/dhcpcd restart ?
    I tried that and it said “Unrecognized Service”


  • Senior Developer

    Try

    /etc/init.d/dhcpcd restart
    


  • Yes, the fog server hands out the DHCP requests to the computers.


  • Senior Developer

    As chad-bisd asked, is DHCP served by your fog server or do you have some other implementation such as AD DHCP, a basic router, etc…? tftp-hpa is a service that hosts the files to serve for PXE boot, but if your DHCP server doesn’t know where to route the traffic during this period (next-server, options 66/67) it would give these issues.


  • Moderator

    Does FOG handle your DHCP requests? Do you use ProxyDHCP?



  • I should also mention that I am doing this with a Dell Latitude E6430 and I am using Linksys SE2500 switches because the network is on it’s on local LAN.


Log in to reply
 

501
Online

38925
Users

10691
Topics

101434
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.