Partition outside of disk and Invalid partition table



  • I’m attempting to deploy images to various machines, and every time I’m getting either one of those error messages.
    The Invalid Partition Table error is the first problem. When I perform an Fdisk, I’ll get the same error. I’ll use Gparted to build a new partition table and then try to use Fog, then I get Partition outside of disk. Then back to square one.

    I’ve replaced the HDD in this machine because I thought it was having issues. Now I’m wondering if my fog server is the problem.

    I’ve attempted to deploy the same images to a virtualbox but I also get the error Partition outside of disk. The image is 24 gigs big. The VDI is 50 gigs. The HDD I replaced in the other machine is a 320 gig.

    I need some help. please. Any advice?


  • Developer

    I normally start with like an 80 gb (its hard to find anything smaller than that on the market anymore) and install my OS and updates from there. I was wondering how I would go about compressing an image if I ever needed to. I’m going to save some of this information, thanks for asking and finding the answers. In the future try an 80 gb starter image :)



  • I’m able to get the image to write. Not sure how though. I did the same as before when I delete the partitions. I’ll be shrinking my volumes for now on.

    Many thanks for the responses.



  • I need to download the image first…

    The source is no longer available and I need this image like now.



  • Download gparted live cd. Resize the partition. Then upload again.



  • That may not be an option.

    There is no way of shrinking a fog image outside of imaging a machine, shrinking, and uploading again?


  • Senior Developer

    The best option is to create the master image on as small of a drive as you can find. Then upload that image.



  • Thanks for the replies.

    So, what are my options to get this images on a PC? Is it possible to shrink it?


  • Senior Developer

    The size of the image, itself, doesn’t matter. If you created the image off a system with a 500 GB drive, but try to put that image onto a drive that’s 320GB, the system will not be able to partion it, because, the Partition table (copied from the MBR) is outside the disk you’re trying to write it to.


  • Senior Developer


  • Senior Developer

    Look on threads I posted sorta how to on fdisk. It is in Spanish but the code base is the same.



  • [SIZE=2]Invalid [/SIZE]partition[SIZE=2] table on /dev/sda [/SIZE]

    [SIZE=2]I tried again, used Gparted and even formatted the drive to NTFS and confirmed with FDISK. Same error.[/SIZE]


  • Senior Developer

    Use fdisk Sorry on cellphone and its autocorrect



  • What do you mean use disk to inialize?

    Also, the image is only 24 gigs and the drive is 320 gigs.

    I’ve deployed these images to dozens of machines and not had this issue.

    Also, can you think of any reason the partition table seems to go out the window when I try to image the machine?


  • Senior Developer

    Make sure the drive is equal or larger than the drive you created the image with. If its a blank non initialized disk use disk to initialize.


Log in to reply
 

449
Online

38995
Users

10715
Topics

101715
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.