Volume not Found error



  • Hi all, I’ve moved my images to a different partition and followed the instructions as best I could from here;
    [url]http://www.fogproject.org/wiki/index.php/Adding_Storage_to_a_FOG_Server[/url]
    most of it went well but as it was a partition on the same drive I never had the ‘1’ after my device name.

    Anyway all seemed to be working well as it mounts the folder after a reboot and images can be deployed like before. However I’ve since created a new image “Optiplex755Athro” (directory and files are created in the images folder) and when it comes to deploying this image it fails after 49% saying;
    Volume Not found
    Can’t read the following volume file :
    /images/Optiplex755Athro/d1p1.img.001
    Enter another full path (dir & name)

    The d1p1.img file exists along with d1.mbr but no other files exist in the directory, is it something to do with permissions (fog has create and read access apparently) or is it something else?

    Old images that were moved from images.old seem to work fine.

    Using Fog 0.32 on Ubuntu 11.10

    All help gratefully received.



  • This post is deleted!


  • Nope still not working. First I created a new image (new name) as well which failed the same way, the permissions on the folder of the image were set to root as owner. So I uploaded the same new image to an existing Fog image and during the upload it reset the permissions on that folder to root as owner, and the same problem again while downloading the image to a different host.

    And no still no sign of this fabled d1p1.img.001 file.

    Update - Yeah using a new workstation and creating a new image from scratch seems to have fixed it. Thanks


  • Senior Developer

    That’s what I was just going to say.

    The reason it’s failing is because it can’t find the d1p1.img.001 file which, from the sounds of it, used to exist.

    Update the image using another machine and then you should be good to go.



  • Yeah the path looks fine in the GUI. On Friday I thought this was the problem as the old image had [storagenodedir]/Optiplex755, that’s when I deleted the old image and created a new one ensuring it used /images instead (also deleted storage nodes that I never used).

    The image was originally a Multiple Partition, Single Disk but the newest image I created I set to All disks in the hope of rectifying the problem. And no the .001 file doesn’t exist only d1p1.img and d1.mbr do.

    Will probably recreate a new image today set to single disk now that permissions seem sorted.


  • Senior Developer

    The next thing I Would check is that the images are actually pointing to that directory.

    Under GUI, Image Management, Make sure the line for Image Files is pointing to your image name. So in your case it looks like it should contain:
    [CODE]/images/1A3DellOptiplex360[/CODE]
    and
    [CODE]/images/755Athro[/CODE]

    The other thing to check is that it’s of the correct type of image.

    Based on the File you’re saying is failing it sounds like it’s a:
    Multiple Partition, All Disk image.

    I could be wrong.

    Also, you said that the d1p1.img file exists.

    Does d1p1.img.001 exist?



  • Cheers both. I ran those commands Tom and I’ve checked the permissions (through Terminal) and they are identical to other images yet it still gives me the same error. I also recreated the image.

    example;
    [CODE]drwxrwxrwx 2 fog root 4096 2013-05-21 13:55 1A3DellOptiplex360
    drwxrwxrwx 2 fog root 4096 2013-09-06 15:04 755Athro
    [/CODE]


  • Senior Developer

    As a caveat to chad-bisd’s message:

    Make sure you also performed:

    [CODE]touch /images/.mntcheck; touch /images/dev/.mntcheck
    chmod a+rwx /images
    [/CODE]


  • Moderator

    check the permissions on the new location. If you renamed the old /images so you could make a new /images folder on the other partition, you may have left the default permissions, which are too restrictive for imaging.


Log in to reply
 

394
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.