FOG Quick/Full inventory attempt on a Dell XPS 8700 locks/fails.



  • As the subject suggests, I can’t get the Quick/Full inventory to complete when trying to inventory a Dell XPS 8700 (I7 machine) with the FOG server. It worked perfectly on all of the Dell Optiplex 780 (Core 2 machine) machines, however it seems to be failing with this newer machine for some reason.

    I’m running the FOG server on an I7 machine, running Fedora 13 kernel 2.6.34.9-69.fc13.x86_64 and it is on a private network with only the gigabit router, the fog server, and the machine I am trying to inventory.

    What happens is, this:

    Loading fog/kernel/bzImage…
    Loading fog/images/init.gz… ready.
    [ 1.022257] tps65010: no chip?
    [ 1.232307] acpiphp_ibm: ibm+acpiphp_init: acpi_walk_namespace failed
    [ 1.232509] Could not find Carillo Ranch MCH device.
    [ 1.232689] uvesafb: failed to execute /sbin/v86d
    [ 1.232734] uvesafb: make sure that v86d helper is installed and executable
    [ 1.232780] uvesafb: Getting VBE info block failed (eax=0x4f00, err=-2)
    [ 1.232825] uvesafb: vbe_init() failed with -22
    [ 2.527112] drm/i810 does not support SMP
    [ 3.722891] Error: Driver ‘mdio-dpio’ is already registered, aborting…
    [ 3.730585] cs89x0: request_region(0x320, 0x10) failed

    Then, at this point it just stops and seems to hang forever. Not even the cursor blinks as far as I can tell. It doesn’t matter whether I choose Quick Inventory, Full Inventory, choosing Client System Information to determine the IP/MAC. That is as far as I can get no matter which option is chosen essentially.

    I’m curious if anyone knows what the problem is… so far usually it’s been something simple, and I’m hoping that this is the case here as well!

    Thanks in advance

    –CrazyHorse



  • I’d like to say I was also getting a blank screen after the bzimage and init.gz deployed.
    This is on HP EliteDesk 800 G1
    <snip>
    uvesafb: failed to execute /sbin/v86d
    uvesafb: make sure that v86d helper is installed and executable
    uvesafb: Getting VBE info block failed (eax=0x4f00, err=-2)
    uvesafb: vbe_init() failed with -22
    this is where the screen goes black and nothing happens.
    I am using FOG 0.32, kernel 3.6.9 (I cannot get 3.8.8 to function, PXE boots ok but when selecting any options nothing happens)
    when I used the bzImage Tom provided earlier this worked and the image deployed although the display was low resolution (this does not matter when deploying to be honest…)
    So, thanks Tom, good solution :)
    Cheers
    Pete



  • Tom,

    I don’t believe I am using a custom init.gz, but I am getting the issues you describe including the skipping and partial copies. It does however actually get to that point where the original bzImage would fail/lock at that point. If using a custom init.gz would help, it would be interesting to know how to do that. I’m going to try with your 11 MB image today and see what happens, didn’t get a chance yesterday.


  • Senior Developer

    I hope it helps as well. Are you using a custom init.gz as well? I’ve seen the skipping and even partial copies with my custom one. Though it’s still a work in progress. Uploads seem to work fine, but deploy’s don’t for some reason. That’s an area I’ll worry about later on though.



  • Jaymes, and Tom,

    Jaymes, from now on I will try that option and see if it recognizes the partitioning scheme any better in the future.

    Tom, well the sector by sector copy I did with the dd option worked on the host upload, but when I went to deploy it to the client, it just skipped it as if it didn’t exist and went right to being “done”. There didn’t seem to be any error message either that I could see, but it scrolled by incredibly fast all times I tried to see it.

    So I think I’ll try your 11 MB image you linked in the post above and see what happens when I try to upload/deploy with that. Here’s hoping!



  • Tom,

    Ok, I will try that if need be, but for image type I’m using the: Multiple Partition Image - Single Disk (Not Resizeable) as the selection in image management. Do you think that might be giving it a problem? I think I might try: Raw Image (Sector By Sector, DD, Slow) instead. Who cares if it’s slow at least if I only have to do that for uploading and not for deploying it out.

    If that doesn’t work, then I will try the kernel you posted above, and see what happens, I think I will do that anyways simply to test it for you on hardware that is relatively new.

    I’ll let you know either way.


  • Senior Developer

    The kernel creates a small partion at point /dev/sda, I haven’t been able to figure that out yet. But it does have support for ext4. So it’s not abnormal for your disk to found on /dev/sdb

    if it was actually creating the image, to my knowledge, partimage only pulls the used data off of the partitions and leaves free space alone. I just finished building a kernel off of core, so maybe this will correct the /dev/sd{a,b} problem, but the kernel size is now at 11MB, I haven’t had much time to test it if it’s using the video information, but hopefully it will operate properly as I found, today, it doesn’t recognize the drive from an HP 6475b system. So let me upload this file and give it a shot, I’ll call it bzImageCORE. Just rename it to plain bzImage for your fog host.

    [url]https://mastacontrola.com/fogboot/kernel/bzImageCORE[/url]


  • Developer

    Not to stray to far from topic, what is the option your are using to select the partition type? I normally use Multi Partition - All Disks.

    See if uploading the image this way has any affect on the outcome.



  • Tom,

    At first it seemed to be able to image the XPS 8700 host correctly but there were a few possible issues…

    1. I’m not certain if it’s relevant, but the disk on the host I wanted to image FOG seemed to think it was sdb when on the host itself it’s sda, but not certain if that makes a difference.

    2. The host I was trying to take the image off of has 5 partitions, one of which is an extended, and another within the extended, the other 3 are primary. They are all ext4 partitions, and there is nothing with LVM going on. When FOG tried to image them, it seemed to image the first 3 very very quickly, almost as it if skipped them, and the 3rd (the swap partition) it seemed to skip altogether. The final partition with most of the data in it it seemed to image 69 GB of the 1 TB, and it went fairly quickly. Most of that 1 TB was emtpy space,and it seemed like the kernel skipped it for that reason.

    However, when I tried to deploy the image to another machine of exactly the same configuration, it failed to deploy the image properly, and I am certain that was due to it’s having issue imaging the original host.

    I’m not certain exactly what happened, the only thing I can think of is fdisk -l on the original host per partition shows something akin to:

    partition x does not start on physical sector boundary. It says that for all 5 partitions, and I’m not sure if that is giving FOG any problems. I could reinstall CentOS 6.4 on the host if need be to fix it.

    Let me know what you think. If necessary I could provide screenshots, but it’s quite a strange issue.


  • Senior Developer

    The 45 seconds you’re seeing in delay is due to the kernel having drivers setup for scsi systems as well and it’s actually checking for alternate ATA device connections. This is normal and expected behavior.



  • Tom,

    Sounds good, and I am trying it now. Thus far, it’s a little more “strange” than the original kernel, but it does seem to get past getting hung up on whatever piece of hardware the original bzImage was. However, when it tries to run the kernel on the client, I get a odd pause for 45 seconds to a minute. However, after that so far it seems to behave normally.

    I do like how it “appears” to ignore uploading the free space, and only uploads actual data, that’s a nice welcome change. I’m uploading a host now, and attempting to deploy it to another system of the same type. So far so good, but it’s not complete yet, I’ll let you know!

    Also, you were probably right about it being a hardware issue… most likely because the video card is a newer ATI Radeon model. Now that it skips over that, things are actually proceeding.


  • Senior Developer

    Go to the directory:
    /tftpboot/fog/kernel

    Copy the original kernel as backup;
    mv bzImage bzImage_orig

    Wget the new kernel in the directory:
    wget --no-check-certificate [url]http://mastacontrola.com/fogboot/kernel/bzImage[/url]

    You should be set.



  • Tom,

    Thanks a bunch, I will try it, but how exactly should I install that kernel, is there a specific process? Also, is there a way to set FOG so that it works only as a cloner, and doesn’t necessarily try to adjust for hardware profile changes?


  • Senior Developer

    It sounds like a driver issue within the kernel:

    Try my kernel as it’s small and only contains drivers for network and hdd’s no video. I don’t know your specific device setup, but I hear this one’s been working:

    [url]https://mastacontrola.com/fogboot/kernel/bzImage[/url]


Log in to reply
 

433
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.