Computer Wont PXE-boot



  • I installed fog 0.33, after sime obstals and one computer wont pxe boot from fog
    It dectes iit. But tftp loads forever? Any help


  • Senior Developer

    It sounds like you installed the DHCP server on your fog server, and it’s not communicating properly because your router doesn’t know how to pass the information, to the tftp server. What kind of router are you using? Do you have the ability to setup something like:
    dhcp-boot=pxelinux.0,fogstorage,192.168.XXX.XXX
    or
    next-server options,
    or
    DHCP 66/67 information?

    Could you try with a switch or hub connected directly to the fog server (bypassing the router) just to see if it can actually communicate with the FOG Server?



  • the non-apple computer it finds a dhcp server but tftp wont load,and it doesnt go to the menu
    after i restart the server computer and it doesn’t find the dhcp server.Do i have to start the fog server


  • Senior Developer

    mlb2009,

    Please provide more information in your posts.

    So it never gives you a menu or is it like it can’t find a DHCP server?



  • [quote=“Tom Elliott, post: 15539, member: 7271”]So you’re trying to image the Macbook (Pro?) using PXE? You’re sure it’s already setup to boot from network and uses the PXE interface? Do you have any other machines (preferably not Apple) to test that the tftp server is working? FOG is not a service persay, it’s a suite of services. Part of the suite is tftp which gets installed. To make sure tftp service is restarted, the best method is to restart the entire server. All services on the server should should have been setup to be started on bootup so a restart is the best method to ensure the system is working properly.[/quote]
    I am not trying to boot pxe from mac,i am trying to boot pxe on a non-apple computer.


  • Senior Developer

    So you’re trying to image the Macbook (Pro?) using PXE? You’re sure it’s already setup to boot from network and uses the PXE interface? Do you have any other machines (preferably not Apple) to test that the tftp server is working? FOG is not a service persay, it’s a suite of services. Part of the suite is tftp which gets installed. To make sure tftp service is restarted, the best method is to restart the entire server. All services on the server should should have been setup to be started on bootup so a restart is the best method to ensure the system is working properly.



  • No,i have ethernet pullged in and i am not using public ip.I can (connect to fog mangement)
    How can i start the fog server again. I usally use my mac and windows partition.(i have a real mac).


  • Senior Developer

    Your FOG Server needs to remain running. It’s the server providing PXE for your clients.

    When you installed, did you setup your fog server as the DHCP server?

    Is your setup now within your local network? Or did you setup with your public IP Address?

    PXE works by linking to the system, so if you’re using Public IP address, it’s being stopped by your router as chances are it’s trying, essentially, to make a loop back to itself which the router typically will not allow. If not, are you sure firewall is not running? You can stop the firewall in Fedora 19 with the commands:
    service firewalld stop; chkconfig firewalld off

    You understand that PXE only works from the Network Adapter via Cable as well? You’re not attempting to PXE boot over wireless correct?

    Again, more information about your specific setup. We can’t help if we don’t have the information.



  • when i reboot my computer the other computer doesn’t connect to anything at all
    do i have to start fog.If so,what command?

    but before it was tftp wold load forever. Open timeout or something it will say when loading


  • Senior Developer

    mlb2009,

    We need more detail to help out. It’s not working doesn’t help anybody assist you. What is the exact messages you’re getting?

    Can you take a picture and post it?

    Thanks,



  • Sorry for the late repliy.still not working.


  • Senior Developer

    If it’s not getting to the Menu to give you selections, you’ll need to set your router up to forward the tftp side to pxelinux.0

    I don’t know your router or your particular setup, but it needs to point back to your FOG Server’s IP address. 127.0.0.1 is not a valid IP Address either as 127.0.0.1 is the localhost address. This means if you used 127.0.0.1 as your servers IP Address, you’ll need to change that to the router assigned IP.


  • Senior Developer

    How do you mean it loads forever? You mean it gives you the menu, and when you select the menu option the kernel and init.gz file loads forever, or do you mean that it just sits at the loading the menu option?


Log in to reply
 

371
Online

38982
Users

10712
Topics

101680
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.