Fog wont install


  • Senior Developer

    There are alternatives for PXE boot such as iPXE and GPXE but before you go changing that, lets try getting this working for you.

    I’ve still got about an hour or so until fedora 19 is downloaded for me.

    Make it just a little bit longer, I’m doing minimal install rather than full DVD disk download.



  • My router is saying the public ip



  • yes,of course.


  • Senior Developer

    Are you trying to use your fog server as the DHCP server?

    If you are, set the Router IP address to the same as your System.

    You said you were behind a router. If that’s the case, chances are your router IP address is 192.168.1.1, but this doesn’t matter.

    You’re sure mysql is running?

    Do you have the ability to install another OS like CentOS?

    I don’t have a copy of Fedora 19 so I can’t test anything out for you. Give me a few hours and I’ll build a VM for it to try to see what you’re seeing.

    To find out your router IP, go into the router settings. It will be somewhere, but again I don’t know your router.



  • and are there alterntives for pxe boot?



  • with 0.33,it dectects my ip and eveything.I have a internet connection.Same error about mysql.
    And how to find out my dhcp router ip?
    do i go to my router settings?


  • Senior Developer

    Any luck yet?

    What do you mean remove MySQL? Do you mean you’re uninstalling it, or not allowing fog to deal with the install of it?

    Also, did you find your private IP for your system? The sock isn’t going to connect on your public IP address which could be your entire holdup.

    My best suggestion is to find out what IP’s your router distributes for DHCP. (Usually something like: 192.168.1.100 thru 192.168.1.200)

    Then statically set your FOG Server’s IP to something out side that scope (Like : 192.168.1.10)

    Then when you go thru the installer, set your Server’s IP Address to 192.168.1.10
    Your Router IP Address would then be set to 192.168.1.1
    Your DNS IP would then be 192.168.1.1

    Because you’re not trying to access your fog system using the internet, (your public IP Address), the system shouldn’t have any issues finding your system during the mysql part. Then again, I don’t know, I’m not there to see the issue either.



  • This post is deleted!


  • getting the same error.I will remove mysql and see what happens this time


  • Senior Developer


  • Senior Developer

    Are you trying to do this install from your home system?

    Give me a minute or two and I’ll post the latest and greatest that I’ve created.

    I don’t know if it will work, but it will contain many of the Fixes I’ve already implemented.



  • 0.33?How do you download that


  • Senior Developer

    Okay,

    Is there any way you’d be able to allow remote access that I could actually take a look at the file/install process?

    There shouldn’t be any problem with installing, so it seems there’s a borked command in the installer somewhere, I just don’t know where. I’m running on CentOS 6.4 and I haven’t run into any issues. I’m also running/testing 0.33 so I’m not a good example.



  • sorry for the late reply. i connected to the router that connects me to the modem.i know that mysql is working because when enter mysql in the command line,it dosen’t give me any errors.
    I downloaded the rpms for mysql and that didn’t work. the command you gave me finally worked.
    i disabled iptables and selinux some time ago.


  • Senior Developer

    Also,

    When giving information, please try to provide as much information as possible. It’s not easy to troubleshoot something when not being directly in front of it. It makes it much more difficult to help out when there isn’t any information to go off of.

    Responses such as:
    “didn’t work.”,“Didn’t help”

    Doesn’t give us anything to work off. We don’t know what you’ve tried, or how you know certain things.

    How do you know that mysql is working?
    What have you tried beyond the help I’ve tried giving?
    What kinds of error messages is the system telling you? Fog tells you information, but we don’t know your systems particular setup.


  • Senior Developer

    Okay,

    Is your FOG Server behind a router that then connects to a modem or directly connected to the modem?

    If you’re connected directly to the modem, then how did you get the DHCP Server and the DNS Server IP Address?

    You’re sure mysql is actually running on your system then?

    Is selinux running or disabled?
    To check:
    cat /etc/sysconfig/selinux

    Look for:
    SELINUX=disabled
    If it doesn’t say disabled change it and reboot your machine.
    Then check that iptables is disabled <- DONT DO THIS IF YOU’RE CONNECTED DIRECTLY TO THE MODEM
    service iptables stop; chkconfig iptables off
    Once done, retry the install process.
    Can you post a reading of:
    /var/log/messages
    Directly after you’ve tried installing fog.
    Thank you,



  • it looks like the code to check the packges is this:

    confirmPackageInstallation()
    {
    for x in $packages
    do
    echo -n " * Checking package: $x";
    rpm -q $x >/dev/null 2>&1;
    if [ “$?” != “0” ]
    then
    echo “…Failed!”
    exit 1;

        else
            echo "...OK";
        fi
    done;
    

    }

    and the configue mySQL code is here:

    configureMySql()
    {
    echo -n " * Setting up and starting MySql";
    chkconfig mysqld on;
    service mysqld restart >/dev/null 2>&1;
    service mysqld status >/dev/null 2>&1;
    if [ “$?” != “0” ]
    then
    echo “…Failed!”;
    exit 1;
    else
    echo “…OK”;
    fi
    }
    I do have some command line experence



  • it doesn’t tell me the ip i should use.I found the ip,still not installing.And my isp wont allow me to have a static ip anyway.But i am ok with changing it all the time


  • Senior Developer

    Is your fog server connected directly to the internet? You understand linux and the command line?

    The way to obtain your systems IP (which you should have setup statically) is to run:
    ifconfig
    If you have multiple interfaces, you’ll need to figure out which interface you’re trying to use and use the IP associated with that.

    I assume your IP is going to be in the range of 192.168.1.2 thru 192.168.1.254 as you put your router and dns server as 192.168.1.1

    Your files to be edited should be located in:
    <locationOfFogInstallFolder>/lib/redhat

    There are two files in there which I forget the names of.

    However, if my memory serves me correctly, when you do the install, it should ask you what you want to set your IP up as, and it defaults to your systems IP, so unless your FOG server is directly connected to the Modem, it should have a private IP address assigned to it already. I’d recommend, until you understand what this software is doing, sticking with the defaults.



  • This post is deleted!

Log in to reply
 

451
Online

5.9k
Users

13.3k
Topics

125.1k
Posts