Fog wont install

  • I know how to edit them,but i don’t know where to edit them.Also,where do i find my servers internal ip

  • This post is deleted!

  • Senior Developer

    Okay, looking into this, I don’t think there’s an issue with the default installation files for redhat. Fedora 19 should use the yum install mysql mysql-server and the configuration is chkconfig mysqld on; service mysqld restart which, you stated, works fine for your system.

    However, it may have an issue because it’s trying to restart the service from your public IP address, which would cause a failure as it, theoretically, can’t access from that point.

    Try not using your public IP address and use your server’s internal IP address during the setup. Hopefully this helps out.

  • Senior Developer

    Your public IP is not what should be used. You would use the IP address your fog server is setup for within your internal network (the network you’re trying to image from).

    Can you do me a favor and check the install. I’ll download a copy of the tar file and see what it’s doing as well, but I’ve never seen any issues with it before. Maybe it’s forgetting a part for Fedora 19 which is RH Based.

    I’ll double check, but do you know how to edit the files?

    From the install folder, look within for a folder that contains redhat and which files do the install process. I will get back here with the info, but it’s going to be a little bit.

  • By the way,Am i supposed to use my public ip? (unrelated)

  • it says i dont have mysql installed and when it download and installs the packages it wont say Skipping:MySQL (Alrerdy installed) I tried 2 times,but with the same error

  • Senior Developer


    So now that we know mysql is installed and working (how btw?) what’s the error’s you’re getting with installing fog?

  • Fog is not installing still,but mysql is intsalled perfectly

  • Senior Developer

    So is your fog setup now installed?

    If it is, what did you end up having to do?

    If it isn’t, I’ll take a look at the 0.32 Redhat install portion to find out why it didn’t install for you.


  • no errors.MySQL working perfectly now

  • Senior Developer


    What errors is it giving you when you try to manually install mysql, if any?

  • Didn’t work.

  • Senior Developer

    Try manually installing mysql with yum -y install mysql-server, it should install the package. Check that mysql is installed then, and you should find /var/lib/mysql folder. Another way to find out if it’s installed is to run:
    chkconfig mysqld on; service mysqld start
    Then, try your install. I’ll need to check the install folder for redhat to see that it’s pointing to the right package for mysql.

Log in to reply