Can't Register any hosts



  • Hi Everybody,

    I think I’m going to love FOG if I can ever get it set up correctly.

    I cannot seem to register any hosts onto the server. Most of the computers are Vostro 230s which are compatible as per the [URL=‘http://www.fogproject.org/wiki/index.php/WorkingDevices’]working devices page[/URL]. I can get to the FOG boot page, but that’s it.

    I have tried multiple different kernels, editing /tftpboot/pxelinux.cfg/default and making sure the ip address is correct but nothing works.

    I consistently get an “inappropriate ioctl” error.

    What am I doing wrong?


  • Developer

    Way to go! Sorry I couldn’t be of more assistance to you, but I am glad you got it going!



  • okay, I solved this.

    The issue was in my apache settings. This server was being used to serve other webpages using VirtualHost containers. I had “deny from all” set on my VirtualHost and that was causing some issues. I also had a permanent https redirect that might have been causing issues too.

    Once I fixed that I got the hosts to register and now I can image them.

    I hope this helps somebody.



  • Okay, so I can boot to the debug mode command line just fine. I get an IP address and everything, so the NIC is working with the latest kernel but I simply cannot register the host.

    When I type in the “fog” command I get:

    [QUOTE]Error detected.
    Cannot determine Operating System type[/QUOTE]

    The fog.man.reg command gives the same ioctl error as above.

    PLEASE somebody help me debug this.



  • I’ve tried this with three other computers: A Dell Dimension C521 circa 2004, a Shuttle XH61V which is fairly new and an ANCIENT HP Pavilion a1106n.
    They all give the same errors. I have a hard time believing that not one of these computers is compatible.

    Is there another reason why this could be happening?



  • Thanks for the quick reply. I tried the bzImage file that you point to but it immediately gives me a “flags mismatch” error and then the same thing happens.

    How can I tell what driver isn’t working? There has to be an easier way than this, no?
    Also, those fixes seem to be for an Atheros NIC but these computers are all Broadcom.


  • Developer

    try this one here
    [quote]
    We were having issues with new laptops that use the Atheros 8161 Ethernet controller so we have compiled the compat-drivers (alx) with Kernel version 3.5.4-kitchensink. Here is a link to the download for anyone that needs it:[URL=‘http://davidouwinga.com/bzImage.zip’]http://www.davidouwinga.com/bzImage.zip[/URL]
    You will need to extract the zip file and move the bzImage file to /tftpboot/fog/kernel/ as root[/quote]

    It’s a kernel issue, one of the drivers are missing you just need to figure out which and include it.

    this page explains how to include the drivers not included with the kitchen sink or not included in the kernel to enable.

    [url]http://fogproject.org/forum/threads/dell-2330-all-in-one-network-issue.1054/page-2[/url]

    and according to chad
    [quote]
    "I had a weird issue registering hosts similar to this. It turns out the students had removed the belt from the dvd-rom drives and Fog would freeze for about 45 seconds. I guess it was trying to get the status of the device, but without being able to confirm if the drive was open or closed, it just sat there and spun the motor back and forth for a while.

    I found ejecting the drive with a paper clip immediately caused Fog to continue to the normal registration.

    [B]Something else to consider is that the error you see has nothing to do with what is really causing registration to fail. Consider booting the debug mode see if the error you see is truly what’s wrong. There is a wiki guide to debugging somewhere.[/B]"[/quote]

    [url]http://fogproject.org/forum/threads/unable-to-register-certain-host.773/#post-3457[/url]

    Best of Luck.


Log in to reply
 

354
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.