• [COLOR=#333333][FONT=Arial]Version:[/FONT][/COLOR]
    [COLOR=#333333][FONT=Arial]Fog 0.32[/FONT][/COLOR]
    [COLOR=#333333][FONT=Arial]Ubuntu - 12.04 LTS[/FONT][/COLOR]
    [COLOR=#333333][FONT=Arial]Kernel - 3.9.1-030.901 generic[/FONT][/COLOR]
    [COLOR=#333333][FONT=Arial]I have 2 problems when trying to upload image:[/FONT][/COLOR]
    [COLOR=#333333][FONT=Arial]1 - HP 100B All-in-One PC (Anping-DG) Brazil - attached erro1.jpg[/FONT][/COLOR]
    [COLOR=#333333][FONT=Arial]2 - Optiplex 990 - attached erro2.jpg[/FONT][/COLOR]


  • did you run sysprep as administrator before you tried to pull the image? (first pic)

  • [quote=“Jaymes Driver, post: 13144, member: 3582”]Again, I would still be checking the permissions of the folder, because once we get the kernel working you’re going to need the permissions set properly to upload your image.

    Also I forgot to ask, what Operating System are you imaging with?[/quote]

    windows 7

  • I have had the same problem with our 990:s, check so your kernel has NFS support. Otherwize the problem lies in the init.gz, we have managed to recompile it after a lot of trouble but since we are struggling with RAID support our bzImage and init.gz are unstable otherwize I would upload them.

    Try recompiling the kernel with NFS support and get back if it ain’t working.

  • the fog server must be in the DOMINIO? because it is not the fault of uploading permission. Anyone know help me?

  • the fog server must be in the field? because it is not the fault of uploading permission. Anyone know help me?

  • Developer

    Again, I would still be checking the permissions of the folder, because once we get the kernel working you’re going to need the permissions set properly to upload your image.

    Also I forgot to ask, what Operating System are you imaging with?

  • Developer

    The Kitchen Sink kernel includes extra drivers that may be necessary for your machine hardware, the stock kernel doesn’t include all of the extra drivers as it adds to the load time of the pxe boot menu and such. But when you are stuck it’s a great starting point.

    It’s good that you are using the default folder, and that you are on a fresh server, if these applications do not work it would be a good idea to re-configure your fog server, there may be a setting somewhere that got nerfed.

    Are the ONLY pieces of hardware you are working with the HP100b and the Optiplex? Do you have other hardware you can try?

    The HP problem is a driver problem,
    The Optiplex problem is a permissions problem.

    There is an AMAZING guide written by Ozzy and posted in tutorials, it explains the process of creating a custom kernel. ->[url]http://fogproject.org/forum/threads/request-for-kernel-compiling-info-please-read.4045/[/url]

    [B]How to Build a Custom Kernel for FOG Server using Ubuntu 12.04[/B]

    First, make sure you have [B]G++ (GNU C++ compiler) and QT4 (Qt 4 Designer) [/B]installed through the Ubuntu software center.

    Next, pick a Linux kernel you want to use to compile the kernel at [URL=‘http://www.kernel.org/’]www.kernel.org[/URL]. (Used linux-3.10-rc2.tar.xz for this document;[url]https://www.kernel.org/pub/linux/kernel/v3.x/testing/linux-3.10-rc2.tar.xz[/url]) Download the file to the ‘home/user/Downloads/’ directory. (default)

    Then, download the Fog installation package installer. (Current version 0.32;[url]http://sourceforge.net/projects/freeghost/files/FOG/fog_0.32/fog_0.32.tar.gz/download[/url]) Make sure to download to the ‘home/user/Downloads/’ directory. (default)

    Now we will extract the files to their proper locations.

    First, extract the FOG installer to the download folder. (see below for command)
    [B]sudo [/B][B][FONT=Tahoma]tar -xvf /home/user/Downloads/fog_0.32.tar.gz[/FONT][/B]

    Then, we will want to extract the kernel to the ‘/usr/src/kernels/’ directory. If the directory does not exist create it. You will also need to copy the tar.gz file to the kernels directory in order to extract properly. (see below for commands)
    [B]sudo mkdir /usr/src/kernels/[/B]
    [B]sudo cp /home/user/Downloads/linux-3.10-rc2.tar.xz /usr/src/kernels/[/B]
    [B]cd /usr/src/kernels/[/B]
    [B]sudo tar –xvf linux-3.10-rc2.tar.xz[/B]

    Now we can either use CORE or Kitchen Sink to create the kernel.

    To use [B]Core[/B] use the following command:
    [B]sudo cp [/B][B][FONT=Tahoma]/home/username/Downloads/fog_0.32/kernel/core.config /usr/src/kernels/linux-3.10-rc2/.config[/FONT][/B]

    To use [B]Kitchen Sink[/B] use the following command:
    [B]sudo cp [/B][B][FONT=Tahoma]/home/username/Downloads/fog_0.32/kernel/kitchensink.config /usr/src/kernels/linux-3.10-rc2/.config[/FONT][/B]

    Once the .config file is copied to /usr/src/kernels/ you can now run the make xconfig command.
    [B]cd /usr/src/kernels/linux-3.10-rc2[/B]
    [B]sudo make xconfig[/B]

    Now the kernel editor should pop-up after a few seconds. Here is where you will locate and select/deselect drivers you want to load to your custom kernel. (see screenshot for example)


    Once you are done with your selections just [B]save and quit[/B].

    Now you have to run one final command to write the kernel file.

    For 64-bit systems:
    [B][FONT=Tahoma]sudo make ARCH=i386 bzImage[/FONT][/B]

    [FONT=Tahoma]For 32-bit systems:[/FONT]
    [B][FONT=Tahoma]sudo make bzImage[/FONT][/B]

    [FONT=Tahoma]You may get a few prompts during the compile, I just used default options (enter). It will take a while (10-30 minutes) to compile the kernel so be patient.[/FONT]

    [FONT=Tahoma]Now that you have created a custom kernel you will need to copy/cut the file to your FOG server.[/FONT]
    [FONT=Tahoma]Go to the [B]/usr/src/kernels/linux-3.10-rc2/arch/x86/boot/[/B] directory to find the new [B]bzImage[/B] file you created. That is the file you need to import to your FOG server kernels directory in order to use it. (You can rename it or use the new kernel as the default kernel for FOG to use if you leave the name bzImage)[/FONT]

    [FONT=Tahoma]The directory where you should paste the new kernel is /tftpboot/fog/kernel/ on the FOG server.[/FONT]

    [FONT=Tahoma]Make sure you assign the custom kernel to the proper host in the FOG management GUI and then you should be able to Upload/Deploy. You might need to add the host manually; you’ll just need the MAC address of the NIC for the host.[/FONT]

    [B][I][FONT=Tahoma]Written by Ozzy[/FONT][/I][/B]

  • yes
    only one hardware server, and am testing on 2 machines with different hardware … (1 error in each)
    I’m saving for the default folder
    I installed this server last week, these are my first tests …

    how do I create a kernel? my version is the most current … can it be so?

  • Developer

    Well a search and a quick look reveals the solution to the problem in the first picture.

    I would try the kitchen sink kernel and see if that helps, it may be a driver issue, you should consider writing your own custom kernel with your specific drivers included.

    As per the posting [url]http://fogproject.org/forum/threads/pxe-boot-error-no-chip.4466/#post-13138[/url]

    Jason recommends a Kitchen Sink kernel to solve the problem.

    I would still recommend taking a look at your permission settings, without the correct settings it won’t matter if you can load the pxe boot screen or not. Without the proper permissions on the folders and files you WILL NOT be able to save them.

    [SIZE=4]You also never answered my questions.[/SIZE]

    [SIZE=4][B]Is this a new fog server? [/B][/SIZE]
    [SIZE=4][B]Have you tried other hardware? [/B][/SIZE]
    [SIZE=4][B]Does the other hardware work with fog? [/B][/SIZE]
    [SIZE=4][B]Can you try another machine and see if it is driver specific? again if it is you will need a custom kernel.[/B][/SIZE]

    [SIZE=4][B]Are you saving to the /images folder or are you saving your images on another server or NAS?[/B][/SIZE]

    [SIZE=4][B]If this is NOT a new server are any other hardware affected? [/B][/SIZE]
    [SIZE=4][B]When did the problem first arise?[/B][/SIZE]

    [SIZE=3]I’d love to help you but I’m not going to try to exhume information from you or try to hold your hand, if you want help you need to pay attention and cooperate.[/SIZE]

  • the first is a mistake yes, because if I leave the machine turned on it does not upload the image. therefore believe it is a mistake!

  • Developer

    The first error you posted shouldn’t be causing you any problems, what it does first is check the bios revision and such so it can get an idea of the manufacturer and the hardware. It’s not desperately important for all of these to succeed, mainly only the video card drivers, nic, and the hard drive have to be detected.

    The second image you posted explains exactly what the problem is… You do not have permission to write to the folder.

    You will want to check your permission settings for the folder /images/dev/
    browse to the folder, right mouse click then select permissions.
    Make sure that the root user is set as the owner and that it has create and delete capabilities, and that the root group has create and delete capabilities.

    [B]1.)[/B] Is this a fresh install? If so and no images are on the server, just nuke it and try to install again, if not, does this occur on all hardware, or just a specific model? I’m going to say the issue is with the folder permissions and not the hardware for now.

    [B]2.)[/B] Are you saving your images to the /images/dev/ folder or are you saving to a NAS?

    This information below explains how to change your save space. Don’t follow it to a T, just try to remove your older folder and create a new one with the .mntcheck if the steps above do not resolve the issue,.

    [INDENT=1]Ok so for future individuals, here’s my little guide during installation[/INDENT]
    [INDENT=1] [/INDENT]
    [INDENT=1]Adding a NFS share[/INDENT]
    [INDENT=1] [/INDENT]
    [INDENT=1]First, get rid of the old /images directory. Move it somewhere safe[/INDENT]
    [INDENT=1][B]sudo mv /images /imagesold[/B][/INDENT]
    [INDENT=1][B]sudo mkdir /images[/B][/INDENT]
    [INDENT=1][B]sudo chown –R fog:root /images[/B][/INDENT]
    [INDENT=1][B]sudo chmod –R 777 /images[/B][/INDENT]
    [INDENT=1] [/INDENT]
    [INDENT=1]Next, let’s edit your fstab[/INDENT]
    [INDENT=1][B]sudo nano /etc/fstab[/B][/INDENT]
    [INDENT=1] [/INDENT]
    [INDENT=1]Add the line in your fstab for the nfs drive[/INDENT]
    [INDENT=1][B]IPADDRESS:/sharename /images nfs defaults 0 0[/B][/INDENT]
    [INDENT=1] [/INDENT]
    [INDENT=1]Mount the drive[/INDENT]
    [INDENT=1][B]sudo mount -a[/B][/INDENT]
    [INDENT=1] [/INDENT]
    [INDENT=1]Then reapply the permissions to the folder now that the drive is mounted. Create the dev folder and .mntcheck folders[/INDENT]
    [INDENT=1][B]sudo mkdir /images/dev[/B][/INDENT]
    [INDENT=1][B]sudo touch /images/dev/.mntcheck[/B][/INDENT]
    [INDENT=1][B]sudo touch /images/.mntcheck[/B][/INDENT]
    [INDENT=1][FONT=arial][SIZE=3][B]sudo chown –R fog:root /images[/B][/SIZE][/FONT][/INDENT]
    [INDENT=1][SIZE=3][FONT=arial][B]sudo chmod –R 755 /images[/B][/FONT][/SIZE][/INDENT]
    [INDENT=1][SIZE=3][FONT=arial][B]sudo chmod –R 777 /images/dev[/B][/FONT][/SIZE][/INDENT]
    [INDENT=1] [/INDENT]
    [INDENT=1]Then login to the FOG panel, go to storage management, click Add Storage Node and then use these values[/INDENT]
    [INDENT=1] [/INDENT]
    [INDENT=1]Storage Node Name: Whatever you want[/INDENT]
    [INDENT=1]Storage Node Description: Whatever you want[/INDENT]
    [INDENT=1]IP Address: IP Address of your NFS share. JUST THE IP ADDRESS[/INDENT]
    [INDENT=1]Max Clients: Whatever you want, I generally stick 10 in there[/INDENT]
    [INDENT=1]Is Master Node: Yes. Note - if you tick this, it’ll wipe images you’ve already created[/INDENT]
    [INDENT=1]Storage group: Default[/INDENT]
    [INDENT=1]Image location: Enter the folder on your NAS drive that your images are stored in[/INDENT]
    [INDENT=1]Is enabled: Tick it[/INDENT]
    [INDENT=1]Management Username: the username you use to login to the FOG control panel[/INDENT]
    [INDENT=1]Management Password: the password you use to login to the FOG control panel[/INDENT]
    [INDENT=1] [/INDENT]
    [INDENT=1]Click update, and you’re done![/INDENT]

    icarus - [url]http://fogproject.org/forum/threads/error-mounting-filesystem-images-dev-on-an-nfs.4205/[/url]