Slow multicast?


  • Moderator

    Hi we have seperate Vlans here server, student and staff

    student and staff dhcp options 66/67 has been configured on both of these vlans pxe menu/unicasting works great, 100mb network unicast speeds of 1.25gb/min

    switches are cisco with multicasting enabled
    when trying a multicast with the same 2 pc’s that were used for unicasting the multicast speed drops to 10mb/min any ideas or tests I can run?

    server spec is
    fog 0.32 ubuntu server 11.10
    Linux 3.0.0-15-server on x86_64
    Intel® Core™2 Duo CPU E6750 @ 2.66GHz, 2 cores
    2gb ram


  • Moderator

    Yes I must add whilst I had a good run with multicasting I now prefer to unicast.


  • Moderator

    I think slow multicast is usually do to kernel problems on the client or network misconfigurations. And the slowest multicast client will drag everyone down to their speed.

    I can generally unicast 15 clients faster than I can multicast to them, because even with 15 clients active on a gigabit network, I’m getting 900MB/min to each client.

    If you are sure your network is configured properly, then I’d try different kernels on the clients.


  • Moderator

    [SIZE=11px][FONT=Verdana][COLOR=#333333]‘Webmin is a web-based interface for system administration for Unix’[/COLOR][/FONT][/SIZE]

    you can download it [URL=‘http://www.webmin.com/download.html’]here[/URL]

    note that you can do what I said via commands but webmin is a pretty neat tool for servers without a gui



  • Falko,
    I am running into this same issue with my fog server. It seems at right around 20% my multicast speed has declined from 500Mb/min to less than 100Mb/min. I am also running Ubuntu 12.04, and would like to see if I can make it work without rolling back to 10.04.

    I am somewhat unfamiliar with this part of your post “Using Webadmin, I logged into the mysql section created a new user (fogadmin) and password, giving this account full permission. I then edited the MYSQL info in /var/www/fog/commons/config.php + /opt/fog/service/etc/config.php. to match.”

    If you can spare the time, could you elaborate a bit more about this process?

    Thanks, in advance



  • Cool I will try this on my network soon and let you know how it goes.


  • Moderator

    okay so I have believe I have fixed the issue after rebuilding the server a few times. I settled with ubuntu 10.04.03 in the end. During FOG install I set the mysql root password as normal

    Using Webadmin, I logged into the mysql section created a new user (fogadmin) and password, giving this account full permission. I then edited the MYSQL info in /var/www/fog/commons/config.php + /opt/fog/service/etc/config.php. to match. Multicast speed is now at 670+ mb/min.

    also I am now using the newly released kernel 3.2.4

    this week I will move the server to a gigabit port on the switch which I hope will help increase this speed, though it is still 100mb to desktop.


  • Moderator

    (bump) anyone have any ideas/settings to check?
    ghost multicast works and can image a suite in one hour, but fog says it will take 30+


Log in to reply
 

392
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.