Lenovo x131e w/ AMD processor



  • I just received a batch of Lenovo x131e laptops with an AMD E2-1800 processor and Radeon HD 7340 graphics. The computers are crashing to a static screen while attempting to boot from the fog server. I have updated the fog server to the latestest 3.8.8 core kernel. I have also tried compiling a 3.10.1 and a 3.11 kernel with the core and kitchensink config files. I get the static screen with each of the bzImage files I have tried.

    Any suggestions would be greatly appreciated.


  • Senior Developer

    Nothing broke between them. A core kernel such as the one you’re describing (default install) contains drivers for video cards. With this comes the idea of kernel mode setting (KMS) which makes the terminal screen fit to the native resolution (if I understand it correctly) to your display.

    The issue was KMS was not a fully tested feature and hence would show a snowy screen on some systems. Other systems it would display perfectly fine.

    I imagine that an updated kernel (which one did you use 3.8.8 or something somebody built?) just has more support for video and can properly negotiate the KMS needed for the display.

    If you’re using a custom one, I imagine you’re using a kernel that doesn’t care about the video card and just displays no matter what, which would also explain why you’re not seeing the “snowy” screen anymore.



  • I just built a fresh FOG 0.32 server and forgot to update the kernel. Much to my surprise, I was able to perfectly inventory and deploy to these X131e systems without the snowy screen. So, what broke between the default kernel and the updated ones??


  • Developer

    I would say you are definitely on the right track, it appears to be a Video card driver issue :)



  • I believe I’ve got my issue straightened out. I compiled a 3.11rc kernel using the core config file. I used make menuconfig and removed support for the ATI Radeon. I was able to boot to the coomand prompt in debug mode, successfully perform a full inventory and am currently loading an image.


Log in to reply
 

432
Online

38938
Users

10697
Topics

101491
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.