Computers are not renaming themselves and joining the domain after imaging.



  • We have an issue where our hosts, upon reimage, are no longer renaming themselves and joining to the domain. The process works perfectly in our IT offices. It appears that when crossing VLAN’s the issue is manifested.

    Has anyone seen this issue and know of a solution to it?

    Thank you,

    Justin



  • The specified hostname is the name we specified for the computer. It is using our naming convention.



  • In the web console go to the host section and search for 00:01:6C:55:98:43
    What is specified for the hostname?



  • Well… I had a few computers that were not registered at all this morning. I performed a Full Host Registration and the same thing is happening after re-imaging them. We are not using Capone.



  • I think I know what your issue is. You have quick registered the computers and not used the full registration in fog menu. This uses the mac address as a hostname and that’s not a valid computer name in windows, or you are using Capone and the computers are not in the database.

    See:-

    7/18/2013 9:00 AM FOG::HostnameChanger Host name was not found in the database.
    7/18/2013 9:05 AM FOG::TaskReboot No job exists for 00:01:6C:55:98:43

    Search for 00:01:6C:55:98:43 and change it for a valid hostname.



  • Here is the fog.log:

    7/3/2013 11:14 AM FOG::ClientUpdater Checking Status : UserTracker.dll
    7/3/2013 11:14 AM FOG::ClientUpdater No update found on server for UserTracker.dll
    7/3/2013 11:14 AM FOG::ClientUpdater Checking Status : config.ini
    7/3/2013 11:14 AM FOG::ClientUpdater No update found on server for config.ini
    7/3/2013 11:14 AM FOG::ClientUpdater Zero byte response returned
    7/3/2013 11:14 AM FOG::ClientUpdater 0 new modules found!
    7/3/2013 11:14 AM FOG::ClientUpdater Client update will be applied during next service startup.
    7/3/2013 11:14 AM FOG::ClientUpdater Client update process complete, exiting…
    7/3/2013 11:18 AM FOG::SnapinClient Attempting to connect to fog server…
    7/3/2013 11:18 AM FOG::SnapinClient Module is active…
    7/3/2013 11:18 AM FOG::SnapinClient No Tasks found for: 00:01:6C:55:B7:04
    7/3/2013 11:23 AM FOG::SnapinClient Attempting to connect to fog server…
    7/3/2013 11:23 AM FOG::SnapinClient Module is active…
    7/3/2013 11:23 AM FOG::SnapinClient No Tasks found for: 00:01:6C:55:B7:04
    7/3/2013 11:28 AM FOG::SnapinClient Attempting to connect to fog server…
    7/3/2013 11:28 AM FOG::SnapinClient Module is active…
    7/3/2013 11:28 AM FOG::SnapinClient No Tasks found for: 00:01:6C:55:B7:04
    7/3/2013 11:34 AM FOG::SnapinClient Attempting to connect to fog server…
    7/3/2013 11:34 AM FOG::SnapinClient Module is active…
    7/3/2013 11:34 AM FOG::SnapinClient No Tasks found for: 00:01:6C:55:B7:04
    7/3/2013 11:39 AM FOG::SnapinClient Attempting to connect to fog server…
    7/3/2013 11:39 AM FOG::SnapinClient Module is active…
    7/3/2013 11:39 AM FOG::SnapinClient No Tasks found for: 00:01:6C:55:B7:04
    7/3/2013 11:44 AM FOG::SnapinClient Attempting to connect to fog server…
    7/3/2013 11:44 AM FOG::SnapinClient Module is active…
    7/3/2013 11:44 AM FOG::SnapinClient No Tasks found for: 00:01:6C:55:B7:04
    7/3/2013 11:49 AM FOG::SnapinClient Attempting to connect to fog server…
    7/3/2013 11:49 AM FOG::SnapinClient Module is active…
    7/3/2013 11:49 AM FOG::SnapinClient No Tasks found for: 00:01:6C:55:B7:04
    7/3/2013 11:54 AM FOG::SnapinClient Attempting to connect to fog server…
    7/3/2013 11:54 AM FOG::SnapinClient Module is active…
    7/3/2013 11:54 AM FOG::SnapinClient No Tasks found for: 00:01:6C:55:B7:04
    7/3/2013 11:56 AM FOG::UserTracker Event: LOGOUT for CENTCOLLEGE\teacher
    7/3/2013 11:56 AM FOG::UserTracker Record processed by server!
    7/18/2013 9:00 AM FOG Service Engine Version: 3
    7/18/2013 9:00 AM Starting all sub processes
    7/18/2013 9:00 AM 14 modules loaded
    7/18/2013 9:00 AM * Starting FOG.AutoLogOut
    7/18/2013 9:00 AM * Starting FOG.SnapinClient
    7/18/2013 9:00 AM * Starting FOG.DirCleaner
    7/18/2013 9:00 AM FOG::AutoLogOut Starting process…
    7/18/2013 9:00 AM FOG::DirCleaner Sleeping for 32 seconds.
    7/18/2013 9:00 AM FOG::ClientUpdater Starting client update process…
    7/18/2013 9:00 AM FOG::ClientUpdater Sleeping for 101 seconds.
    7/18/2013 9:00 AM * Starting FOG.DisplayManager
    7/18/2013 9:00 AM * Starting FOG.GreenFog
    7/18/2013 9:00 AM FOG::DisplayManager Starting display manager process…
    7/18/2013 9:00 AM * Starting FOG.GUIWatcher
    7/18/2013 9:00 AM FOG::GUIWatcher Starting GUI Watcher…
    7/18/2013 9:00 AM FOG::GreenFog Sleeping for 50 seconds.
    7/18/2013 9:00 AM * Starting FOG.HostNameChanger
    7/18/2013 9:00 AM * Starting FOG.HostRegister
    7/18/2013 9:00 AM FOG::HostRegister Starting host registration process…
    7/18/2013 9:00 AM FOG::HostnameChanger Starting hostname change process…
    7/18/2013 9:00 AM FOG::HostnameChanger Yielding to other subservices for 8 seconds.
    7/18/2013 9:00 AM * Starting FOG.MODDebug
    7/18/2013 9:00 AM FOG::MODDebug Start Called
    7/18/2013 9:00 AM FOG::MODDebug Sleeping for 100 Seconds
    7/18/2013 9:00 AM FOG::PrinterManager Starting interprocess communication process…
    7/18/2013 9:00 AM * Starting FOG.SnapinClient
    7/18/2013 9:00 AM FOG::PrinterManager interprocess comm startup: OK
    7/18/2013 9:00 AM FOG::SnapinClient Starting snapin client process…
    7/18/2013 9:00 AM * Starting FOG.TaskReboot
    7/18/2013 9:00 AM FOG::TaskReboot Taskreboot in lazy mode.
    7/18/2013 9:00 AM FOG::TaskReboot Starting Task Reboot…
    7/18/2013 9:00 AM * Starting FOG.UserCleanup
    7/18/2013 9:00 AM FOG::UserCleanup Sleeping for 18 seconds.
    7/18/2013 9:00 AM * Starting FOG.UserTracker
    7/18/2013 9:00 AM FOG::UserTracker Starting user tracking process…
    7/18/2013 9:00 AM FOG::AutoLogOut Unable to continue, MAC is null!
    7/18/2013 9:00 AM FOG::SnapinClient Sleeping for 468 seconds.
    7/18/2013 9:00 AM FOG::UserTracker Unable to determine MAC address, exiting…
    7/18/2013 9:00 AM FOG::TaskReboot No valid MAC addresses found!
    7/18/2013 9:00 AM FOG::TaskReboot No task found for client.
    7/18/2013 9:00 AM FOG::HostnameChanger Host name was not found in the database.
    7/18/2013 9:00 AM FOG::UserCleanup Starting user cleanup process…
    7/18/2013 9:00 AM FOG::UserCleanup Attempting to connect to fog server…
    7/18/2013 9:00 AM FOG::UserCleanup Module is disabled globally on the FOG Server, exiting.
    7/18/2013 9:00 AM FOG::DirCleaner Starting directory cleaning process…
    7/18/2013 9:00 AM FOG::DirCleaner Attempting to connect to fog server…
    7/18/2013 9:00 AM FOG::DirCleaner Module is active…
    7/18/2013 9:00 AM FOG::DirCleaner Determining which directories should be cleaned…
    7/18/2013 9:00 AM FOG::DirCleaner No directories are configured to be cleaned.
    7/18/2013 9:00 AM FOG::DirCleaner Starting directory cleaning loop…
    7/18/2013 9:00 AM FOG::DirCleaner Module has finished work and will now exit.
    7/18/2013 9:01 AM FOG::GreenFog Starting green fog…
    7/18/2013 9:01 AM FOG::GreenFog Attempting to connect to fog server…
    7/18/2013 9:01 AM FOG::GreenFog Module is active…
    7/18/2013 9:01 AM FOG::GreenFog No actions were found.
    7/18/2013 9:01 AM FOG::GreenFog No tasks found after validation!
    7/18/2013 9:01 AM FOG::MODDebug Reading config settings…
    7/18/2013 9:01 AM FOG::MODDebug Reading of config settings passed.
    7/18/2013 9:01 AM FOG::MODDebug Starting Core processing…
    7/18/2013 9:01 AM FOG::MODDebug Operating System ID: 6
    7/18/2013 9:01 AM FOG::MODDebug Operating System Minor: 1
    7/18/2013 9:01 AM FOG::MODDebug MAC ID 0 00:01:6C:55:98:43
    7/18/2013 9:01 AM FOG::MODDebug MAC POST String: 00:01:6C:55:98:43
    7/18/2013 9:01 AM FOG::MODDebug No user is currently logged in
    7/18/2013 9:01 AM FOG::MODDebug Hostname: APPLES
    7/18/2013 9:01 AM FOG::MODDebug Attempting to open connect to: [url]http://10.100.2.100/fog/service/debug.php[/url]
    7/18/2013 9:01 AM FOG::MODDebug Server responded with: Hello FOG Client
    7/18/2013 9:01 AM FOG::MODDebug Module has finished work and will now exit.
    7/18/2013 9:01 AM FOG::ClientUpdater Attempting to connect to fog server…
    7/18/2013 9:01 AM FOG::ClientUpdater Module is active…
    7/18/2013 9:01 AM FOG::ClientUpdater Checking Status : AutoLogOut.dll
    7/18/2013 9:01 AM FOG::ClientUpdater No update found on server for AutoLogOut.dll
    7/18/2013 9:01 AM FOG::ClientUpdater Checking Status : ClientUpdater.dll
    7/18/2013 9:01 AM FOG::ClientUpdater No update found on server for ClientUpdater.dll
    7/18/2013 9:01 AM FOG::ClientUpdater Checking Status : DirCleaner.dll
    7/18/2013 9:01 AM FOG::ClientUpdater No update found on server for DirCleaner.dll
    7/18/2013 9:01 AM FOG::ClientUpdater Checking Status : DisplayManager.dll
    7/18/2013 9:01 AM FOG::ClientUpdater No update found on server for DisplayManager.dll
    7/18/2013 9:01 AM FOG::ClientUpdater Checking Status : GreenFog.dll
    7/18/2013 9:01 AM FOG::ClientUpdater No update found on server for GreenFog.dll
    7/18/2013 9:01 AM FOG::ClientUpdater Checking Status : GUIWatcher.dll
    7/18/2013 9:01 AM FOG::ClientUpdater No update found on server for GUIWatcher.dll
    7/18/2013 9:01 AM FOG::ClientUpdater Checking Status : HostRegister.dll
    7/18/2013 9:01 AM FOG::ClientUpdater No update found on server for HostRegister.dll
    7/18/2013 9:01 AM FOG::ClientUpdater Checking Status : MODDebug.dll
    7/18/2013 9:01 AM FOG::ClientUpdater No update found on server for MODDebug.dll
    7/18/2013 9:01 AM FOG::ClientUpdater Checking Status : PrinterManager.dll
    7/18/2013 9:01 AM FOG::ClientUpdater No update found on server for PrinterManager.dll
    7/18/2013 9:01 AM FOG::ClientUpdater Checking Status : SnapinClient.dll
    7/18/2013 9:01 AM FOG::ClientUpdater No update found on server for SnapinClient.dll
    7/18/2013 9:01 AM FOG::ClientUpdater Checking Status : TaskReboot.dll
    7/18/2013 9:01 AM FOG::ClientUpdater No update found on server for TaskReboot.dll
    7/18/2013 9:01 AM FOG::ClientUpdater Checking Status : UserCleanup.dll
    7/18/2013 9:01 AM FOG::ClientUpdater No update found on server for UserCleanup.dll
    7/18/2013 9:01 AM FOG::ClientUpdater Checking Status : UserTracker.dll
    7/18/2013 9:01 AM FOG::ClientUpdater No update found on server for UserTracker.dll
    7/18/2013 9:01 AM FOG::ClientUpdater Checking Status : config.ini
    7/18/2013 9:01 AM FOG::ClientUpdater No update found on server for config.ini
    7/18/2013 9:01 AM FOG::ClientUpdater Zero byte response returned
    7/18/2013 9:01 AM FOG::ClientUpdater 0 new modules found!
    7/18/2013 9:01 AM FOG::ClientUpdater Client update will be applied during next service startup.
    7/18/2013 9:01 AM FOG::ClientUpdater Client update process complete, exiting…
    7/18/2013 9:05 AM FOG::TaskReboot Attempting to connect to fog server…
    7/18/2013 9:05 AM FOG::TaskReboot Module is active…
    7/18/2013 9:05 AM FOG::TaskReboot Attempting to connect to fog server…
    7/18/2013 9:05 AM FOG::TaskReboot No job exists for 00:01:6C:55:98:43
    7/18/2013 9:05 AM FOG::TaskReboot No task found for client.



  • Restart the fog service and then look at c:\fog.log again There should be an entry for Hostname changer like below:-

    18/07/2013 09:03 FOG::HostnameChanger Attempting to connect to fog server…
    18/07/2013 09:03 FOG::HostnameChanger Module is active…
    18/07/2013 09:03 FOG::HostnameChanger Hostname is up to date

    If you running 0.32 you could also try changing the fog setting [B]FOG_CHANGE_HOSTNAME_EARLY[/B] to [B]0[/B]



  • This computer was re-imaged today.

    This is what is in the fog.log:

    7/15/2013 10:00 AM FOG::ClientUpdater Zero byte response returned
    7/15/2013 10:00 AM FOG::ClientUpdater 0 new modules found!
    7/15/2013 10:00 AM FOG::ClientUpdater Client update will be applied during next service startup.
    7/15/2013 10:00 AM FOG::ClientUpdater Client update process complete, exiting…
    7/15/2013 10:03 AM FOG::SnapinClient Attempting to connect to fog server…
    7/15/2013 10:03 AM FOG::SnapinClient Module is active…
    7/15/2013 10:03 AM FOG::SnapinClient No Tasks found for: 00:01:6C:55:98:43
    7/15/2013 10:08 AM FOG::SnapinClient Attempting to connect to fog server…
    7/15/2013 10:08 AM FOG::SnapinClient Module is active…
    7/15/2013 10:08 AM FOG::SnapinClient No Tasks found for: 00:01:6C:55:98:43
    7/15/2013 10:14 AM FOG::SnapinClient Attempting to connect to fog server…
    7/15/2013 10:14 AM FOG::SnapinClient Module is active…
    7/15/2013 10:14 AM FOG::SnapinClient No Tasks found for: 00:01:6C:55:98:43
    7/15/2013 10:19 AM FOG::SnapinClient Attempting to connect to fog server…
    7/15/2013 10:19 AM FOG::SnapinClient Module is active…
    7/15/2013 10:19 AM FOG::SnapinClient No Tasks found for: 00:01:6C:55:98:43
    7/15/2013 10:24 AM FOG::SnapinClient Attempting to connect to fog server…
    7/15/2013 10:24 AM FOG::SnapinClient Module is active…
    7/15/2013 10:24 AM FOG::SnapinClient No Tasks found for: 00:01:6C:55:98:43
    7/15/2013 11:15 AM FOG::SnapinClient Attempting to connect to fog server…
    7/15/2013 11:15 AM FOG::SnapinClient Module is active…
    7/15/2013 11:15 AM FOG::SnapinClient No Tasks found for: 00:01:6C:55:98:43



  • As above login to computer using local admin account and check c:\fog.log. The auto login script is not the reason why its failing. Your answer will be in there.



  • Here is the issue. We have a registry setting to automatically login as a generic domain user. What happens is that after FOG imaging, the host attempts to log in as this domain user before it has been put onto the domain. A error message is thrown on the login screen stating cannot log in. In the past, this would not happen. The client would re-image, restart itself, rename itself and add itself to the domaind, restart, and then auto login as the generic domain user.



  • On the client computers, check the contents of c:\fog.log. Is the Client checking into the server. Are there any error messages?



  • We are using AD. This did not used to be an issue. Recently this has become apparent. Additionally, generalize and OOBE are commands for sysprep using WDS. I am using FOG to capture and deploy in our classroom and lab environments. I am able to login to the computer as local admin only. Once in a while, once logging in as local admin, it will rename itself and join the domain, but not everytime. It used to be automated.



  • Had similar problems, although I had thought that this step was done before the machines loaded their image. Are you using active directory at all?

    One issue we had was network card drivers in one particular room. Windows 7, generalize’d and OOBE’d, didn’t like the Intel NIC that was in those particular machines. Added the drivers to the base image and it was fine - computers then all joined and renamed fine.

    Can you actually login to Windows?



  • Kamran just out of interest, can you resolve “fogserver” from any location? or only by IP address?



  • I have found to solution for issue that I was having, reinstalled the fog service on client and gave IP address instead of fog server name.



  • Yes. We have no connection issue. We re-image right from the classroom. It is only the post image rename and domain join that is failing.



  • Can you ping the fog server from said vlan?



  • I have the same problem,

    I have Centos 6 with FOG 0.32 and external DHCP server.


Log in to reply
 

360
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.