Windows 7 image gets corrupted when Steam is installed



  • Hello,

    We’re experiencing a very strange problem when attempting to deploy an image which has the Steam gaming software installed. For about 5 years now, we have had Steam installed in two of our computer labs, and we have always used FOG to create an image from the master PC and then deploy that image to the labs. This process has worked flawlessly in the past, on both Windows XP Professional and Windows 7 Enterprise.

    This year, however, the image is consistently corrupted when pushed to other PCs. We performed a fresh install of Windows 7 Enterprise (64-bit) on one of our PCs, and then installed Steam on it. Everything worked fine on that PC, but when we made a FOG image of it and deployed the image to a second computer, we encountered the problem. Sysprep refused to run due to filesystem errors, and rebooted the machine. CHKDSK ran on the next boot, rebuilt a ton of indexes, and then proceeded to recover a huge number of orphaned files, all of which were under the C:\Program Files (x86)\Steam\ directory. This happens every time the imaged machine boots, so the filesystem is never actually fixed.

    We tried making the image from scratch three times, and this happened every time. The really weird thing is that this only happens after Steam is installed. We’re running the newest version of FOG and this was a clean install of both Windows and Steam. Images without Steam installed work just fine.

    Some details: The image type is “Multiple Partition Image - Single Disk (Not Resizable)”. Steam is installed as a local administrator using the freely-available installer from steampowered.com. Once Steam and its games are installed, the permissions on the “C:\Program Files (x86)\Steam” folder are customized such that only members of the Administrators group have access to it. All other permissions, including inherited permissions, are removed. Doesn’t seem like this should cause the problem’s we’re seeing, though.

    Any ideas and suggestions are welcomed!

    Thanks,
    Dave


  • Moderator

    Also, I assume Steam is up to date. Steam had an known issue mid to late last year that caused orphan files in many systems. They released an update that resolved the issue and cleaned up after its self.


  • Moderator

    Are you using audit mode to customize your image, then sysprep /generalize , etc before you take the image for FOG?

    I’m guessing this is due to DRM changes Steam may have made so you can’t purchase content and then copy it to a bunch of other machines.



  • This post is deleted!

Log in to reply
 

406
Online

38969
Users

10712
Topics

101666
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.