Problem for Trying to change pxelinux to gpxelinux



  • Hello everybody!

    I’m not speak English good, sorry for this.

    I need load ISO over http insead of TFTP, so now I will explain my configuration of files. I use dnsmask service because in my house use a router and I don’t want to install a dhcp server,I use ltsp.conf of FOG WIKI. I’ve changed dhcp-boot and dhcp-range option only:

    The boot filename.

    dhcp-boot=pxelinux.0

    This range(s) is for the public interface, where dnsmasq functions

    as a proxy DHCP server providing boot information but no IP leases.

    Any ip in the subnet will do, so you may just put your server NIC ip here.

    Since dnsmasq is not providing true DHCP services, you do not want it

    handing out IP addresses. Just put your servers IP address for the interface

    that is connected to the network on which the FOG clients exist.

    If this setting is incorrect, the dnsmasq may not start, rendering

    your proxyDHCP ineffective.

    dhcp-range=192.168.1.3,proxy

    But now I don’t know that to change for load ISOS over HTTP.

    Someone can help me please?

    Thank you very match


  • Moderator

    You’re going to need to review the threads here on using gPXE and interpret them to apply to proxy-dhcp/ltsp/dnsmasq. It should not be that difficult, you’re just going to hand off from pxe to gPXE, then grab the correct menu and go from there. The only difference may be the location of your pxelinux.0 file and the pxelinux.cfg directory location.


Log in to reply
 

447
Online

39.4k
Users

11.1k
Topics

105.5k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.