Optiplex 960. Intermittent DHCP issues during PXE boot. No DHCP offers received.



  • I have FOG running in a virtualbox on my workstation and has been working great for the last 7 months until we received a new batch of Optiplex 960’s we are putting in a few labs. The issue is when booting to network PXE-E51 No DHCP or proxyDHCP offers were received. This is an intermittent problem… sometimes works… sometimes don’t… some not at all. These computers were refurbished and have different versions of the Intel Boot Agent but its still intermittent (even if they have the same version).

    Our setup:
    [LIST]
    []FOG is running on Ubuntu 10.04 LTS
    [
    ]Windows 2008 r2 as our DNS/DHCP/Domain server.
    []I’ve set options 066 and 067 correctly.
    [
    ]Went into DHCP Scope properties > Advanced and checked “Both” under Assign IP addresses dynamically to client of.
    [*]Switches connect the buildings together. I haven’t messed with the switches (we probably have close to 2 dozen switches total on our network).
    [/LIST]
    AFAIK, this is only affecting the Optiplex 960’s.
    Has anyone else had issues with this Dell model? Any tips or advice?

    [B]NOTE:[/B] Plugged an Optiplex 960 directly into the wall ethernet port and got the No DHCP offers received. Then restart it but this time plugged the ethernet into our KVM/Ethernet Switch combo that is connected to the SAME wall port and it worked perfectly.
    This is a weird issue. Advise please.



  • Another possibility is that if you are using HP ProCurve switches, the Spanning Tree protocol could be causing the delays which will cause pxe to timeout. I am not sure why reverting to an older bios will help this, but maybe they simply have a longer timeout period.

    TRY turning spanning tree OFF for the switch that the system you are wanting PXE boot is connected to and see if that helps. If it does, then this could be an option for when you need to reimage a room. It is probably best to ensure Spanning Tree is re-enabled when finished to ensure there is some protection from network loops.



  • Just had this same issue where I wasn’t getting an IP on PXE boot. Turns out it was an issue with the BIOS update. The newest right now is A18, but I had to go all the way back down to A04 (Intel Boot Agent 1.3.27) to be able to pick up a PXE IP. I also tested others in between with no success. A04 was the highest that would actually grab the address.

    Here is a link to the BIOS. Give it a shot.
    [url]http://www.dell.com/support/drivers/us/en/555/DriverDetails/Product/optiplex-960?driverId=1NTXN&fileId=2731108670[/url]

    Hope this helps!



  • Christian, this sounds to me like it might be a switch configuration issue; if you’re using Cisco switches check to see if PortFast is enabled.


  • group:cid:13:privileges:mods:members

    Especially with a new batch of hardware that’s causing problems, have you updated the BIOS on them, also, have you tried a different kernel? 3.6.9 seemed to work with our Dell’s really well.



  • bump


Log in to reply
 

364
Online

38976
Users

10712
Topics

101675
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.