Setting passwords for users in FOG management issues...



  • It seems the passwords I set cannot have any special characters in them. (@, $, *, &, as examples). For example, if I reset the default fog user from the default “password” to “p@$$w0rd” it will error out on me and say invalid password. I also tried to reset it through the database via the following link and I was not able to log in at all:

    [url]http://www.fogproject.org/wiki/index.php/Reset_WebUI_FOG_password[/url]

    I’m running FOG 0.32 on Ubuntu 10.04.4 Server. Any insight into the issue would be appreciated. Thanks!



  • That worked. Thanks!


  • Developer

    I have not adjusted the passwords but I know there is a section of the Web GUI where you can set the characters accepted for a password.

    Click on Other Settings, then FOG Settings, 3/4 of the way down the page

    User Management

    FOG_USER_MINPASSLENGTH
    FOG_USER_VALIDPASSCHARS

    default is set to 1234567890ABCDEFGHIJKLMNOPQRSTUVWZXYabcdefghijklmnopqrstuvwxyz_hB()^!
    try setting it to 1234567890ABCDEFGHIJKLMNOPQRSTUVWZXYabcdefghijklmnopqrstuvwxyz_hB()^!@#$%^&*-=+

    I saved the changes and it accepts the characters but again, I’ve not tried adjusting passwords.


Log in to reply
 

523
Online

39.4k
Users

11.1k
Topics

105.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.