FOG problems connecting to NFS share on NAS4FREE



  • So I spent 10+ hours today trying to get this to work. I’ve followed multiple tutorials on using an external NFS share and my results are not good. After I configure the NFS share in FOG the web GUI says unable to connect on the front page where usually the space free/used is displayed. I’ve created the NFS share, remade /images mounted my NFS share in FOG on /images, created the .mntcheck and then the /dev folder with .mntcheck inside it. I’ve made sure to chmod -R fog:root /images. When uploading an image once the process gets to send method-nfs I get an error of mount: 192.168.62.125:mnt/nfsdata/dev/ failed, reason given by server : Permission denied
    mount: mounting 192.168.62.125:/mnt/nfsdata/dev/ on /images failed bad file descriptor. I’ve even tried following posts on here where people had similar issues and i’ve had no luck. The fog server is a vm running in Proxmox with bridged networking. Any ideas?



  • [quote=“Axel, post: 12528, member: 686”]So I spent 10+ hours today trying to get this to work. I’ve followed multiple tutorials on using an external NFS share and my results are not good. After I configure the NFS share in FOG the web GUI says unable to connect on the front page where usually the space free/used is displayed. I’ve created the NFS share, remade /images mounted my NFS share in FOG on /images, created the .mntcheck and then the /dev folder with .mntcheck inside it. I’ve made sure to chmod -R fog:root /images. When uploading an image once the process gets to send method-nfs I get an error of mount: 192.168.62.125:mnt/nfsdata/dev/ failed, reason given by server : Permission denied
    mount: mounting 192.168.62.125:/mnt/nfsdata/dev/ on /images failed bad file descriptor. I’ve even tried following posts on here where people had similar issues and i’ve had no luck. The fog server is a vm running in Proxmox with bridged networking. Any ideas?[/quote]

    hey Axel

    not sure if you resolved your issue, post is too long… didn’t read all of it…

    however, I have noticed two things that may be causing your issue…

    the first… you used chmod -R fog:root /images… when it should be chown -R fog:root /images (perhaps you meant to type that…)
    the second, in your screen shots for the storage node section, the password field should resemble the password in plain text, not the encrypted type… try changing to your normal password, save and try that…

    I always issue (right or wrong) the following commands on the /images folder…
    chmod -R 777 /images
    chown -R fog:root /images

    but that’s just me…



  • Hello fellow FOGGERS hahahhah, I am new to the whole FOG Server (Love it, I think I’ve paid my dues in installing OS from scratch), I am about to run the same setup for 60 PC. Were you able to mount the NFS Share folder? I have Ubuntu & FOG Server set up where do I go from here? Any help will be appreciated.

    Thanks in advance,
    Tired of Running Setups



  • Hi,

    by default there is storage group with a belonging storage node if you installed fog.
    if you now would like to add an additional storage node (nfs share) where fog is not installed physically on the os side, create an additional storage group with your storage node configured inside.

    Greetz X23



  • I’m afraid I don’t understand what you mean here, did I do something to it ?



  • Hi,

    leave the default storage node completely untouched.
    [QUOTE]The Trick is to not disable the DefaultMember node even not using it.[/QUOTE]
    hehe i need to quote myself :D

    Greetz X23



  • OK, made some progress but need some more guidance here. First off i’m still getting this permission denied error, but its only naming the /images/dev folder
    [ATTACH=full]328[/ATTACH]

    good news is I can now see what I have for storage on my nas4free server
    [ATTACH=full]329[/ATTACH]

    Here is what my storage definition page looks like in the web gui

    [ATTACH=full]330[/ATTACH]

    Here is what my fstab looks like on the fog server, I have been trying several configurations which is why I have a commented out entry in my fstab.

    [ATTACH=full]331[/ATTACH]

    Below is a ls -la of my images directory, would my .mntcheck files being owned by root be the problem?

    [ATTACH=full]332[/ATTACH]

    The next image is showing nfs mounts available

    [ATTACH=full]333[/ATTACH]

    Below are some screens from my nas4free system. I have a fog user set up on my nas, but i’ve tried the password for the fog user as “password” but this does now work.

    [ATTACH=full]334[/ATTACH]

    Finally my nfs settings on the nas4free box

    [ATTACH=full]335[/ATTACH]

    I have my zfs pool mounted on /images on my nas box. I’m literally stuck on this and following similar problems how to’s and fixes doesn’t seem to be helping my permissions denied problems.

    [url="/_imported_xf_attachments/0/328_fogerror.JPG?:"]fogerror.JPG[/url][url="/_imported_xf_attachments/0/329_fogdash.JPG?:"]fogdash.JPG[/url][url="/_imported_xf_attachments/0/330_fogstorage.JPG?:"]fogstorage.JPG[/url][url="/_imported_xf_attachments/0/331_fogfstab.JPG?:"]fogfstab.JPG[/url][url="/_imported_xf_attachments/0/332_imagesdevpermissions.JPG?:"]imagesdevpermissions.JPG[/url][url="/_imported_xf_attachments/0/333_showmount.JPG?:"]showmount.JPG[/url][url="/_imported_xf_attachments/0/334_nasimagesdir.JPG?:"]nasimagesdir.JPG[/url][url="/_imported_xf_attachments/0/335_nfssettings.JPG?:"]nfssettings.JPG[/url]



  • [quote=“chad-bisd, post: 12562, member: 18”]In an earlier post in another thread, I had suggested mounting the nfs shares to /images and /images/dev, respectively, but we tried that and found you cannot export them from the fog server.

    Have you seen: [url]http://www.fogproject.org/forum/threads/how-to-setup-a-fog-storage-node-without-installing-fog.4294/#post-12035[/url][/quote]

    I’ve combed the forums and google for the solution. I’ve seen that thread but i’m not sure which part I need to be looking at to solve my problem. Do I need to create a new default share for my FOG images locally to mount to and then set up the mount point to the external NFS share?

    To confirm if i’m understanding I can create a new FOG share on the FOG server at /fogimages. I then follow the how to [url]http://www.fogproject.org/wiki/index.php/Change_NFS_location[/url] to change NFS location and then I can mount my NFS share at my new /fogimages location?


  • Moderator

    In an earlier post in another thread, I had suggested mounting the nfs shares to /images and /images/dev, respectively, but we tried that and found you cannot export them from the fog server.

    Have you seen: [url]http://www.fogproject.org/forum/threads/how-to-setup-a-fog-storage-node-without-installing-fog.4294/#post-12035[/url]



  • I looked at the system log in the FOG server and noticed these messages

    Jun 6 11:23:20 crfog rpc.mountd[1259]: authenticated mount request from 192.168.62.150:786 for /images/dev (/images/dev)
    Jun 6 11:23:20 crfog rpc.mountd[1259]: qword_eol: fflush failed: errno 22 (Invalid argument)
    Jun 6 11:23:20 crfog rpc.mountd[1259]: Cannot export /images/dev, possibly unsupported filesystem or fsid= required

    192.168.62.150 is the IP address of the client trying to upload the image


Log in to reply
 

375
Online

38982
Users

10712
Topics

101680
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.