Continually getting "Searching for server (DHCP)...No IP." message when trying to boot Fog Client



  • Hi All,

    I am new to using FOG. I have two Virtual machines that I am using with FOG. One is running Ubuntu 12.04 and I successfully installed FOG Server on this machine. The other Virtual machine is running Windows 7. I imported this virtual machine into VirtualBox because a colleague already installed the FOG client on that machine. Whenever I try to boot up the Windows 7 VM, I get the following error message: Searching for server (DHCP)…No IP.

    I am not sure how to resolve this issue. I said yes to the following question when performing the installation: Would you like to use the FOG Server for DHCP Service?

    So DHCP should be running.

    Does anyone have any ideas why I keep getting the “Searching for server (DHCP)…No IP.” message when trying to boot the Windows 7 VM with the FOG Client installed on it. Also, how can I resolve this issue?

    I searched the forums to see if I could find the answer but could not.

    Thanks.


  • Developer

    Awesome glad you fixed it :) Enjoy your FOG server ^^



  • Thanks for your help :D



  • Hi Jaymes,

    I used the following link to resolve this issue: [url]http://www.fogproject.org/wiki/index.php/Boot_looping_and_Chainloading[/url]


  • Developer

    Ugh I am out of ideas then mate :)

    When I used virtual box I never had issues with it booting to the hard drive, I find it really peculiar that it only does it after it loads the fog boot menu though.



  • Hi Jaymes,

    I am using VirtualBox and not VMWare. I will take a look at the link you provided. Thanks again.


  • Developer

    What are you using as a Virtual setup? Are you using VMWare or VirtualBox?

    VMWare works with SCSI drives, which fog doesn’t exactly like, if you are going to use VMWare you NEED to create a custom kernel with the VMWare drivers. This is really simple to do, shouldn’t take more than 10 minutes. I had to do this in order to work with VMWare and FOG.

    You can refer to this post here on how to build a custom kernel. [url]http://fogproject.org/forum/threads/request-for-kernel-compiling-info-please-read.4045/[/url] Look at the second post from Ozzy it is a beautifully written guide on creating your own kernel. Only use what you need, the more you add to the kernel the longer it takes to download and load.

    You may also want to take a look at the BIOS Settings and disable to ACPI and a few other settings, FOG doesn’t like some of them. But this seems odd as you didn’t download an image so the hard drive should boot normally, unless it can’t find the hard drive because of the hard drive type. I recommend trying a custom built kernel.



  • Hi Jaymes,

    Thanks again for the reply. I was able to get past the “[COLOR=#000000][FONT=Liberation Serif]loading pxelinux.0” issue – it was due to a dumb mistake. The problem is that the IP Address for “next-server” in /etc/dhcp/dhcpd.conf was incorrect on the FOG Server VM. I put in the correct value and restarted the FOG Server VM machine (lazy way of restarting the services). I then started the Windows 7 VM. I got the FOG screen up on the Windows 7 VM. It automatically chooses “Boot from Hard Disk” after a few seconds. However, now the Windows 7 VM just hangs on “Booting from local disk…” and it never boots up. [/FONT][/COLOR]

    What’s strange about this is that I can go into the boot order for my Windows 7 VM on Virtualbox and remove “network” so that this VM is no longer trying to PXE boot. Now, only “Hard Disk” remains in the boot order. I can then boot up the Windows 7 VM with no issue.

    The above paragraph makes me think that the issue is NOT with the Windows 7 VM. But I am not sure how FOG would be preventing the Windows 7 VM from booting up from the hard-disk.

    Any input would be appreciated.
    Thanks again.


  • Developer

    At this point, I would say it is getting stuck trying to load the pxelinux.0.

    You don’t have to follow all the directions in that post I gave you, you just have to follow the instructions for setting the next-server, but because you are internalizing the server and the virtual machine you shouldn’t really need to set much of anything because the DHCP server is the fog server :/

    Try running wireshark and capturing some packets to make sure all of the packet is getting to where it needs to be! Maybe they get lost after receiving the first part of the packet and not the rest, or maybe NONE of the packet is reaching the destination.

    I would also still recommend trying the proxyDHCP service. Since you are working with virtual machines, make a snapshot and try to the DNSMasq setup and see if that helps any. If not, you can revert to your previous snapshot without problems. Take a look here on how to set up proxydhcp service. [url]http://fogproject.org/wiki/index.php/Using_FOG_with_an_unmodifiable_DHCP_server/_Using_FOG_with_no_DHCP_server[/url]



  • Hi Jaymes,

    I am actually using the DHCP from the FOG Server. The first Adapter card on the Windows 7 VM and the FOG Server VM are setup so that the Windows 7 VM and the FOG Server VM can only see the internel network (which consists of the FOG Server VM and the Windows 7 VM). This prevents them from seeing the DHCP server on our network. So, I cannot follow the instructions you gave me in the following link: [url]http://fogproject.org/wiki/index.php/Modifying_existing_DHCP_server_to_work_with_FOG[/url]

    I ran the following command from the FOG Server VM: tftp -v X.X.X.X -c get pxelinux.0
    The results came back fine.

    I took the Windows 7 VM out of PXE boot and ran the following command:
    tftp x.x.x.x get pxelinux.0

    I got an error message saying: “tftp is not recognized as an internal or external command, operable program or batch file”

    When I have the Windows 7 VM PXE boot again, it still gets stuck on the following (I replaced all numbers with the letter x):
    [COLOR=#000000][FONT=Liberation Serif]MAC: xx::xx:xx:xx:xx:xx UUID: xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx[/FONT][/COLOR]
    [COLOR=#000000][FONT=Liberation Serif]Searching for server (DHCP)…[/FONT][/COLOR]
    [COLOR=#000000][FONT=Liberation Serif]Me: xxx.xxx.x.xx, DHCP: xxx.xxx.x.x, Gateway: xxx.xxx.x.x[/FONT][/COLOR]
    [COLOR=#000000][FONT=Liberation Serif]Loading xxx.xxx.x.x:pxelinux.0 _[/FONT][/COLOR]

    I am not sure why it is getting stuck on [COLOR=#000000][FONT=Liberation Serif]loading pxelinux.0 _[/FONT][/COLOR]

    Any ideas?

    Thanks.[COLOR=#000000][FONT=Liberation Serif][/FONT][/COLOR]


  • Developer

    1.) I’m glad you solved part of your problem!

    2.) To set up your next-server and file name refer to this link
    [url]http://fogproject.org/wiki/index.php/Modifying_existing_DHCP_server_to_work_with_FOG[/url]

    I would say yes, the reason it is now hanging is because it doesn’t actually know where to find the pxelinux.0 file.

    alternatively you can use a command to make sure that the tftp-hpa service is working correctly and you can pull the pxelinux.0 from the server by using the following commands.

    From your FOG server test out tftp
    tftp -v X.X.X.X -c get pxelinux.0

    From a Windows PC run at the cmd prompt:
    tftp x.x.x.x get pxelinux.0

    If tftp & xinetd are running your should get:
    Received XXXX bytes in X.X seconds…

    This will verify that the location is correct and the file can be grabbed, it is a good idea to run wireshark and look for the packets being sent and received, when I set mine up only part of the file go to where it needed to be and I had to enable the proxyDHCP stuff. these command help immensely.

    3.) The ip address of the Server is the only thing that matters when restarting the tftp service because the server is what the hosts are going to talk to and if tftp has not been assigned an IP address, it can’t be found! So when you reboot your server you can manually restart the service, or you can set it up so it will be automatically started after an IP address has been assigned, or after a certain amount of time,

    edit your /etc/rc.local and include
    /bin/sleep30 && /etc/init.d/tftpd-hpa restart

    this is what is required to delay the start up of the tftp service at boot.

    I found another resolve on an Ubuntu site but no one has confirmed if the process works or not, I will post it here if you want to give it a shot and tell me if it works, this should actually automate the tftp-hda and cause it to WAIT for an IP address to be assigned, which is a much better option, if it works…

    [COLOR=#0000ff]I am experiencing this problem in Ubuntu 12.04 Desktop (package: tftpd-5.2-1ubuntu1). The tftpd daemon does not start when the computer starts up, even though the tftpd-hpa job starts. As far as I can tell, the problem is that the tftpd service is starting before the network is properly configured. The problem seemed to go away when I changed the line[/COLOR]
    [COLOR=#0000ff]start on runlevel [2345][/COLOR]
    [COLOR=#0000ff]in /etc/init/tftpd-hpa.conf to[/COLOR]
    [COLOR=#0000ff]start on (local-filesystems and net-device-up IFACE!=lo)[/COLOR]



  • Hi Jaymes,

    Thanks for the reply. I was able to partially resolve my issue by modifying some values in[COLOR=#000000][FONT=Liberation Serif]etc/dhcp/dhcpd.conf on the Ubuntu 12.04 / FOG Server [FONT=Liberation Serif]VM. [/FONT][/FONT][/COLOR]

    Now, when I boot the Windows 7 VM, the following appears on the screen (I replaced all numbers with the letter x):
    [COLOR=#000000][FONT=Liberation Serif]MAC: xx::xx:xx:xx:xx:xx UUID: xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx[/FONT][/COLOR]
    [COLOR=#000000][FONT=Liberation Serif]Searching for server (DHCP)…[/FONT][/COLOR]
    [COLOR=#000000][FONT=Liberation Serif]Me: xxx.xxx.x.xx, DHCP: xxx.xxx.x.x, Gateway: xxx.xxx.x.x[/FONT][/COLOR]
    [COLOR=#000000][FONT=Liberation Serif]Loading xxx.xxx.x.x:pxelinux.0 _[/FONT][/COLOR]

    It is just hanging on “[COLOR=#000000][FONT=Liberation Serif]Loading xxx.xxx.x.x:pxelinux.0[FONT=Liberation Serif]”.[/FONT][/FONT][/COLOR]

    The answer to the following question is no: “Secondly, Did you set up your Next Server and your pxelinux.0 (<— note that is a ZERO not an O) options 066 & 067 respectively?”

    I am guessing that my not having setup my “Next Server” and “pxelinux.0” may be the cause of the Windows 7 VM now hanging. Do you have a link to any documentation that will tell me how to setup “Next Server” and “pxelinux.0”? That would be appreciated.

    You said “Any reboot of the server or restart of the server is going to require you to restart the tftp service after each successful boot. It will tell you the service is running (because it is) but the service started before the NIC actually had an IP address and needs to be restarted after an IP address has been issued”.

    a)
    If I understand this correctly, everytime I reboot the Ubuntu 12.04 / FOG Server, I will need to restart the TFTP service on that machine?

    b)
    Also, does it matter if I restart the TFTP service on the Ubuntu 12.04 / FOG VM before or after the IP Address has been assigned to the Windows 7 VM from the DHCP server on the Ubuntu 12.04 / FOG VM?

    Thanks again for your response.

    [COLOR=#000000][FONT=Liberation Serif][/FONT][/COLOR]

    [COLOR=#000000][FONT=Liberation Serif][/FONT][/COLOR]


  • Developer

    Do you have a DHCP server in your network? Why did you install the FOG DHCP service? It is generally a very bad idea to introduce more than one DHCP Server.

    You can use FOG as the DHCP Server, but if you already have one I suggest not using this service.

    ([B]IF YOU HAVE A DHCP SERVER[/B]) Try re-installing FOG without using the DHCP server. And then come back and tell us what the error is.

    [B]RECOMMENDATIONS[/B]

    I recommend a 10.04 Flavor of Ubuntu myself, because I HATE having to type in commands to get services to start again on boot like the later flavors of Ubuntu have, while this is NOT your main concern it could be in the future, so please keep this in mind. Any reboot of the server or restart of the server is going to require you to restart the tftp service after each successful boot. It will tell you the service is running (because it is) but the service started before the NIC actually had an IP address and needs to be restarted after an IP address has been issued.

    Secondly, Did you set up your Next Server and your pxelinux.0 (<— note that is a ZERO not an O) options 066 & 067 respectively?

    You can install FOG without using the DHCP service and if you STILL need a dhcp server you can install the DNSMasq service which works really nicely I use it in my buildings.



  • I don’t usually like to double-post but I just wanted to add some additional information:

    1. The full error message from when I try to start the Windows 7 VM is:
      [FONT=Liberation Serif]Searching for server (DHCP)…No IP. No IP. No IP. No IP. No IP. No IP.[/FONT]
      [FONT=Liberation Serif]No Server found[/FONT]

    I thought the above error message indicated that the DHCP server was not running on my Ubuntu 12.04 Server VM (which has the newest version of FOG installed on it). I logged into this VM and ran the following 2 commands:
    [COLOR=#ff0000][FONT=Liberation Serif]sudo service isc-dhcp-server start[/FONT][/COLOR][FONT=Liberation Serif] -[/FONT][COLOR=#ff0000][FONT=Liberation Serif]sudo service tftpd-hpa start[/FONT][/COLOR][FONT=Liberation Serif] -[FONT=Liberation Serif] I ran this command because I als[FONT=Liberation Serif]o found some articles on this forum where people [FONT=Liberation Serif]having trouble with [FONT=Liberation Serif]D[FONT=Liberation Serif]HCP ran this command as well.[/FONT][/FONT][/FONT][/FONT][/FONT][/FONT]
    [FONT=Liberation Serif]Both of these commands stated that those services were already running.[/FONT]

    I then ran the following commands:
    [COLOR=#ff0000][FONT=Liberation Serif]sudo service isc-dhcp-server restart[/FONT][/COLOR][FONT=Liberation Serif][/FONT][COLOR=#ff0000][FONT=Liberation Serif]sudo service tftpd-hpa restart[/FONT][/COLOR]

    After running those commands, I started the Windows 7 VM machine but I still got the same error message.

    Thanks in advanced for anyone who can give me some assistance.


Log in to reply
 

423
Online

39184
Users

10832
Topics

103133
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.