Wake on Lan WIndows 7



  • This makes no sense, but I promise that this is the pattern. I have had all of my computers scheduled to WOL daily at 7:00 AM. I have about 40 that we have upgraded to Windows 7. That is the only change. Once they are upgraded to Win7, they no longer Wake up. XP machines still wake up, but win 7 do not. I see no way that the OS could affect this, because the WOL is at the BIOS level. Any suggestions?



  • Thanks. We will work through this and come up with a solution!


  • Developer

    You may need a bios update, my windows 7 machines needed an update in order to turn on the functions for WOL with Windows 7.

    I know you probably don’t need all of this but give your settings a review, this is a walkthrough I set up for some of the things we use in our corporation, like PXE boot and WOL.

    [SIZE=3][FONT=Times New Roman]How to Enable Windows 7 WOL (Wake on Lan)[/FONT][/SIZE]
    [B][SIZE=3][FONT=Times New Roman]WINDOWS 7[/FONT][/SIZE][/B]
    [SIZE=3][FONT=Times New Roman]Right mouse click [U]My Computer[/U] and click on [U]Manage[/U], then [U]Device Manager[/U] in your left panel. Find [U]Network Adapters[/U] and expand it to reveal your Network Card, right mouse click your network card, and click [U]Properties[/U], then the [U]Advanced[/U] tab.[/FONT][/SIZE]

    [SIZE=3][FONT=Times New Roman]Energy Efficient Ethernet - Enabled[/FONT][/SIZE]
    [SIZE=3][FONT=Times New Roman]Shutdown Wake On Lan – Enabled[/FONT][/SIZE]
    [SIZE=3][FONT=Times New Roman]Wake on Magic Packet – Enabled[/FONT][/SIZE]
    [SIZE=3][FONT=Times New Roman]Wake on Pattern Match – Enabled[/FONT][/SIZE]
    [SIZE=3][FONT=Times New Roman]WOL & Shutdown Link Speed 100 MBPS (Only if you have problems getting the computer to receive the packets)[/FONT][/SIZE]

    [SIZE=3][FONT=Times New Roman]Now click on the [U]Power Management[/U] tab.[/FONT][/SIZE]
    [SIZE=3][FONT=Times New Roman]Check “Allow the computer to turn off this device to save power.”[/FONT][/SIZE]
    [SIZE=3][FONT=Times New Roman]Check “Allow this device to wake the computer.”[/FONT][/SIZE]
    [SIZE=3][FONT=Times New Roman]Not necessary but if problems persist, check “Only allow a magic packet to wake the computer.”[/FONT][/SIZE]

    [SIZE=3][FONT=Times New Roman]Boot into computer bios[/FONT][/SIZE]

    [B][SIZE=3][FONT=Times New Roman]BIOS[/FONT][/SIZE][/B]
    [SIZE=3][FONT=Times New Roman]Click the [U]Advanced[/U] tab[/FONT][/SIZE]
    [SIZE=3][FONT=Times New Roman]Choose [U]Integrated Peripherals[/U] and press enter. [/FONT][/SIZE]
    [SIZE=3][FONT=Times New Roman]Lan Rom Option – Enabled[/FONT][/SIZE]
    [SIZE=3][FONT=Times New Roman]Press Escape[/FONT][/SIZE]

    [SIZE=3][FONT=Times New Roman]Choose [U]Power Management[/U] and press enter. [/FONT][/SIZE]
    [SIZE=3][FONT=Times New Roman]EUP 2013 – Disabled[/FONT][/SIZE]
    [SIZE=3][FONT=Times New Roman]Power Loss – Last State[/FONT][/SIZE]
    [SIZE=3][FONT=Times New Roman]Press Escape[/FONT][/SIZE]

    [SIZE=3][FONT=Times New Roman]Choose [U]Wake Up Event Setup[/U] and press enter.[/FONT][/SIZE]
    [SIZE=3][FONT=Times New Roman]Wake up by – BIOS[/FONT][/SIZE]
    [SIZE=3][FONT=Times New Roman]Resume from S3 by PCI/PCI-E Device – Enabled[/FONT][/SIZE]
    [SIZE=3][FONT=Times New Roman]If you are STILL unable to get magic packets to wake computer, log back into Windows 7, go to [U]Control Panel,[/U] click [U]Programs[/U], click on [U]Add or Remove Windows Components[/U], place a check next to [U]Simple [/U][U]TCP[/U][U]/IP[/U] allow to install and reboot.[/FONT][/SIZE]



  • I had not seen that screen before! All boxes were checked, but I will work with various configurations over the next few days and see if any of those make a difference. Thanks



  • In windows 7 I found this option. It is listed when you configure the properties of the NIC.
    The only time we have gotten it to work in windows 7 is with the Magic packet box checked. However I have not tried the top box to turn off powersaving. This may be a fix also.


Log in to reply
 

390
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.